aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2020-02-07 08:01:23 -0800
committerTim Orling <ticotimo@gmail.com>2020-02-07 08:01:23 -0800
commitc0b9946f3b20b3a2ab286fa817c5c683c4a5824e (patch)
treecbc263d3c797f15da0b6024149f7d03c009054e9
parent17fadcce789cdb1eddfa28e9fc318c9f9de5b5ba (diff)
downloadmeta-python2-c0b9946f3b20b3a2ab286fa817c5c683c4a5824e.tar.gz
python-twisted: add required RDEPENDS for twistd
From: Trevor Gamblin <trevor.gamblin@windriver.com> python-twisted is currently missing some packages for its /usr/bin/twistd executable to function. Add these to the RDEPENDS list, and also clean up formatting since the list is getting long. Note that a similar patch has already been submitted for master branch, but the python2 version of twisted needs more explicit RDEPENDS than the python3 version submitted to master in order for /usr/bin/twistd to work properly. Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-twisted_19.10.0.bb18
1 files changed, 17 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-twisted_19.10.0.bb b/recipes-devtools/python/python-twisted_19.10.0.bb
index 4e07d52..51a495a 100644
--- a/recipes-devtools/python/python-twisted_19.10.0.bb
+++ b/recipes-devtools/python/python-twisted_19.10.0.bb
@@ -63,7 +63,23 @@ RDEPENDS_${PN} = "\
${PN}-zsh \
"
-RDEPENDS_${PN}-core = "${PYTHON_PN}-core ${PYTHON_PN}-zopeinterface ${PYTHON_PN}-incremental ${PYTHON_PN}-constantly ${PYTHON_PN}-hyperlink ${PYTHON_PN}-automat ${PYTHON_PN}-pyserial"
+RDEPENDS_${PN}-core = "${PYTHON_PN}-automat \
+ ${PYTHON_PN}-constantly \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-debugger \
+ ${PYTHON_PN}-hyperlink \
+ ${PYTHON_PN}-incremental \
+ ${PYTHON_PN}-misc \
+ ${PYTHON_PN}-pkg-resources \
+ ${PYTHON_PN}-pkgutil \
+ ${PYTHON_PN}-plistlib \
+ ${PYTHON_PN}-pyhamcrest \
+ ${PYTHON_PN}-pyserial \
+ ${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-unixadmin \
+ ${PYTHON_PN}-zopeinterface \
+"
+
RDEPENDS_${PN}-test = "${PN}"
RDEPENDS_${PN}-conch = "${PN}-core ${PN}-protocols ${PYTHON_PN}-bcrypt ${PYTHON_PN}-cryptography ${PYTHON_PN}-pyasn1 ${PYTHON_PN}-pickle"
RDEPENDS_${PN}-mail = "${PN}-core ${PN}-protocols"