aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-30 18:10:25 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 18:08:12 -0800
commitf3505a453fa61faa01ff29293892315d9e1428a1 (patch)
treeddd65e71ce719a171241ea4c052cd6b6c62a12f9
parenta54c8165dbf75e8db0aa130668c90e5401d47354 (diff)
downloadmeta-python2-f3505a453fa61faa01ff29293892315d9e1428a1.tar.gz
python-pytest: upgrade from 3.4.2 => 4.6.6
The last version to support python 2.7 was 4.6.x * Refresh patch. * Add python-logging dependency. * Sort RDEPENDS. Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-pytest/0001-setup.py-remove-setup_requires-for-setuptools-scm.patch31
-rw-r--r--recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch32
-rw-r--r--recipes-devtools/python/python-pytest_4.6.6.bb (renamed from recipes-devtools/python/python-pytest_3.4.2.bb)31
3 files changed, 48 insertions, 46 deletions
diff --git a/recipes-devtools/python/python-pytest/0001-setup.py-remove-setup_requires-for-setuptools-scm.patch b/recipes-devtools/python/python-pytest/0001-setup.py-remove-setup_requires-for-setuptools-scm.patch
new file mode 100644
index 0000000..53e7dea
--- /dev/null
+++ b/recipes-devtools/python/python-pytest/0001-setup.py-remove-setup_requires-for-setuptools-scm.patch
@@ -0,0 +1,31 @@
+From fd66df54245e9e67f4d9e96337658ddc707f5ad0 Mon Sep 17 00:00:00 2001
+From: Tim Orling <ticotimo@gmail.com>
+Date: Sat, 30 Nov 2019 18:39:15 -0800
+Subject: [PATCH] setup.py: remove setup_requires for setuptools-scm
+
+The setup_requires argument forces the download of the egg file for setuptools-scm
+during the do_compile phase. This download is incompatible with the typical fetch
+and mirror structure. The only usage of scm is the generation of the _version.py
+file and in the release tarball it is already correctly created
+
+Upstream-Status: Inappropriate [oe specific]
+
+Signed-off-by: Derek Straka <derek@asterius.io>
+Signed-off-by: Tim Orling <ticotimo@gmail.com>
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 491a6f5..c6af9e2 100644
+--- a/setup.py
++++ b/setup.py
+@@ -23,7 +23,7 @@ INSTALL_REQUIRES = [
+ def main():
+ setup(
+ use_scm_version={"write_to": "src/_pytest/_version.py"},
+- setup_requires=["setuptools-scm", "setuptools>=40.0"],
++ setup_requires=["setuptools>=40.0"],
+ package_dir={"": "src"},
+ # fmt: off
+ extras_require={
diff --git a/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch b/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
deleted file mode 100644
index 06dfcdf..0000000
--- a/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 24a901fd17926e8e05be4ed2e01b0113a2e3a852 Mon Sep 17 00:00:00 2001
-From: Derek Straka <derek@asterius.io>
-Date: Tue, 19 Dec 2017 11:36:39 -0500
-Subject: [PATCH] [PATCH 1/1] setup.py: remove the setup_requires for
- setuptools-scm
-
-The setup_requires argument forces the download of the egg file for setuptools-scm
-during the do_compile phase. This download is incompatible with the typical fetch
-and mirror structure. The only usage of scm is the generation of the _version.py
-file and in the release tarball it is already correctly created
-
-Upstream-Status: Inappropriate [oe specific]
-
-Signed-off-by: Derek Straka <derek@asterius.io>
----
- setup.py | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index 3eb38ef..1163202 100644
---- a/setup.py
-+++ b/setup.py
-@@ -82,7 +82,6 @@ def main():
- keywords="test unittest",
- cmdclass={'test': PyTest},
- # the following should be enabled for release
-- setup_requires=['setuptools-scm'],
- python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
- install_requires=install_requires,
- extras_require=extras_require,
---
-2.7.4
diff --git a/recipes-devtools/python/python-pytest_3.4.2.bb b/recipes-devtools/python/python-pytest_4.6.6.bb
index 63644a4..a9b6492 100644
--- a/recipes-devtools/python/python-pytest_3.4.2.bb
+++ b/recipes-devtools/python/python-pytest_4.6.6.bb
@@ -3,29 +3,37 @@ HOMEPAGE = "http://pytest.org"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=640061b8cee64b308a4d2f9f556c12f2"
-SRC_URI[md5sum] = "889344299c9182aff67d6e461cb7af29"
-SRC_URI[sha256sum] = "27abc3fef618a01bebb1f0d6d303d2816a99aa87a5968ebc32fe971be91eb1e6"
+SRC_URI += " file://0001-setup.py-remove-setup_requires-for-setuptools-scm.patch"
+
+SRC_URI[md5sum] = "0cf02e80d916a81a3d4fa425eb8063c5"
+SRC_URI[sha256sum] = "692d9351353ef709c1126266579edd4fd469dcf6b5f4f583050f72161d6f3592"
-SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch \
- "
inherit update-alternatives pypi setuptools
RDEPENDS_${PN}_class-target += " \
+ ${PYTHON_PN}-argparse \
+ ${PYTHON_PN}-atomicwrites \
${PYTHON_PN}-attrs \
+ ${PYTHON_PN}-compiler \
${PYTHON_PN}-debugger \
${PYTHON_PN}-doctest \
+ ${PYTHON_PN}-funcsigs \
+ ${PYTHON_PN}-importlib-metadata \
${PYTHON_PN}-json \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-more-itertools \
+ ${PYTHON_PN}-packaging \
+ ${PYTHON_PN}-pathlib2 \
${PYTHON_PN}-pluggy \
${PYTHON_PN}-py \
${PYTHON_PN}-setuptools \
${PYTHON_PN}-six \
- ${PYTHON_PN}-atomicwrites \
- ${PYTHON_PN}-importlib-metadata \
- ${PYTHON_PN}-pathlib2 \
${PYTHON_PN}-wcwidth \
- ${PYTHON_PN}-more-itertools \
- ${PYTHON_PN}-packaging \
+"
+
+RDEPENDS_${PN}-ptest += "\
+ ${PYTHON_PN}-hypothesis \
"
FILESEXTRAPATHS_prepend := "${THISDIR}/python-pytest:"
@@ -38,11 +46,6 @@ ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest"
ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test"
ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test"
-RDEPENDS_${PN}_class-target += " \
- ${PYTHON_PN}-argparse \
- ${PYTHON_PN}-compiler \
- ${PYTHON_PN}-funcsigs \
-"
ALTERNATIVE_PRIORITY = "10"
BBCLASSEXTEND = "native nativesdk"