aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-01-30 17:05:22 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2021-01-31 10:49:27 +0100
commite2ea8e3e344c8eec889f625452a8b46ec3b48a30 (patch)
tree6b1e9008f1672e01e2b9dcadb382e599899dbb83
parentc43c29e57f16af4e77441b201855321fbd546661 (diff)
downloadmeta-python2-e2ea8e3e344c8eec889f625452a8b46ec3b48a30.tar.gz
python-setuptools: simplify RDEPENDS setting
* python2 version from meta-python2 caused parsing error now, which unfortunately left bitbake stuck after: ERROR: meta-python2/recipes-devtools/python/python-setuptools_42.0.2.bb: QA Issue: meta-python2/recipes-devtools/python/python-setuptools_42.0.2.bb: Variable RPROVIDES is set as not being package specific, please fix this. [pkgvarcheck] ERROR: meta-python2/recipes-devtools/python/python-setuptools_42.0.2.bb: Fatal QA errors found, failing task. ERROR: Failed to parse recipe: meta-python2/recipes-devtools/python/python-setuptools_42.0.2.bb Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-devtools/python/python-setuptools.inc6
1 files changed, 1 insertions, 5 deletions
diff --git a/recipes-devtools/python/python-setuptools.inc b/recipes-devtools/python/python-setuptools.inc
index d8bce71..5f427fd 100644
--- a/recipes-devtools/python/python-setuptools.inc
+++ b/recipes-devtools/python/python-setuptools.inc
@@ -24,6 +24,7 @@ RDEPENDS_${PN} = "\
${PYTHON_PN}-html \
${PYTHON_PN}-netserver \
${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-pkg-resources \
${PYTHON_PN}-pkgutil \
${PYTHON_PN}-plistlib \
${PYTHON_PN}-shell \
@@ -43,8 +44,3 @@ BBCLASSEXTEND = "native nativesdk"
# minimal distributions.
PACKAGES =+ "${PYTHON_PN}-pkg-resources "
FILES_${PYTHON_PN}-pkg-resources = "${PYTHON_SITEPACKAGES_DIR}/pkg_resources/*"
-# Due to the way OE-Core implemented native recipes, the native class cannot
-# have a dependency on something that is not a recipe name. Work around that by
-# manually setting RPROVIDES.
-RDEPENDS_${PN}_append = " ${PYTHON_PN}-pkg-resources"
-RPROVIDES_append_class-native = " ${PYTHON_PN}-pkg-resources-native"