aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBinghua Guan <freebendy@gmail.com>2018-07-25 21:29:15 +0800
committerKhem Raj <raj.khem@gmail.com>2018-07-27 07:19:14 -0700
commit10620e2faf65628329c4874a899fc72ff8c9b4d7 (patch)
tree95ac10433f492deb40a2df9b49e9ab7ff37e1a2b
parent498628e41cb81011e38af9fb99e919bb497b74dd (diff)
downloadmeta-python2-10620e2faf65628329c4874a899fc72ff8c9b4d7.tar.gz
meta-python: add python-crcmod recipe
(From meta-openembedded commit: 0049076c41d547a90bfdfe826038d6ce6c23bd36) Signed-off-by: Binghua Guan <freebendy@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-crcmod.inc14
-rw-r--r--recipes-devtools/python/python-crcmod_1.7.bb2
2 files changed, 16 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-crcmod.inc b/recipes-devtools/python/python-crcmod.inc
new file mode 100644
index 0000000..85da7cb
--- /dev/null
+++ b/recipes-devtools/python/python-crcmod.inc
@@ -0,0 +1,14 @@
+SUMMARY = "A Python module for generating objects that compute the Cyclic Redundancy Check."
+HOMEPAGE = "https://pypi.org/project/crcmod"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a19291627cad2d1dfbfcf3c9fb85c2"
+
+SRC_URI[md5sum] = "2d5b92117d958dcead94f9e17f54cd32"
+SRC_URI[sha256sum] = "dc7051a0db5f2bd48665a990d3ec1cc305a466a77358ca4492826f41f283601e"
+
+inherit pypi
+
+RDEPENDS_${PN} += "${PYTHON_PN}-unittest"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-devtools/python/python-crcmod_1.7.bb b/recipes-devtools/python/python-crcmod_1.7.bb
new file mode 100644
index 0000000..45b9a2c
--- /dev/null
+++ b/recipes-devtools/python/python-crcmod_1.7.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-crcmod.inc