aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2015-03-27 23:21:02 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-04-13 12:55:49 +0200
commite9c2607c6f6181ed632086b9e5598a5dd4fc6dd3 (patch)
treeb57d81bf6d02de8d631e39420ee127b9c0628ad4
parentade2ece90336f3ad2922c7a4b16888572f6b300a (diff)
downloadmeta-python2-e9c2607c6f6181ed632086b9e5598a5dd4fc6dd3.tar.gz
python-pyopenssl: Downgrade to 0.13
Version 0.14 depends python-cryptography, which is currently unavailable in meta-openembedded. (From meta-openembedded commit: 6a0641398d4b161253afe9bfd744ce0fd5950bc6) Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-pyopenssl-0.13/x509_revoked_dup.patch19
-rw-r--r--recipes-devtools/python/python-pyopenssl_0.13.bb (renamed from recipes-devtools/python/python-pyopenssl_0.14.bb)11
2 files changed, 25 insertions, 5 deletions
diff --git a/recipes-devtools/python/python-pyopenssl-0.13/x509_revoked_dup.patch b/recipes-devtools/python/python-pyopenssl-0.13/x509_revoked_dup.patch
new file mode 100644
index 0000000..c386e9c
--- /dev/null
+++ b/recipes-devtools/python/python-pyopenssl-0.13/x509_revoked_dup.patch
@@ -0,0 +1,19 @@
+diff -Naur pyOpenSSL-0.13.orig/OpenSSL/crypto/crl.c pyOpenSSL-0.13/OpenSSL/crypto/crl.c
+--- pyOpenSSL-0.13.orig/OpenSSL/crypto/crl.c 2011-09-02 17:46:13.000000000 +0200
++++ pyOpenSSL-0.13/OpenSSL/crypto/crl.c 2015-03-26 20:53:08.984999223 +0100
+@@ -3,6 +3,7 @@
+ #include "crypto.h"
+
+
++#if 0
+ static X509_REVOKED * X509_REVOKED_dup(X509_REVOKED *orig) {
+ X509_REVOKED *dupe = NULL;
+
+@@ -32,6 +33,7 @@
+ dupe->sequence = orig->sequence;
+ return dupe;
+ }
++#endif
+
+ static char crypto_CRL_get_revoked_doc[] = "\n\
+ Return revoked portion of the CRL structure (by value\n\
diff --git a/recipes-devtools/python/python-pyopenssl_0.14.bb b/recipes-devtools/python/python-pyopenssl_0.13.bb
index 1f609e3..cf9d73e 100644
--- a/recipes-devtools/python/python-pyopenssl_0.14.bb
+++ b/recipes-devtools/python/python-pyopenssl_0.13.bb
@@ -7,15 +7,16 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
SRCNAME = "pyOpenSSL"
DEPENDS = "openssl"
+PE = "1"
-SRC_URI = "http://pypi.python.org/packages/source/p/pyOpenSSL/pyOpenSSL-${PV}.tar.gz"
-
-SRC_URI[md5sum] = "8579ff3a1d858858acfba5f046a4ddf7"
-SRC_URI[sha256sum] = "a99db8e59c120138ad8a72eecedcc24b4510d2eed3ce48213b7e32f22cc4ee6e"
+SRC_URI = "http://pypi.python.org/packages/source/p/pyOpenSSL/pyOpenSSL-${PV}.tar.gz \
+ file://x509_revoked_dup.patch"
+SRC_URI[md5sum] = "767bca18a71178ca353dff9e10941929"
+SRC_URI[sha256sum] = "21e12b03abaa0e04ecc8cd9c251598f71bae11c9f385304234e4ea5618c6163b"
S = "${WORKDIR}/${SRCNAME}-${PV}"
-inherit setuptools
+inherit distutils
PACKAGES =+ "${PN}-tests"
FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"