aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@minotaurinc.com>2014-11-10 18:19:08 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2014-11-24 11:59:48 +0100
commite9331864806f1812801c16bb9ec139b689058fb1 (patch)
tree68421ef0db3c5511841e31e740265f2ef66854c1
parent44ecb3f307ff2b2328331cb87d295864a133b5b9 (diff)
downloadmeta-python2-e9331864806f1812801c16bb9ec139b689058fb1.tar.gz
python-flufl-enum: add recipe for 4.0.1
(From meta-openembedded commit: 5f6760e59a2df208dddb04e8e45b10a15aa99d2c) Signed-off-by: Derek Straka <derek@minotaurinc.com> Acked-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-flufl-enum_4.0.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-flufl-enum_4.0.1.bb b/recipes-devtools/python/python-flufl-enum_4.0.1.bb
new file mode 100644
index 0000000..a7376db
--- /dev/null
+++ b/recipes-devtools/python/python-flufl-enum_4.0.1.bb
@@ -0,0 +1,33 @@
+SUMMARY = "A Python enumeration package."
+DESCRIPTION = "The flufl.enum library is a Python enumeration package. Its goal is to provide simple, \
+specific, concise semantics in an easy to read and write syntax. flufl.enum has just enough of the \
+features needed to make enumerations useful, but without a lot of extra baggage to weigh them down. "
+HOMEPAGE = "https://pypi.python.org/pypi/flufl.enum"
+SECTION = "devel/python"
+
+LICENSE = "LGPLv3"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=1fa25baed15d3be23c902636379438e8"
+
+SRCNAME = "flufl.enum"
+
+SRC_URI = " \
+ http://pypi.python.org/packages/source/f/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+"
+
+SRC_URI[md5sum] = "b3ad23761a78232bc78499ced7cb85d9"
+SRC_URI[sha256sum] = "4af7e7cf2dcc7517251570c7ef9ad194e30ee4b6f860eba500c03954ae95f9d8"
+
+inherit setuptools
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+PACKAGES =+ "\
+ ${PN}-test \
+"
+
+FILES_${PN}-doc += "\
+ ${libdir}/${PYTHON_DIR}/site-packages/flufl/enum/*.rst \
+ ${libdir}/${PYTHON_DIR}/site-packages/flufl/enum/docs \
+"
+
+FILES_${PN}-test += "${libdir}/${PYTHON_DIR}/site-packages/flufl/enum/tests"