aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2015-03-27 23:21:01 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-04-13 12:55:49 +0200
commitade2ece90336f3ad2922c7a4b16888572f6b300a (patch)
treef42ab322610ccae22f4c384e66bbc44817eb01a5
parent2ad3616ba8198d5b69898440bda27c7a91c581e4 (diff)
downloadmeta-python2-ade2ece90336f3ad2922c7a4b16888572f6b300a.tar.gz
python-pyopenssl: move to meta-python
(From meta-openembedded commit: c9e06339057d8999bd0e056e679368c1a2fab013) Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-pyopenssl_0.14.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pyopenssl_0.14.bb b/recipes-devtools/python/python-pyopenssl_0.14.bb
new file mode 100644
index 0000000..1f609e3
--- /dev/null
+++ b/recipes-devtools/python/python-pyopenssl_0.14.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Simple Python wrapper around the OpenSSL library"
+SECTION = "devel/python"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRCNAME = "pyOpenSSL"
+
+DEPENDS = "openssl"
+
+SRC_URI = "http://pypi.python.org/packages/source/p/pyOpenSSL/pyOpenSSL-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "8579ff3a1d858858acfba5f046a4ddf7"
+SRC_URI[sha256sum] = "a99db8e59c120138ad8a72eecedcc24b4510d2eed3ce48213b7e32f22cc4ee6e"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+PACKAGES =+ "${PN}-tests"
+FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
+
+RDEPENDS_${PN} = "python-threading"
+RDEPENDS_${PN}-tests = "${PN}"