aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@minotaurinc.com>2014-11-14 11:21:16 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2014-11-24 11:59:49 +0100
commita1c3a244b53801e04cf0ecc15d10012eb0ec1147 (patch)
tree1ff7222a7f0e76bc222743af00c4e7159488afa0
parenta50f66b6a463abaf50f8bb690751291e9a7b6863 (diff)
downloadmeta-python2-a1c3a244b53801e04cf0ecc15d10012eb0ec1147.tar.gz
python-ujson: add recipe for 1.33
(From meta-openembedded commit: 0ceb0cea6bc71f1089b97eca7bec656f50be0b86) Signed-off-by: Derek Straka <derek@minotaurinc.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-ujson_1.33.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-ujson_1.33.bb b/recipes-devtools/python/python-ujson_1.33.bb
new file mode 100644
index 0000000..8fdd2b8
--- /dev/null
+++ b/recipes-devtools/python/python-ujson_1.33.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Ultra fast JSON encoder and decoder for Python"
+DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3."
+HOMEPAGE = "https://pypi.python.org/pypi/ujson"
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=5b206f6ba5e41c60df8cdcddf79a3d82"
+
+SRCNAME = "ujson"
+
+SRC_URI = " \
+ http://pypi.python.org/packages/source/u/ujson/${SRCNAME}-${PV}.zip \
+"
+
+SRC_URI[md5sum] = "8148a2493fff78940feab1e11dc0a893"
+SRC_URI[sha256sum] = "68cf825f227c82e1ac61e423cfcad923ff734c27b5bdd7174495d162c42c602b"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} += "python-numbers"