aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Shelton <ben.shelton@ni.com>2015-02-18 17:03:42 -0600
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-27 09:35:51 +0100
commit91bbe738b848ddf3161dbf6736294c6ca5e20de3 (patch)
treefa0ec01c716aa901e5af643fadb8a9f0a7bf10b5
parent5034ff2d7ece23551f91a8acd912507318274b51 (diff)
downloadmeta-python2-91bbe738b848ddf3161dbf6736294c6ca5e20de3.tar.gz
python-requests: add recipe
Requests is an HTTP library for Python with a clean and succinct API. Copied from commit bc572006bfcec10523658b8675f30bf45b43a998 in meta-cloud-services/meta-openstack and updated to version 2.5.1. (From meta-openembedded commit: da6ca531874356077977e9bfed661629a95eb16d) Signed-off-by: Ben Shelton <ben.shelton@ni.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-requests_2.5.1.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-requests_2.5.1.bb b/recipes-devtools/python/python-requests_2.5.1.bb
new file mode 100644
index 0000000..b719dca
--- /dev/null
+++ b/recipes-devtools/python/python-requests_2.5.1.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Python HTTP for Humans."
+HOMEPAGE = "http://python-requests.org"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c7869e52c8275537186de35e3cd5f9ec"
+
+PR = "r0"
+SRCNAME = "requests"
+
+SRC_URI = "http://pypi.python.org/packages/source/r/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "c270eb5551a02e8ab7a4cbb83e22af2e"
+SRC_URI[sha256sum] = "7b7735efd3b1e2323dc9fcef060b380d05f5f18bd0f247f5e9e74a628279de66"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools