aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@minotaurinc.com>2014-11-14 11:04:44 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2014-11-24 11:59:49 +0100
commit504eb80ff75e0c9c11da85ba5171051f280928db (patch)
treefc1803a27a3430291e698fa43d7e3db7c2149c08
parent9fa19e831873f1cf121a7d9ad64eecbf33195afb (diff)
downloadmeta-python2-504eb80ff75e0c9c11da85ba5171051f280928db.tar.gz
python-certifi: add recipe for 14.05.14
(From meta-openembedded commit: cebb6af29ed1613df69ac8a3f78e0b88fb75ac3f) Signed-off-by: Derek Straka <derek@minotaurinc.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-certifi_14.05.14.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-certifi_14.05.14.bb b/recipes-devtools/python/python-certifi_14.05.14.bb
new file mode 100644
index 0000000..5e0404e
--- /dev/null
+++ b/recipes-devtools/python/python-certifi_14.05.14.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Python package for providing Mozilla's CA Bundle."
+DESCRIPTION = "This installable Python package contains a CA Bundle that you can reference in your \
+Python code. This is useful for verifying HTTP requests, for example. This is the same CA Bundle \
+which ships with the Requests codebase, and is derived from Mozilla Firefox's canonical set."
+HOMEPAGE = "https://pypi.python.org/pypi/certifi"
+SECTION = "devel/python"
+
+LICENSE = "ISC"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f77f61d14ee6feac4228d3ebd26cc1f1"
+
+SRCNAME = "certifi"
+
+SRC_URI = "https://pypi.python.org/packages/source/c/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "315ea4e50673a16ab047099f816fd32a"
+SRC_URI[sha256sum] = "1e1bcbacd6357c151ae37cf0290dcc809721d32ce21fd6b7339568f3ddef1b69"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools