aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Shelton <ben.shelton@ni.com>2015-02-18 17:03:41 -0600
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-27 09:35:51 +0100
commit5034ff2d7ece23551f91a8acd912507318274b51 (patch)
tree3105d10c699e913c420725509c6edada6eaa4c3d
parent3e251fbdea48cf0078764c9e1bc92698c59a2072 (diff)
downloadmeta-python2-5034ff2d7ece23551f91a8acd912507318274b51.tar.gz
python-msgpack: add recipe
python-msgpack implements the MessagePack binary serialization format for Python. Copied from commit 91ed2353847d4121e3dd8ad10ca0c24194ac9765 in meta-cloud-services/meta-openstack and updated to version 0.4.5. (From meta-openembedded commit: 8b0a43983c65a2f453d82f909a1860f5770e5041) Signed-off-by: Ben Shelton <ben.shelton@ni.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-msgpack_0.4.5.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-msgpack_0.4.5.bb b/recipes-devtools/python/python-msgpack_0.4.5.bb
new file mode 100644
index 0000000..206b03d
--- /dev/null
+++ b/recipes-devtools/python/python-msgpack_0.4.5.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "MessagePack (de)serializer"
+HOMEPAGE = "https://pypi.python.org/pypi/msgpack-python/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=cd9523181d9d4fbf7ffca52eaa2a5751"
+
+PR = "r0"
+SRCNAME = "msgpack-python"
+
+SRC_URI = "https://pypi.python.org/packages/source/m/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "3b82bc542d5599896695512e7c32f42d"
+SRC_URI[sha256sum] = "a07cd6615a6bf38cfa2f010b121c7e77b74a3e7b971ef3e475c3d33308014cbb"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools