aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiLo <milo-software@users.sourceforge.net>2015-01-27 19:08:36 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-12 19:31:53 +0100
commit452adfce1ede4f95fdd5da088e1486a0a0e4444f (patch)
tree71db47ffbf3803e94d8f62d917776d7c9fdfb0a7
parent4f8ec26348a71632f5cc8d837b9a331e9a583adf (diff)
downloadmeta-python2-452adfce1ede4f95fdd5da088e1486a0a0e4444f.tar.gz
python-twisted: Fix dependencies of twisted modules
When installing just "twisted-web" on a device, none of the dependencies are being copied, it wouldn't even install python-core. Fix the recipe so that its packages have proper dependencies, and no longer require to install the empty python-twisted meta recipe. Add "python-contextlib" to the core dependencies and stop causing systems to crash with: File "/usr/lib/python2.7/site-packages/twisted/python/threadpool.py", line 18, in <module> ImportError: No module named contextlib (From meta-openembedded commit: 10a483537723255549ec9030d619e0e3f60772ac) Signed-off-by: Mike Looijmans <milo-software@users.sourceforge.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-twisted_13.2.0.bb17
1 files changed, 15 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-twisted_13.2.0.bb b/recipes-devtools/python/python-twisted_13.2.0.bb
index 80d64a0..8930169 100644
--- a/recipes-devtools/python/python-twisted_13.2.0.bb
+++ b/recipes-devtools/python/python-twisted_13.2.0.bb
@@ -38,8 +38,7 @@ PACKAGES += "\
${PN}-core \
"
-RDEPENDS_${PN} = "python-core python-zopeinterface"
-RDEPENDS_${PN} += "\
+RDEPENDS_${PN} = "\
${PN}-conch \
${PN}-lore \
${PN}-mail \
@@ -50,6 +49,20 @@ RDEPENDS_${PN} += "\
${PN}-words \
"
+RDEPENDS_${PN}-core = "python-core python-zopeinterface python-contextlib"
+RDEPENDS_${PN}-test = "${PN}"
+RDEPENDS_${PN}-conch = "${PN}-core ${PN}-protocols"
+RDEPENDS_${PN}-lore = "${PN}-core"
+RDEPENDS_${PN}-mail = "${PN}-core ${PN}-protocols"
+RDEPENDS_${PN}-names = "${PN}-core"
+RDEPENDS_${PN}-news = "${PN}-core ${PN}-protocols"
+RDEPENDS_${PN}-runner = "${PN}-core ${PN}-protocols"
+RDEPENDS_${PN}-web += "${PN}-core ${PN}-protocols"
+RDEPENDS_${PN}-words += "${PN}-core"
+RDEPENDS_${PN}-flow += "${PN}-core"
+RDEPENDS_${PN}-pair += "${PN}-core"
+RDEPENDS_${PN}-dbg = "${PN}"
+
ALLOW_EMPTY_${PN} = "1"
FILES_${PN} = ""