aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2015-02-10 14:55:10 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-12 19:35:40 +0100
commitc5ab672d132e73b22196322fbb66b34b1e95857a (patch)
tree3db590266c7ea138bf92aa25e05f3f1ee0ac54f2
parent1da403433d104b18b2577cbb1ac239bbbcf88eac (diff)
downloadmeta-python2-c5ab672d132e73b22196322fbb66b34b1e95857a.tar.gz
python-pip: add python-distribute in RDEPENDS
Fix the following runtime issue of pip: # pip Traceback (most recent call last): File "/usr/bin/pip", line 5, in <module> from pkg_resources import load_entry_point ImportError: No module named pkg_resources (From meta-openembedded commit: 618c70da1e9b7062196dfaf7be28e63402b81d9d) Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-pip_1.5.6.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-pip_1.5.6.bb b/recipes-devtools/python/python-pip_1.5.6.bb
index 0c240e4..b4ce9e5 100644
--- a/recipes-devtools/python/python-pip_1.5.6.bb
+++ b/recipes-devtools/python/python-pip_1.5.6.bb
@@ -12,4 +12,4 @@ S = "${WORKDIR}/pip-${PV}"
inherit setuptools
# Since PIP is like CPAN for PERL we need to drag in all python modules to ensure everything works
-RDEPENDS_${PN} = "python-modules"
+RDEPENDS_${PN} = "python-modules python-distribute"