aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiLo <milo-software@users.sourceforge.net>2015-01-27 19:34:53 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-12 19:31:53 +0100
commitb0a3d37b1c704b130b5aa5ed47ba1fd37e8d5890 (patch)
treecd56d867d2fd147de0b0108c02578d0eaf74a464
parent452adfce1ede4f95fdd5da088e1486a0a0e4444f (diff)
downloadmeta-python2-b0a3d37b1c704b130b5aa5ed47ba1fd37e8d5890.tar.gz
python-twisted: Create a separate source code package and bin package
Python-twisted installs about 1MB of ".py" files that are not actually being used for anything. To save on flash space on devices, move the source code into its own package. This modification has been in use for several years in the OpenPLi project, which heavily leans on twisted for the GUI and web interfaces, and did not cause any problems. Move the /usr/bin/ scripts into their own package as well. Installing python-twisted will still install these scripts. (From meta-openembedded commit: 60e962d5c440f00a517df0627ec8232bc77c7425) Signed-off-by: Mike Looijmans <milo-software@users.sourceforge.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-twisted_13.2.0.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-twisted_13.2.0.bb b/recipes-devtools/python/python-twisted_13.2.0.bb
index 8930169..2b433f7 100644
--- a/recipes-devtools/python/python-twisted_13.2.0.bb
+++ b/recipes-devtools/python/python-twisted_13.2.0.bb
@@ -38,7 +38,13 @@ PACKAGES += "\
${PN}-core \
"
+PACKAGES =+ "\
+ ${PN}-src \
+ ${PN}-bin \
+"
+
RDEPENDS_${PN} = "\
+ ${PN}-bin \
${PN}-conch \
${PN}-lore \
${PN}-mail \
@@ -233,3 +239,9 @@ ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/.debug \
${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/.debug \
"
+RDEPENDS_{PN}-src = "${PN}"
+FILES_${PN}-src = " \
+ ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py \
+ ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*.py \
+ ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/*.py \
+ "