aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@minotaurinc.com>2014-11-14 11:04:45 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2014-11-24 11:59:49 +0100
commita50f66b6a463abaf50f8bb690751291e9a7b6863 (patch)
tree0438b26475c2199d950ecd54b6867fc97a90ff23
parent504eb80ff75e0c9c11da85ba5171051f280928db (diff)
downloadmeta-python2-a50f66b6a463abaf50f8bb690751291e9a7b6863.tar.gz
python-tornado: add recipe for 4.0.2
(From meta-openembedded commit: 6f82155058e9ce1b4d11cedc0051ebcfaadeadf5) Signed-off-by: Derek Straka <derek@minotaurinc.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-tornado_4.0.2.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-tornado_4.0.2.bb b/recipes-devtools/python/python-tornado_4.0.2.bb
new file mode 100644
index 0000000..f1b8141
--- /dev/null
+++ b/recipes-devtools/python/python-tornado_4.0.2.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed."
+DESCRIPTION = "Tornado is a Python web framework and asynchronous networking library, originally developed at FriendFeed. \
+By using non-blocking network I/O, Tornado can scale to tens of thousands of open connections, making it ideal for long \
+polling, WebSockets, and other applications that require a long-lived connection to each user."
+HOMEPAGE = "http://www.tornadoweb.org/en/stable/"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=5208df23820f490f691712a654be256d"
+
+SRCNAME = "tornado"
+
+SRC_URI = " \
+ https://pypi.python.org/packages/source/t/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+"
+SRC_URI[md5sum] = "985c0e704b765c33a6193d49d1935588"
+SRC_URI[sha256sum] = "900c5124ebdb6598ca8e8a0c5888f41a5f14117952d5515258e3d20222b21bfa"
+
+inherit setuptools
+
+RDEPENDS_${PN} += "python-compression python-numbers python-email python-subprocess \
+ python-pkgutil python-html python-json python-backports-ssl python-certifi"
+
+RDEPENDS_${PN}-test += "${PN} python-unittest"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+PACKAGES =+ "\
+ ${PN}-test \
+"
+
+FILES_${PN}-test = " \
+ ${libdir}/${PYTHON_DIR}/site-packages/${SRCNAME}/test \
+ ${libdir}/${PYTHON_DIR}/site-packages/${SRCNAME}/testing.py* \
+"