aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2020-02-25 20:07:38 +0100
committerTim Orling <ticotimo@gmail.com>2020-02-25 19:50:04 -0800
commit749f11c460486a699b5a8c419ff34a9da4139dcf (patch)
tree09a10c398ef371c7fa90bd9a9290db7502fb184d
parent01cca0922ce3156bedb8707ecd1841d79a339a0c (diff)
downloadmeta-python2-749f11c460486a699b5a8c419ff34a9da4139dcf.tar.gz
python-ldap: skip when meta-networking isn't included
* fixes: ERROR: Nothing PROVIDES 'cyrus-sasl' (but meta-python2/recipes-devtools/python/python-ldap_3.2.0.bb DEPENDS on or otherwise requires it) in world builds without meta-networking Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-ldap_3.2.0.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-ldap_3.2.0.bb b/recipes-devtools/python/python-ldap_3.2.0.bb
index af8961e..8e43dee 100644
--- a/recipes-devtools/python/python-ldap_3.2.0.bb
+++ b/recipes-devtools/python/python-ldap_3.2.0.bb
@@ -23,9 +23,15 @@ do_configure_prepend() {
sed -i -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' setup.cfg
}
+
RDEPENDS_${PN} = " \
${PYTHON_PN}-pprint \
${PYTHON_PN}-threading \
${PYTHON_PN}-pyasn1 \
${PYTHON_PN}-pyasn1-modules \
"
+
+python() {
+ if 'networking-layer' not in d.getVar('BBFILE_COLLECTIONS').split():
+ raise bb.parse.SkipRecipe('Requires networking-layer to be present to provide cyrus-sasl.')
+}