aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2020-01-27 19:54:09 -0800
committerTim Orling <ticotimo@gmail.com>2020-01-27 20:30:14 -0800
commit27ce1aba5df9d48c7d94f03f4e5647bd02b132d6 (patch)
treee37c6ecd7c419e7ae00326e1fdd3e76f593de513
parent7f1058debfdf4613de92100bc964bbb832644ca5 (diff)
downloadmeta-python2-27ce1aba5df9d48c7d94f03f4e5647bd02b132d6.tar.gz
dnssec-conf: add missing RDEPENDS
Fixes: "dnssec-configure requires the pyparser package from http://pyparsing.wikispaces.com [...] " Fixes: "dnskey-pull requires the python-dns package from http://www.dnspython.org/ [...] " It has dependencies on the split packages from python manifest, but since it RDEPENDS on "python", all standard lib modules are pulled in. If someone requires a smaller image, the RDEPENDS could be paired down. It also requires "curl" as shown in INSTALL and: https://github.com/xelerance/dnssec-conf/blob/8e799683736b4a7b5e5e78f98fba0a6f48393537/dnskey-pull#L86 It also requires "host" (from bind-utils) as shown in: https://github.com/xelerance/dnssec-conf/blob/8e799683736b4a7b5e5e78f98fba0a6f48393537/dnskey-pull#L299 It recommends "bind", but another nameserver can be used. That level of complexity is left up to someone that needs a different configuration. Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-support/dnssec-conf/dnssec-conf_2.02.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes-support/dnssec-conf/dnssec-conf_2.02.bb b/recipes-support/dnssec-conf/dnssec-conf_2.02.bb
index ca59bd2..1b767a3 100644
--- a/recipes-support/dnssec-conf/dnssec-conf_2.02.bb
+++ b/recipes-support/dnssec-conf/dnssec-conf_2.02.bb
@@ -32,4 +32,10 @@ do_install () {
install -m 0644 packaging/fedora/dnssec.sysconfig ${D}${sysconfdir}/sysconfig/dnssec
}
-RDEPENDS_${PN} = "python"
+RDEPENDS_${PN} = "\
+ bind-utils \
+ curl \
+ python \
+ python-dnspython \
+ python-pyparsing \
+"