aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2020-01-20 20:50:15 -0800
committerTim Orling <ticotimo@gmail.com>2020-01-20 20:59:49 -0800
commitd4aa005c7ece4ee90009f04e76aa9f37260677c3 (patch)
tree4a8e5fb8b74541e376caf70dc65416d2fb099ace
parent7f3a2f90f7957da8d7a0811ab1e6ab0df5391580 (diff)
downloadmeta-python2-d4aa005c7ece4ee90009f04e76aa9f37260677c3.tar.gz
python-pymisp: add missing RDEPENDS
* differentiate target from -native,-nativesdk RDEPENDS while we are at it (for that day when someone wants it) * Add missing run-time dependies [1]: - python-cachetools - python-deprecated [1] https://github.com/MISP/PyMISP/blob/fac748dd4c63c9eef4056c5fc5201e811a97be10/setup.py#L44 Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-pymisp_2.4.119.1.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-pymisp_2.4.119.1.bb b/recipes-devtools/python/python-pymisp_2.4.119.1.bb
index 097328a..627716b 100644
--- a/recipes-devtools/python/python-pymisp_2.4.119.1.bb
+++ b/recipes-devtools/python/python-pymisp_2.4.119.1.bb
@@ -13,11 +13,15 @@ SRC_URI[sha256sum] = "594ea0a9e150052232425009eac6dd104a80f494d0e273cc48dd114d7e
inherit pypi setuptools
-RDEPENDS_${PN} += " \
+RDEPENDS_${PN}_append_class-target = " \
${PYTHON_PN}-dateutil \
${PYTHON_PN}-json \
${PYTHON_PN}-jsonschema \
+"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-cachetools \
+ ${PYTHON_PN}-deprecated \
${PYTHON_PN}-requests \
${PYTHON_PN}-six \
"
-