aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-30 22:08:26 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 18:08:12 -0800
commit6c92d390aa3379ff749b8bba7121341b6ca08818 (patch)
treeaa06752e0d6cda37894daf169f597e9246b66c92
parentb5da87b110c17b81753cff514d45775946587620 (diff)
downloadmeta-python2-6c92d390aa3379ff749b8bba7121341b6ca08818.tar.gz
python-which: move from meta-oe
Part of the EOL python2 process. Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-which_1.1.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-which_1.1.0.bb b/recipes-devtools/python/python-which_1.1.0.bb
new file mode 100644
index 0000000..901fdc7
--- /dev/null
+++ b/recipes-devtools/python/python-which_1.1.0.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "which.py -- a portable GNU which replacement"
+HOMEPAGE = "http://code.google.com/p/which/"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=030b09798681482b9ad12ac47be496ea"
+
+inherit setuptools pypi python-dir
+
+SRCREV = "425bdeeb2d87c36e2313dc4b8d69ff2bb5a02ee9"
+PYPI_SRC_URI = "git://github.com/trentm/which"
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ rmdir -p --ignore-fail-on-non-empty ${D}${STAGING_BINDIR_NATIVE}
+ rmdir -p --ignore-fail-on-non-empty ${D}${datadir}
+}
+
+BBCLASSEXTEND = "native nativesdk"