aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-30 20:02:04 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 18:08:12 -0800
commit33ecae3504cf56223299689581ed783c5de348c4 (patch)
tree86048bb8e002d38c1aac00ef1d6be7903a558ce9
parentb0741dc775a904f82eac1ef80efef80437f677e2 (diff)
downloadmeta-python2-33ecae3504cf56223299689581ed783c5de348c4.tar.gz
python-cryptography: fix ptest dependency
ptest depends on python-hypothesis NOTE: these tests are compute and memory hungry, it is known that 4096 MB is not enough RAM. For testimage, add the following to your local.conf: TEST_QEMUPARAMS += "-smp 4 -m 8192" TEST_RUNQEMUPARAMS += "kvm gl" For runqemu, run with something like: $ runqemu kvm gl qemuparams="-smp 4 -m 8192" meta-python2-ptest-image While we are at it, fix kas-meta-python2-ptest-image.yml Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--kas-meta-python2-ptest-image.yml4
-rw-r--r--recipes-devtools/python/python-cryptography_2.8.bb1
2 files changed, 3 insertions, 2 deletions
diff --git a/kas-meta-python2-ptest-image.yml b/kas-meta-python2-ptest-image.yml
index 22ca473..3a15add 100644
--- a/kas-meta-python2-ptest-image.yml
+++ b/kas-meta-python2-ptest-image.yml
@@ -15,8 +15,8 @@ local_conf_header:
EXTRA_IMAGE_FEATURES = "debug-tweaks"
TESTIMAGE_AUTO = "1"
TEST_SUITES = " ping ssh ptest"
- TEST_QEMUPARAMS += "-smp 4 -m 4096"
+ TEST_QEMUPARAMS += "-smp 4 -m 8192"
TEST_RUNQEMUPARAMS += "kvm gl"
IMAGE_ROOTFS_SIZE ?= "8192"
IMAGE_ROOTFS_EXTRA_SPACE_append = "${@bb.utils.contains("DISTRO_FEATURES", "systemd", " + 4096", "", d)}"
- EXTRA_IMAGE_INSTALL += " ptest-runner dropbear procps coreutils iproute2 sysstat"
+ IMAGE_INSTALL_append = " ptest-runner dropbear procps coreutils iproute2 sysstat"
diff --git a/recipes-devtools/python/python-cryptography_2.8.bb b/recipes-devtools/python/python-cryptography_2.8.bb
index bc0bee4..1d4b43f 100644
--- a/recipes-devtools/python/python-cryptography_2.8.bb
+++ b/recipes-devtools/python/python-cryptography_2.8.bb
@@ -44,6 +44,7 @@ RDEPENDS_${PN}_class-target += " \
RDEPENDS_${PN}-ptest += " \
${PN} \
${PYTHON_PN}-cryptography-vectors \
+ ${PYTHON_PN}-hypothesis \
${PYTHON_PN}-iso8601 \
${PYTHON_PN}-pretend \
${PYTHON_PN}-pytest \