aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-06-23 10:30:29 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2021-06-23 11:13:32 +0200
commitb901080cf57d9a7f5476ab4d96e56c30db8170a8 (patch)
treeda8088d9f1d12b150d9d7736dd7db779ee0a0578
parent6b3000729ce3424c2aa8a03cd46ef37b200d2fc1 (diff)
downloadmeta-python2-dunfell.tar.gz
python-chardet: rename ${bindir}/chardetect to avoid conflict with python3-chardetdunfell-nextdunfell
* to allow both python-chardet and python3-chardet to be installed in the same image * now it fails with: Collected errors: * check_data_file_clashes: Package python-chardet wants to install file image/1.0/rootfs/usr/bin/chardetect But that file is already provided by package * python3-chardet * the only difference is the shebang: --- python-chardet/3.0.4-r0/image/usr/bin/chardetect 2021-06-23 01:24:17.172638046 -0700 +++ python3-chardet/3.0.4-r0/image/usr/bin/chardetect 2021-06-23 01:24:17.412641733 -0700 @@ -1,4 +1,4 @@ -#!/usr/bin/env python +#!/usr/bin/env python3 # EASY-INSTALL-ENTRY-SCRIPT: 'chardet==3.0.4','console_scripts','chardetect' __requires__ = 'chardet==3.0.4' import re Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-devtools/python/python-chardet_3.0.4.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-chardet_3.0.4.bb b/recipes-devtools/python/python-chardet_3.0.4.bb
index 19d7b77..d84a305 100644
--- a/recipes-devtools/python/python-chardet_3.0.4.bb
+++ b/recipes-devtools/python/python-chardet_3.0.4.bb
@@ -26,6 +26,10 @@ RDEPENDS_${PN}_class-target += " \
inherit pypi setuptools
+do_install_append() {
+ mv ${D}${bindir}/chardetect ${D}${bindir}/chardetect-py2
+}
+
RDEPENDS_${PN} += "${PYTHON_PN}-argparse"
BBCLASSEXTEND = "native nativesdk"