aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2015-02-10 14:55:10 +0800
committerArmin Kuster <akuster808@gmail.com>2015-03-21 07:56:31 -0700
commitf1fedf11eb4c19512f7a397b71781b656f7d4627 (patch)
tree1c270551dbbf1dfda171d91ce27fe42cf425a4d4
parentc64792a49886a48fb4008200b43c9d549ad3ead4 (diff)
downloadmeta-python2-f1fedf11eb4c19512f7a397b71781b656f7d4627.tar.gz
python-pip: add python-distribute in RDEPENDSdizzy-nextdizzy
Fix the following runtime issue of pip: # pip Traceback (most recent call last): File "/usr/bin/pip", line 5, in <module> from pkg_resources import load_entry_point ImportError: No module named pkg_resources (From meta-openembedded commit: 66ca394c5b0b597b9eaaa22f8bf9fc924ef9ab54) Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-pip_1.3.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-pip_1.3.1.bb b/recipes-devtools/python/python-pip_1.3.1.bb
index d1a7c8b..1388a3d 100644
--- a/recipes-devtools/python/python-pip_1.3.1.bb
+++ b/recipes-devtools/python/python-pip_1.3.1.bb
@@ -11,4 +11,4 @@ S = "${WORKDIR}/pip-${PV}"
inherit setuptools
# Since PIP is like CPAN for PERL we need to drag in all python modules to ensure everything works
-RDEPENDS_${PN} = "python-modules"
+RDEPENDS_${PN} = "python-modules python-distribute"