aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2014-08-22 02:46:22 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-27 12:48:45 +0200
commit939e13c369cccd96704c92d5d90c5249de410c37 (patch)
tree01a215646e635f1978f508fd1af5249786f1d40a
parent97c9ceda7b7a4f677fd12fd9d469ebb0c558d370 (diff)
downloadmeta-python2-939e13c369cccd96704c92d5d90c5249de410c37.tar.gz
python-cython: add RDEPENDS on some required python modules
python-distribute: File "/usr/bin/cython", line 5, in <module> ImportError: No module named pkg_resources python-netserver: File "_tempita.py", line 34, in init Cython.Tempita._tempita ImportError: No module named cgi python-subprocess: File "/usr/lib/python2.7/site-packages/Cython/Debugger/Cygdb.py", line 19, in <module> ImportError: No module named subprocess python-shell: File "/usr/lib/python2.7/site-packages/Cython/Debugger/Cygdb.py", line 16, in <module> ImportError: No module named glob (From meta-openembedded commit: fea3840ee5829afc4b159c81341366e47e4d6959) Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-cython_0.20.2.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-cython_0.20.2.bb b/recipes-devtools/python/python-cython_0.20.2.bb
index 9f357ec..3966e0b 100644
--- a/recipes-devtools/python/python-cython_0.20.2.bb
+++ b/recipes-devtools/python/python-cython_0.20.2.bb
@@ -14,3 +14,11 @@ SRC_URI[md5sum] = "7fc13e1c665bdf7cea19ad08906af91f"
SRC_URI[sha256sum] = "ed13b606a2aeb5bd6c235f8ed6c9988c99d01a033d0d21d56137c13d5c7be63f"
inherit setuptools
+
+RDEPENDS_${PN} += "\
+ python-distribute \
+ python-netserver \
+ python-subprocess \
+ python-shell \
+"
+RDEPENDS_${PN}_class-native = ""