aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/zbedic
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qtopia/zbedic')
-rw-r--r--recipes-qtopia/zbedic/libbedic_1.1.bb40
-rw-r--r--recipes-qtopia/zbedic/zbedic/include-cstdio.patch12
-rw-r--r--recipes-qtopia/zbedic/zbedic/opie-icons.patch14
-rw-r--r--recipes-qtopia/zbedic/zbedic/qtopia17.patch21
-rw-r--r--recipes-qtopia/zbedic/zbedic_1.2.bb46
5 files changed, 133 insertions, 0 deletions
diff --git a/recipes-qtopia/zbedic/libbedic_1.1.bb b/recipes-qtopia/zbedic/libbedic_1.1.bb
new file mode 100644
index 0000000..8af2162
--- /dev/null
+++ b/recipes-qtopia/zbedic/libbedic_1.1.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "Library to handle bedic dictionary"
+HOMEPAGE = "http://bedic.sourceforge.net/"
+AUTHOR = "Rafal Mantiuk <rafm@users.sourceforge.net>"
+SECTION = "opie/libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "sqlite3"
+APPTYPE = "binary"
+APPDESKTOP = "${WORKDIR}/zbedic/misc"
+FILESPATHPKG .= ":zbedic"
+PR = "r5"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/bedic/libbedic_${PV}-0.tgz;subdir=${BPN}-${PV} \
+ file://include-cstdio.patch \
+ "
+
+inherit palmtop
+# need to override this, because bedic contains exception handling
+# pass VERSION as a string \\"${PV}.0\\"
+export OE_QMAKE_CXXFLAGS="-fexceptions -fno-rtti ${CXXFLAGS} -DVERSION=\\"${PV}.0\\""
+
+do_configure() {
+ qmake -project && qmake -makefile -t lib -spec ${QMAKESPEC} CONFIG=console CONFIG+=staticlib CONFIG+=sharedlib -after \
+ TARGET=bedic \
+ SOURCES-=src/xerox.cpp OBJECTS-=xerox.o \
+ SOURCES-=src/mkbedic.cpp OBJECTS-=mkbedic.o \
+ SOURCES-=src/test_dynamic_dictionary.cpp \
+}
+
+do_install() {
+ install -d ${D}${includedir}
+ install -m 0644 ${S}/include/*.h ${D}${includedir}
+ install -d ${D}${libdir}
+ oe_libinstall -a libbedic ${D}${libdir}
+}
+
+FILES_${PN}-dev = "${includedir} ${libdir}"
+
+SRC_URI[md5sum] = "211ea5a881b5691ec7a1aedbe7fc406c"
+SRC_URI[sha256sum] = "0cb299278f17d4580d9b1b56df8b7c356afb016f2a68ce7d13a8169f74e2a16b"
diff --git a/recipes-qtopia/zbedic/zbedic/include-cstdio.patch b/recipes-qtopia/zbedic/zbedic/include-cstdio.patch
new file mode 100644
index 0000000..f4e1771
--- /dev/null
+++ b/recipes-qtopia/zbedic/zbedic/include-cstdio.patch
@@ -0,0 +1,12 @@
+Index: zbedic/src/shcm.cpp
+===================================================================
+--- zbedic/src/shcm.cpp
++++ zbedic/src/shcm.cpp
+@@ -20,6 +20,7 @@
+
+ #include <stdio.h>
+ #include <vector>
++#include <cstdlib>
+
+ #include "shcm.h"
+ #include "shc.h"
diff --git a/recipes-qtopia/zbedic/zbedic/opie-icons.patch b/recipes-qtopia/zbedic/zbedic/opie-icons.patch
new file mode 100644
index 0000000..cd320b3
--- /dev/null
+++ b/recipes-qtopia/zbedic/zbedic/opie-icons.patch
@@ -0,0 +1,14 @@
+--- zbedic/src/zbedic.cpp.old 2008-09-20 14:36:24.000000000 -0500
++++ zbedic/src/zbedic.cpp 2008-09-20 14:37:21.000000000 -0500
+@@ -142,9 +142,9 @@ ZBEDic::ZBEDic(QWidget *parent, const ch
+ action[TB_SwitchDictionaries] = createAction( tr( "Switch dictionaries" ), "zbedic/switch_dictionary",
+ SLOT(switchToPreviousDict()), CTRL+Key_S );
+ action[TB_ShowHistory] = createAction( tr( "Show history" ), "zbedic/history", SLOT(showHistoryPopup()), CTRL+Key_H );
+- action[TB_Back] = createAction( tr( "Go back" ), "zbedic/back",
++ action[TB_Back] = createAction( tr( "Go back" ), "back",
+ SLOT(navigationPrevious()), Key_End );
+- action[TB_Forward] = createAction( tr( "Go forward" ), "zbedic/forward",
++ action[TB_Forward] = createAction( tr( "Go forward" ), "forward",
+ SLOT(navigationNext()), Key_Home );
+ action[TB_LookupSelection] = createAction( tr( "Lookup selection" ), "zbedic/lookup_selection",
+ SLOT(lookupSelection()), CTRL+Key_L );
diff --git a/recipes-qtopia/zbedic/zbedic/qtopia17.patch b/recipes-qtopia/zbedic/zbedic/qtopia17.patch
new file mode 100644
index 0000000..749fde2
--- /dev/null
+++ b/recipes-qtopia/zbedic/zbedic/qtopia17.patch
@@ -0,0 +1,21 @@
+--- zbedic/src/main.cpp.old 2008-09-20 14:40:57.000000000 -0500
++++ zbedic/src/main.cpp 2008-09-20 14:51:11.000000000 -0500
+@@ -48,8 +48,16 @@ int main( int argc, char **argv )
+
+ #include <qpe/qpeapplication.h>
+
+-QTOPIA_ADD_APPLICATION("zbedic", ZBEDic)
+-QTOPIA_MAIN
++int main(int argc, char** argv)
++{
++ QPEApplication app( argc, argv );
++
++ ZBEDic mainWindow( NULL, NULL );
++ app.setMainWidget( &mainWindow );
++
++ mainWindow.show();
++ return app.exec();
++}
+
+ #endif
+
diff --git a/recipes-qtopia/zbedic/zbedic_1.2.bb b/recipes-qtopia/zbedic/zbedic_1.2.bb
new file mode 100644
index 0000000..216fc00
--- /dev/null
+++ b/recipes-qtopia/zbedic/zbedic_1.2.bb
@@ -0,0 +1,46 @@
+DESCRIPTION = "A dictionary application for Qt/E based Palmtop Environments"
+HOMEPAGE = "http://bedic.sourceforge.net/"
+AUTHOR = "Rafal Mantiuk <rafm@users.sourceforge.net>"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "libbedic"
+APPTYPE = "binary"
+APPDESKTOP = "${WORKDIR}/misc"
+PR = "r3"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/bedic/zbedic_${PV}-2.tgz;subdir=${BPN}-${PV} \
+ file://opie-icons.patch \
+ file://qtopia17.patch"
+
+inherit opie
+export OE_QMAKE_LINK="${CXX}"
+export OE_QMAKE_CXXFLAGS=" -DVERSION=\\"${PV}.2\\" -DPREFIX_PATH=\\"/usr\\""
+
+EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${STAGING_INCDIR}/libbedic LIBS+=-lbedic LIBS+=-lsqlite3 TARGET=zbedic"
+
+do_configure_prepend() {
+ rm -f Makefile
+ qmake -project
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/zbedic/
+ install -d ${D}${palmtopdir}/help/html/
+ # we copy small icons - in other way QVGA users will complain
+ install -m 0644 ${S}/misc/small_icons/*.png ${D}${palmtopdir}/pics/zbedic/
+ install -m 0644 ${S}/misc/large_icons/zbedic.png ${D}${palmtopdir}/pics/
+ install -m 0644 ${S}/doc/manual/*.html ${D}${palmtopdir}/help/html/
+ rm ${D}${palmtopdir}/pics/zbedic/zbedic.png
+
+ # those ones are taken from OPIE so they have proper size (depend on device)
+ rm ${D}${palmtopdir}/pics/zbedic/back.png
+ rm ${D}${palmtopdir}/pics/zbedic/forward.png
+}
+
+PACKAGES = "${PN}-dbg ${PN}-doc ${PN} ${PN}-dev"
+
+FILES_${PN}-doc += "${palmtopdir}/help"
+
+SRC_URI[md5sum] = "c7e8e267567a96cff7920a0365978c4d"
+SRC_URI[sha256sum] = "b991cc5635849353081c2a3350142484763323bc58bfa49b62285645aac129b9"