aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/zbedic/libbedic_1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qtopia/zbedic/libbedic_1.1.bb')
-rw-r--r--recipes-qtopia/zbedic/libbedic_1.1.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-qtopia/zbedic/libbedic_1.1.bb b/recipes-qtopia/zbedic/libbedic_1.1.bb
new file mode 100644
index 0000000..8af2162
--- /dev/null
+++ b/recipes-qtopia/zbedic/libbedic_1.1.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "Library to handle bedic dictionary"
+HOMEPAGE = "http://bedic.sourceforge.net/"
+AUTHOR = "Rafal Mantiuk <rafm@users.sourceforge.net>"
+SECTION = "opie/libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "sqlite3"
+APPTYPE = "binary"
+APPDESKTOP = "${WORKDIR}/zbedic/misc"
+FILESPATHPKG .= ":zbedic"
+PR = "r5"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/bedic/libbedic_${PV}-0.tgz;subdir=${BPN}-${PV} \
+ file://include-cstdio.patch \
+ "
+
+inherit palmtop
+# need to override this, because bedic contains exception handling
+# pass VERSION as a string \\"${PV}.0\\"
+export OE_QMAKE_CXXFLAGS="-fexceptions -fno-rtti ${CXXFLAGS} -DVERSION=\\"${PV}.0\\""
+
+do_configure() {
+ qmake -project && qmake -makefile -t lib -spec ${QMAKESPEC} CONFIG=console CONFIG+=staticlib CONFIG+=sharedlib -after \
+ TARGET=bedic \
+ SOURCES-=src/xerox.cpp OBJECTS-=xerox.o \
+ SOURCES-=src/mkbedic.cpp OBJECTS-=mkbedic.o \
+ SOURCES-=src/test_dynamic_dictionary.cpp \
+}
+
+do_install() {
+ install -d ${D}${includedir}
+ install -m 0644 ${S}/include/*.h ${D}${includedir}
+ install -d ${D}${libdir}
+ oe_libinstall -a libbedic ${D}${libdir}
+}
+
+FILES_${PN}-dev = "${includedir} ${libdir}"
+
+SRC_URI[md5sum] = "211ea5a881b5691ec7a1aedbe7fc406c"
+SRC_URI[sha256sum] = "0cb299278f17d4580d9b1b56df8b7c356afb016f2a68ce7d13a8169f74e2a16b"