aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/tximage
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qtopia/tximage')
-rw-r--r--recipes-qtopia/tximage/tximage-0.2/gcc3.patch27
-rw-r--r--recipes-qtopia/tximage/tximage-0.2/gcc4.patch15
-rw-r--r--recipes-qtopia/tximage/tximage_0.2.bb24
3 files changed, 66 insertions, 0 deletions
diff --git a/recipes-qtopia/tximage/tximage-0.2/gcc3.patch b/recipes-qtopia/tximage/tximage-0.2/gcc3.patch
new file mode 100644
index 0000000..7729603
--- /dev/null
+++ b/recipes-qtopia/tximage/tximage-0.2/gcc3.patch
@@ -0,0 +1,27 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- tximage-0.2/imagelistview.cpp~gcc3 2003-06-21 03:47:29.000000000 +0200
++++ tximage-0.2/imagelistview.cpp 2004-02-10 00:26:31.000000000 +0100
+@@ -88,7 +88,7 @@
+ }
+
+
+-ImageListView::ImageListView(QWidget *parent, const char *name=0)
++ImageListView::ImageListView(QWidget *parent, const char *name)
+ : QListView(parent, name)
+ {
+ addColumn("Name");
+--- tximage-0.2/settingsdialog.cpp~gcc3 2003-06-21 03:05:06.000000000 +0200
++++ tximage-0.2/settingsdialog.cpp 2004-02-10 00:27:25.000000000 +0100
+@@ -37,7 +37,7 @@
+ #include "settingsdialog.h"
+
+
+-SettingsDialog::SettingsDialog(QWidget *parent = 0, const char *name = 0)
++SettingsDialog::SettingsDialog(QWidget *parent, const char *name)
+ : SettingsDialogBase(parent, name, true)
+ {
+ settings = NULL;
diff --git a/recipes-qtopia/tximage/tximage-0.2/gcc4.patch b/recipes-qtopia/tximage/tximage-0.2/gcc4.patch
new file mode 100644
index 0000000..d327754
--- /dev/null
+++ b/recipes-qtopia/tximage/tximage-0.2/gcc4.patch
@@ -0,0 +1,15 @@
+
+#
+# Signed off by Michael 'Mickey' Lauer <mickey@Vanille.de>
+#
+
+--- tximage-0.2/imageviewer.h~gcc4
++++ tximage-0.2/imageviewer.h
+@@ -32,6 +32,7 @@
+ #include "imagereader.h"
+
+ class ImageWidget;
++class ImageViewer;
+ class QString;
+ class QImage;
+ class QScrollView;
diff --git a/recipes-qtopia/tximage/tximage_0.2.bb b/recipes-qtopia/tximage/tximage_0.2.bb
new file mode 100644
index 0000000..ab2a59a
--- /dev/null
+++ b/recipes-qtopia/tximage/tximage_0.2.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Tx Image Viewer"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://community.zaurus.com/projects/tximage/"
+PR = "r2"
+
+SRC_URI = "http://www.openzaurus.org/mirror/tximage-${PV}.tar.gz \
+ file://gcc3.patch \
+ file://gcc4.patch"
+
+inherit palmtop
+
+do_install() {
+ install -d ${D}${palmtopdir}/apps/Applications \
+ ${D}${palmtopdir}/pics \
+ ${D}${palmtopdir}/bin
+ install -D -m 755 tximage ${D}${palmtopdir}/bin/tximage
+ install -D -m 644 imageviewer.desktop ${D}${palmtopdir}/apps/Applications/tximage.desktop
+ cp -pPR tximage.png ${D}${palmtopdir}/pics/
+}
+
+SRC_URI[md5sum] = "eca63798136caeeaf7fd4b24c3e10783"
+SRC_URI[sha256sum] = "88b11a3e89db847e1db51e6f2b0c69e2afa0035fb4a47f523d264765eedb2958"