aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/snes9x/snes9x-sdl_1.39.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qtopia/snes9x/snes9x-sdl_1.39.bb')
-rw-r--r--recipes-qtopia/snes9x/snes9x-sdl_1.39.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-qtopia/snes9x/snes9x-sdl_1.39.bb b/recipes-qtopia/snes9x/snes9x-sdl_1.39.bb
new file mode 100644
index 0000000..df712f5
--- /dev/null
+++ b/recipes-qtopia/snes9x/snes9x-sdl_1.39.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Super Nintendo Emulator based on SDL"
+SECTION = "games"
+PRIORITY = "optional"
+DEPENDS = "virtual/libsdl zlib"
+LICENSE = "snes9x"
+PR = "r3"
+
+SRC_URI = "http://www.vanille.de/mirror/snes9x-sdl-${PV}.tar.bz2 \
+ file://compile.patch \
+ file://gcc-4.1.patch"
+S = "${WORKDIR}/snes9x-sdl-${PV}"
+
+do_compile() {
+ oe_runmake CC="${CC}" CCC="${CXX} -fno-rtti -fno-exceptions" \
+ INCLUDES="-I${STAGING_INCDIR} `sdl-config --cflags`" \
+ LDLIBS="`sdl-config --libs`"
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 snes9x ${D}${bindir}/snes9x
+}
+
+FILES_${PN} = "${bindir}/snes9x"
+
+SRC_URI[md5sum] = "a7836a9b6eaae433079c1c9d19f2635a"
+SRC_URI[sha256sum] = "489bb2f9fb69922e9befc27ae1b8d19d31c83c586f55b7ecc503cb4f5e767da4"