aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/sidplayer
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qtopia/sidplayer')
-rw-r--r--recipes-qtopia/sidplayer/sidplayer-1.5.0/gcc3.patch69
-rw-r--r--recipes-qtopia/sidplayer/sidplayer-1.5.0/gcc34.patch40
-rw-r--r--recipes-qtopia/sidplayer/sidplayer-1.5.0/use-external-libsidplay.patch20
-rw-r--r--recipes-qtopia/sidplayer/sidplayer_1.5.0.bb27
4 files changed, 156 insertions, 0 deletions
diff --git a/recipes-qtopia/sidplayer/sidplayer-1.5.0/gcc3.patch b/recipes-qtopia/sidplayer/sidplayer-1.5.0/gcc3.patch
new file mode 100644
index 0000000..b94e26a
--- /dev/null
+++ b/recipes-qtopia/sidplayer/sidplayer-1.5.0/gcc3.patch
@@ -0,0 +1,69 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- sidplayer/sidplayer.cpp~gcc3 2003-09-26 20:28:51.000000000 +0200
++++ sidplayer/sidplayer.cpp 2004-02-12 19:24:33.000000000 +0100
+@@ -83,8 +83,8 @@
+ //============================================================================================
+
+ Sidplayer::Sidplayer( int argc, char **argv, QPEApplication *app,
+- QWidget *parent, const char *name, WFlags f )
+- : TabbedDialog( parent, name, f ),
++ QWidget *parent, const char *name, WFlags flags )
++ : TabbedDialog( parent, name, flags ),
+ application( app ),
+ selectedSong( 1 ),
+ totalSongs( 1 ),
+@@ -710,7 +710,7 @@
+
+ //--------------------------------------------------------------------------------------------
+
+-void Sidplayer::updateListeningMileageLabel( bool forceUpdate = false )
++void Sidplayer::updateListeningMileageLabel( bool forceUpdate )
+ {
+ static int oldSecondsTotal = 0;
+ int secondsTotal = myEmuEngine.getSecondsTotal();
+--- sidplayer/sidplayer_file.cpp~gcc3 2003-09-25 21:56:57.000000000 +0200
++++ sidplayer/sidplayer_file.cpp 2004-02-12 19:24:33.000000000 +0100
+@@ -249,7 +249,7 @@
+ }
+ }
+
+-void Sidplayer::populateFileView( const QString &directory, const QString &selectThis = "" )
++void Sidplayer::populateFileView( const QString &directory, const QString &selectThis )
+ {
+ QDir dir( directory );
+
+--- sidplayer/sidplayer_list.cpp~gcc3 2003-07-09 21:49:28.000000000 +0200
++++ sidplayer/sidplayer_list.cpp 2004-02-12 19:24:33.000000000 +0100
+@@ -172,7 +172,7 @@
+ setAllPlaylistViewItemsOddFlag();
+ }
+
+-void Sidplayer::insertDir_( QString dirpath = "" )
++void Sidplayer::insertDir_( QString dirpath )
+ {
+ if ( dirpath == "" )
+ dirpath = currentDir;
+@@ -225,7 +225,7 @@
+ setAllPlaylistViewItemsOddFlag();
+ }
+
+-void Sidplayer::insertDirRecursive_( QString dirpath = "" )
++void Sidplayer::insertDirRecursive_( QString dirpath )
+ {
+ if ( dirpath == "" )
+ dirpath = currentDir;
+--- sidplayer/volumebarwidget.cpp~gcc3 2003-07-09 22:35:48.000000000 +0200
++++ sidplayer/volumebarwidget.cpp 2004-02-12 19:28:54.000000000 +0100
+@@ -18,7 +18,7 @@
+
+ #include <iostream>
+
+-VolumeBarWidget::VolumeBarWidget( QWidget *parent = 0, const char *name = 0, WFlags f = 0 )
++VolumeBarWidget::VolumeBarWidget( QWidget *parent, const char *name, WFlags f )
+ : QWidget( parent, name, f )
+ {
+ getVolume();
diff --git a/recipes-qtopia/sidplayer/sidplayer-1.5.0/gcc34.patch b/recipes-qtopia/sidplayer/sidplayer-1.5.0/gcc34.patch
new file mode 100644
index 0000000..00598a1
--- /dev/null
+++ b/recipes-qtopia/sidplayer/sidplayer-1.5.0/gcc34.patch
@@ -0,0 +1,40 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- sidplayer/sidplayer.h~gcc34.patch 2004-05-16 20:54:24.000000000 +0200
++++ sidplayer/sidplayer.h 2004-05-16 20:54:24.000000000 +0200
+@@ -36,7 +36,7 @@
+
+ #define SHUTDOWN_TIMER_TIMEOUT 10 // 2 would probably be also long enough
+
+-
++static bool evenFlag = 0;
+ extern bool sidEmuFastForwardReplay( int );
+
+
+--- sidplayer/sidplayer_list.cpp~gcc34.patch 2004-05-16 20:54:24.000000000 +0200
++++ sidplayer/sidplayer_list.cpp 2004-05-16 20:55:40.000000000 +0200
+@@ -23,9 +23,6 @@
+ #include <qpe/config.h>
+
+
+-static bool evenFlag; // This global flag is used to toggle between even and odd list entries
+- // when generating list items (i.e. when populating a list).
+-
+ PlaylistItem::PlaylistItem( QListView *parent, QListViewItem *after, const QFileInfo &fi,
+ const QString &name,
+ const QString &author,
+--- sidplayer/sidplayer_file.cpp~gcc34.patch 2004-05-16 20:54:24.000000000 +0200
++++ sidplayer/sidplayer_file.cpp 2004-05-16 20:56:01.000000000 +0200
+@@ -24,9 +24,6 @@
+ #endif
+
+
+-static bool evenFlag; // This global flag is used to toggle between even and odd list entries
+- // when generating list items (i.e. when populating a list).
+-
+ FileItem::FileItem( QListView *parent, const QFileInfo &fi, int type )
+ : ItemBase( parent ),
+ fileInfo( fi )
diff --git a/recipes-qtopia/sidplayer/sidplayer-1.5.0/use-external-libsidplay.patch b/recipes-qtopia/sidplayer/sidplayer-1.5.0/use-external-libsidplay.patch
new file mode 100644
index 0000000..7c00079
--- /dev/null
+++ b/recipes-qtopia/sidplayer/sidplayer-1.5.0/use-external-libsidplay.patch
@@ -0,0 +1,20 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- sidplayer/sidplayer.h~use-external-libsidplay 2003-09-26 00:28:31.000000000 +0200
++++ sidplayer/sidplayer.h 2004-02-12 18:16:19.000000000 +0100
+@@ -13,9 +13,9 @@
+
+ #include "tabbeddialog.h"
+
+-#include "libsidplay/src/player.h"
+-#include "libsidplay/src/fformat.h"
+-#include "libsidplay/src/myendian.h"
++#include <player.h>
++#include <fformat.h>
++#include <myendian.h>
+ #include "audiodrv.h"
+
+ #include <qpe/qpeapplication.h>
diff --git a/recipes-qtopia/sidplayer/sidplayer_1.5.0.bb b/recipes-qtopia/sidplayer/sidplayer_1.5.0.bb
new file mode 100644
index 0000000..d617ca8
--- /dev/null
+++ b/recipes-qtopia/sidplayer/sidplayer_1.5.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "A SID Player for the Qt/Embedded based Palmtop Environments"
+SECTION = "opie/multimedia"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://sidplayer.sourceforge.net/"
+DEPENDS = "libsidplay"
+PR = "r1"
+
+SRC_URI = "http://sidplayer.sourceforge.net/sidplayer.tar.gz \
+ file://use-external-libsidplay.patch \
+ file://gcc3.patch \
+ file://gcc34.patch"
+S = "${WORKDIR}/sidplayer"
+
+EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${STAGING_INCDIR}/sidplay"
+
+inherit palmtop
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Applications \
+ ${D}${palmtopdir}/pics
+ cp -pPR ../apps ../bin ../pics ${D}${palmtopdir}/
+}
+
+SRC_URI[md5sum] = "bba4a99e59581066e905c9326a724ba5"
+SRC_URI[sha256sum] = "bc6bfd100c495e74baa651c470252484b19bfc2e6fa8520f591b0c01b9fcfb5d"