aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/sidplayer/sidplayer_1.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qtopia/sidplayer/sidplayer_1.5.0.bb')
-rw-r--r--recipes-qtopia/sidplayer/sidplayer_1.5.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-qtopia/sidplayer/sidplayer_1.5.0.bb b/recipes-qtopia/sidplayer/sidplayer_1.5.0.bb
new file mode 100644
index 0000000..d617ca8
--- /dev/null
+++ b/recipes-qtopia/sidplayer/sidplayer_1.5.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "A SID Player for the Qt/Embedded based Palmtop Environments"
+SECTION = "opie/multimedia"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://sidplayer.sourceforge.net/"
+DEPENDS = "libsidplay"
+PR = "r1"
+
+SRC_URI = "http://sidplayer.sourceforge.net/sidplayer.tar.gz \
+ file://use-external-libsidplay.patch \
+ file://gcc3.patch \
+ file://gcc34.patch"
+S = "${WORKDIR}/sidplayer"
+
+EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${STAGING_INCDIR}/sidplay"
+
+inherit palmtop
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Applications \
+ ${D}${palmtopdir}/pics
+ cp -pPR ../apps ../bin ../pics ${D}${palmtopdir}/
+}
+
+SRC_URI[md5sum] = "bba4a99e59581066e905c9326a724ba5"
+SRC_URI[sha256sum] = "bc6bfd100c495e74baa651c470252484b19bfc2e6fa8520f591b0c01b9fcfb5d"