aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/qpf-fonts
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qtopia/qpf-fonts')
-rwxr-xr-xrecipes-qtopia/qpf-fonts/files/update-qtfontdir74
-rw-r--r--recipes-qtopia/qpf-fonts/qpf-arabic_1.0.bb11
-rw-r--r--recipes-qtopia/qpf-fonts/qpf-bitstream-vera-sans-mono_1.10.bb39
-rw-r--r--recipes-qtopia/qpf-fonts/qpf-bitstream-vera_1.10.bb27
-rw-r--r--recipes-qtopia/qpf-fonts/qpf-font-common_1.0.bb14
-rw-r--r--recipes-qtopia/qpf-fonts/qpf-freemono_1.0.bb13
-rw-r--r--recipes-qtopia/qpf-fonts/qpf-freeserif_1.0.bb13
-rw-r--r--recipes-qtopia/qpf-fonts/qpf-helvetica_1.0.bb12
-rw-r--r--recipes-qtopia/qpf-fonts/qpf-hunkysans_0.3.0.bb13
-rw-r--r--recipes-qtopia/qpf-fonts/qpf-hunkyserif_0.3.0.bb13
-rw-r--r--recipes-qtopia/qpf-fonts/qpf-qte_2.3.10.bb38
-rw-r--r--recipes-qtopia/qpf-fonts/qpf-qte_3.3.5.bb60
-rw-r--r--recipes-qtopia/qpf-fonts/qpf-terminus.bb13
-rw-r--r--recipes-qtopia/qpf-fonts/qpf-unifont_1.0.bb11
-rw-r--r--recipes-qtopia/qpf-fonts/qpf-unismall_1.0.0.bb12
-rw-r--r--recipes-qtopia/qpf-fonts/qpf-utopia_1.0.bb12
-rw-r--r--recipes-qtopia/qpf-fonts/qpf.inc32
17 files changed, 407 insertions, 0 deletions
diff --git a/recipes-qtopia/qpf-fonts/files/update-qtfontdir b/recipes-qtopia/qpf-fonts/files/update-qtfontdir
new file mode 100755
index 0000000..34f2ffd
--- /dev/null
+++ b/recipes-qtopia/qpf-fonts/files/update-qtfontdir
@@ -0,0 +1,74 @@
+#!/bin/sh
+
+usage()
+{
+ echo "usage: $0 [font directory, defaults to \$QTDIR/lib/fonts]"
+ exit 1
+}
+
+setVar()
+{
+ eval "$1='$2'"
+}
+
+getVar()
+{
+ eval "echo \$$1"
+}
+
+handleQPF()
+{
+ base=`basename $1`
+ family=`echo $base|cut -d_ -f1`
+ pt=`echo $base|cut -d_ -f2`
+ weight=`echo $base|cut -d_ -f3|sed -e 's,i$,,'`
+ if (echo $base|cut -d_ -f3|grep -q 'i$'); then
+ italic="y"
+ else
+ italic="n"
+ fi
+ echo "$family $base.qpf QPF $italic $weight $pt u"
+}
+
+if [ "$1" = "-f" ]; then
+ FORCE=1
+ shift
+else
+ FORCE=0
+fi
+
+if [ -z "$1" ]; then
+ if [ -n "$QTDIR" ]; then
+ fontdir=$QTDIR/lib/fonts
+ else
+ fontdir=@palmtopdir@/lib/fonts
+ fi
+else
+ fontdir=$1
+fi
+
+if ! [ -d $fontdir ]; then
+ echo Error: $fontdir not a directory
+ exit 1
+fi
+
+if [ -e $fontdir/fontdir ]; then
+ if find $fontdir -newer $fontdir/fontdir | grep -q "\(qpf\|ttf\)"; then
+ #echo "fontdir needs updating..."
+ :
+ elif [ "$FORCE" = "0" ]; then
+ #echo "fontdir already up to date - exiting"
+ exit 0
+ fi
+ cat $fontdir/fontdir | grep -v '\.qpf' > $fontdir/fontdir.new
+fi
+
+(
+ for file in `ls $fontdir/*.qpf 2>/dev/null |sed -e's,\.qpf$,,; s,_t[^_]*$,,;'|sort -u`; do
+ handleQPF $file
+ done
+) >> $fontdir/fontdir.new
+
+mv $fontdir/fontdir.new $fontdir/fontdir
+
+exit 0
diff --git a/recipes-qtopia/qpf-fonts/qpf-arabic_1.0.bb b/recipes-qtopia/qpf-fonts/qpf-arabic_1.0.bb
new file mode 100644
index 0000000..9a0d22f
--- /dev/null
+++ b/recipes-qtopia/qpf-fonts/qpf-arabic_1.0.bb
@@ -0,0 +1,11 @@
+require qpf.inc
+
+DESCRIPTION = "Arabic fonts from Arabeyes.org"
+HOMEPAGE = "http://www.arabeyes.org"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/arabeyes/arabic-fonts-${PV}.tar.gz;subdir=${BPN}-${PV}"
+
+SRC_URI[md5sum] = "c6b1aa28bfecdd0c693a2afc43d7679e"
+SRC_URI[sha256sum] = "d5b93fb8dbfa73e4a542bb8ad7d61c8b48dcf79948da26da9e9ef3b1a49c4221"
diff --git a/recipes-qtopia/qpf-fonts/qpf-bitstream-vera-sans-mono_1.10.bb b/recipes-qtopia/qpf-fonts/qpf-bitstream-vera-sans-mono_1.10.bb
new file mode 100644
index 0000000..d84e3f7
--- /dev/null
+++ b/recipes-qtopia/qpf-fonts/qpf-bitstream-vera-sans-mono_1.10.bb
@@ -0,0 +1,39 @@
+require qpf.inc
+
+DESCRIPTION = "Bitstream Vera Monospaced Font, QPF for Qt/Embedded"
+LICENSE = "Bitstream Vera"
+PR = "r4"
+
+PROVIDES += "qpf-bitstream-vera-sans-mono-small"
+PROVIDES += "qpf-bitstream-vera-sans-mono-larger"
+PROVIDES += "qpf-bitstream-vera-sans-mono-large"
+PROVIDES += "qpf-bitstream-vera-sans-mono-huge"
+
+SRC_URI = "http://openzaurus.org/mirror/fonts-bitstream-vera-sans-mono.tar.gz"
+S = "${WORKDIR}/verasansmono"
+
+FILES_${PN} += "${palmtopdir}"
+
+PACKAGES = "${PN}-dbg \
+qpf-bitstream-vera-sans-mono-small \
+qpf-bitstream-vera-sans-mono-large \
+qpf-bitstream-vera-sans-mono-larger \
+qpf-bitstream-vera-sans-mono-huge ${PN}"
+
+FILES_qpf-bitstream-vera-sans-mono-small = "\
+${palmqtdir}/lib/fonts/verasansmono_10* \
+ ${palmqtdir}/lib/fonts/verasansmono_11* \
+ ${palmqtdir}/lib/fonts/verasansmono_12* \
+ ${palmqtdir}/lib/fonts/verasansmono_13* \
+ ${palmqtdir}/lib/fonts/verasansmono_14*"
+FILES_qpf-bitstream-vera-sans-mono-large = "\
+ ${palmqtdir}/lib/fonts/verasansmono_15*" \
+ ${palmqtdir}/lib/fonts/verasansmono_16* \
+ ${palmqtdir}/lib/fonts/verasansmono_17* \
+ ${palmqtdir}/lib/fonts/verasansmono_18* \
+ ${palmqtdir}/lib/fonts/verasansmono_19*"
+FILES_qpf-bitstream-vera-sans-mono-larger = "${palmqtdir}/lib/fonts/verasansmono_2*"
+FILES_qpf-bitstream-vera-sans-mono-huge = "${palmqtdir}/lib/fonts/verasansmono_3*"
+
+SRC_URI[md5sum] = "890615fa4b3e6c82cd1b9807b106f042"
+SRC_URI[sha256sum] = "42c15ed555719c27f67990454cdda791cbcd26ab98712fd88ca7e20e6ce3f1fd"
diff --git a/recipes-qtopia/qpf-fonts/qpf-bitstream-vera_1.10.bb b/recipes-qtopia/qpf-fonts/qpf-bitstream-vera_1.10.bb
new file mode 100644
index 0000000..29e3f62
--- /dev/null
+++ b/recipes-qtopia/qpf-fonts/qpf-bitstream-vera_1.10.bb
@@ -0,0 +1,27 @@
+require qpf.inc
+
+DESCRIPTION = "The Bitstream Vera fonts - QPF Edition"
+LICENSE = "Bitstream Vera"
+PR = "r3"
+
+PROVIDES = "qpf-bitstream-vera-small qpf-bitstream-vera-large"
+
+SRC_URI = "http://openzaurus.org/mirror/vera-qpf_1.10-3.tar.gz"
+S = "${WORKDIR}/vera-qpf"
+
+PACKAGES = "${PN}-dbg qpf-bitstream-vera-small qpf-bitstream-vera-large ${PN}"
+
+FILES_qpf-bitstream-vera-small = "${palmqtdir}/lib/fonts/vera_80_50* \
+${palmqtdir}/lib/fonts/vera_80_50i* ${palmqtdir}/lib/fonts/vera_80_75* ${palmqtdir}/lib/fonts/vera_80_75i* \
+${palmqtdir}/lib/fonts/vera_100_50* ${palmqtdir}/lib/fonts/vera_100_50i* ${palmqtdir}/lib/fonts/vera_100_75* \
+${palmqtdir}/lib/fonts/vera_100_75i* ${palmqtdir}/lib/fonts/vera_120_50* ${palmqtdir}/lib/fonts/vera_120_50i* \
+${palmqtdir}/lib/fonts/vera_120_75* ${palmqtdir}/lib/fonts/vera_120_75i*"
+
+FILES_qpf-bitstream-vera-large = "${palmqtdir}/lib/fonts/vera_140_50* ${palmqtdir}/lib/fonts/vera_140_50i* \
+${palmqtdir}/lib/fonts/vera_140_75* \
+${palmqtdir}/lib/fonts/vera_140_75i* ${palmqtdir}/lib/fonts/vera_160_50* ${palmqtdir}/lib/fonts/vera_160_50i* \
+${palmqtdir}/lib/fonts/vera_160_75* ${palmqtdir}/lib/fonts/vera_160_75i* ${palmqtdir}/lib/fonts/vera_180_50* \
+${palmqtdir}/lib/fonts/vera_180_50i* ${palmqtdir}/lib/fonts/vera_180_75* ${palmqtdir}/lib/fonts/vera_180_75i*"
+
+SRC_URI[md5sum] = "13327e7086fa5ceec44550745a914f42"
+SRC_URI[sha256sum] = "1ca61d438f3e5f4b7af853b48e16d68b226d568cd12eda36b94ffbf3cb9458c1"
diff --git a/recipes-qtopia/qpf-fonts/qpf-font-common_1.0.bb b/recipes-qtopia/qpf-fonts/qpf-font-common_1.0.bb
new file mode 100644
index 0000000..ba4f086
--- /dev/null
+++ b/recipes-qtopia/qpf-fonts/qpf-font-common_1.0.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Common files for Qt/Embedded fonts"
+LICENSE = "GPL QPL"
+PR = "r4"
+
+SRC_URI = "file://update-qtfontdir"
+S = "${WORKDIR}/qt-${PV}"
+
+do_install() {
+ install -d ${D}${sbindir}/
+ install -m 0755 ${WORKDIR}/update-qtfontdir ${D}${sbindir}/
+ sed -i -e 's,@palmtopdir@,${palmtopdir},g' ${D}${sbindir}/update-qtfontdir
+}
+
+PACKAGE_ARCH = "all"
diff --git a/recipes-qtopia/qpf-fonts/qpf-freemono_1.0.bb b/recipes-qtopia/qpf-fonts/qpf-freemono_1.0.bb
new file mode 100644
index 0000000..f1a5ece
--- /dev/null
+++ b/recipes-qtopia/qpf-fonts/qpf-freemono_1.0.bb
@@ -0,0 +1,13 @@
+require qpf.inc
+
+DESCRIPTION = "FreeMono font - QPF Edition"
+HOMEPAGE = "http://savannah.nongnu.org/projects/freefont/"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://www.openzaurus.org/download/3.5.4/sources/${PN}-${PV}.tar.bz2"
+
+S = "${WORKDIR}/${PN}"
+
+SRC_URI[md5sum] = "28688d47cd80d3a6bb833adb22292e15"
+SRC_URI[sha256sum] = "5ac0513efe6270d45a2ada5dc653c434677da4282e026d8c1a9c156cd99e11c8"
diff --git a/recipes-qtopia/qpf-fonts/qpf-freeserif_1.0.bb b/recipes-qtopia/qpf-fonts/qpf-freeserif_1.0.bb
new file mode 100644
index 0000000..cd7e7f4
--- /dev/null
+++ b/recipes-qtopia/qpf-fonts/qpf-freeserif_1.0.bb
@@ -0,0 +1,13 @@
+require qpf.inc
+
+DESCRIPTION = "FreeSerif font - QPF Edition"
+HOMEPAGE = "http://savannah.nongnu.org/projects/freefont/"
+LICENSE = "GPL"
+PR = "r3"
+
+SRC_URI = "http://www.openzaurus.org/download/3.5.4/sources/${PN}-${PV}.tar.bz2"
+
+S = "${WORKDIR}/${PN}"
+
+SRC_URI[md5sum] = "a7fa0210e02f42d5b14245e260bc72c3"
+SRC_URI[sha256sum] = "c8ee6e5e62b0a182dbee85865e56b1572e6875769b8256b39c75b2334a283e45"
diff --git a/recipes-qtopia/qpf-fonts/qpf-helvetica_1.0.bb b/recipes-qtopia/qpf-fonts/qpf-helvetica_1.0.bb
new file mode 100644
index 0000000..306c116
--- /dev/null
+++ b/recipes-qtopia/qpf-fonts/qpf-helvetica_1.0.bb
@@ -0,0 +1,12 @@
+require qpf.inc
+
+DESCRIPTION = "Helvetica fonts - QPF Edition"
+HOMEPAGE = "http://www.pobox.sk/~mico/zaurus.html"
+LICENSE = "GPL QPL"
+PR = "r2"
+
+SRC_URI = "http://www.openzaurus.org/download/3.5.4/sources/qpf-helvetica.tar.bz2"
+S = "${WORKDIR}/helvetica"
+
+SRC_URI[md5sum] = "20c040a004f4949b6849658148a78388"
+SRC_URI[sha256sum] = "4b6a122b4f95cf90f9639ca423947e70bba4e567099f9baeada419a51b11924b"
diff --git a/recipes-qtopia/qpf-fonts/qpf-hunkysans_0.3.0.bb b/recipes-qtopia/qpf-fonts/qpf-hunkysans_0.3.0.bb
new file mode 100644
index 0000000..0cef7f6
--- /dev/null
+++ b/recipes-qtopia/qpf-fonts/qpf-hunkysans_0.3.0.bb
@@ -0,0 +1,13 @@
+require qpf.inc
+
+DESCRIPTION = "Hunky Sans font - QPF Edition"
+HOMEPAGE = "http://www.yoper.com/ariszlo/hunky.html http://sourceforge.net/projects/hunkyfonts"
+LICENSE = "LGPL"
+PR = "r6"
+
+SRC_URI = "http://www.openzaurus.org/download/3.5.4/sources/${PN}-${PV}-r4.tar.bz2"
+
+S = "${WORKDIR}/${PN}"
+
+SRC_URI[md5sum] = "917d7f8f3ad3c5b94c747b37d0a5e74a"
+SRC_URI[sha256sum] = "c3cdd8f234cbc1694af777dc1739ca4439cd472567d85f333dc11264d6bda7c8"
diff --git a/recipes-qtopia/qpf-fonts/qpf-hunkyserif_0.3.0.bb b/recipes-qtopia/qpf-fonts/qpf-hunkyserif_0.3.0.bb
new file mode 100644
index 0000000..e018e0d
--- /dev/null
+++ b/recipes-qtopia/qpf-fonts/qpf-hunkyserif_0.3.0.bb
@@ -0,0 +1,13 @@
+require qpf.inc
+
+DESCRIPTION = "Hunky Serif font - QPF Edition"
+HOMEPAGE = "http://www.yoper.com/ariszlo/hunky.html http://sourceforge.net/projects/hunkyfonts"
+LICENSE = "LGPL"
+PR = "r6"
+
+SRC_URI = "http://www.openzaurus.org/download/3.5.4/sources/${PN}-${PV}-r4.tar.bz2"
+
+S = "${WORKDIR}/${PN}"
+
+SRC_URI[md5sum] = "02b38aeaf30c17e15b714b9594ca504d"
+SRC_URI[sha256sum] = "3c5890d6b0aee2d4c1e0c6b8101b6b5381985e86bc50dffc338b8601f4aa7ae8"
diff --git a/recipes-qtopia/qpf-fonts/qpf-qte_2.3.10.bb b/recipes-qtopia/qpf-fonts/qpf-qte_2.3.10.bb
new file mode 100644
index 0000000..07b6fbb
--- /dev/null
+++ b/recipes-qtopia/qpf-fonts/qpf-qte_2.3.10.bb
@@ -0,0 +1,38 @@
+require qpf.inc
+
+DESCRIPTION = "Qt/Embedded fonts version ${PV}"
+HOMEPAGE = "http://www.trolltech.com"
+LICENSE = "GPL QPL"
+PR = "r2"
+
+PROVIDES = "qte-font-helvetica-100 qte-font-helvetica-120"
+PROVIDES += "qte-font-fixed-70 qte-font-fixed-120"
+PROVIDES += "qte-font-helvetica-80 qte-font-helvetica-140 qte-font-helvetica-180 qte-font-helvetica-240"
+PROVIDES += "qte-font-smallsmooth-90"
+PROVIDES += "qte-font-micro-40"
+PROVIDES += "qte-font-japanese-230"
+PROVIDES += "qte-font-smoothmono-90 qte-font-smoothmono-100 qte-font-smoothmono-110 qte-font-smoothmono-120"
+PROVIDES += "qte-font-smoothmono-140 qte-font-smoothmono-180 qte-font-smoothmono-240"
+PROVIDES += "qte-font-smoothsans-90 qte-font-smoothsans-100 qte-font-smoothsans-110 qte-font-smoothsans-120"
+PROVIDES += "qte-font-smoothsans-140 qte-font-smoothsans-180 qte-font-smoothsans-240"
+PROVIDES += "qte-font-smoothserif-90 qte-font-smoothserif-100 qte-font-smoothserif-110 qte-font-smoothserif-120"
+PROVIDES += "qte-font-smoothserif-140 qte-font-smoothserif-180 qte-font-smoothserif-240"
+PROVIDES += "qte-font-smoothtimes-100 qte-font-smoothtimes-160 qte-font-smoothtimes-170"
+PROVIDES += "qte-font-smoothtimes-220 qte-font-smoothtimes-250 qte-font-smoothtimes-440"
+PROVIDES += "qte-font-unifont"
+RPROVIDES_qte-font-unifont += "virtual-japanese-font"
+RPROVIDES_qte-font-japanese += "virtual-japanese-font"
+
+SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-${PV}-free.tar.gz"
+S = "${WORKDIR}/qt-${PV}"
+
+QPF_PKGPATTERN = "qte-font-%s"
+QPF_DESCRIPTION = "Qt/E font %s"
+
+do_install() {
+ install -d ${D}${palmqtdir}/lib/fonts/
+ cp -pPR lib/fonts/* ${D}${palmqtdir}/lib/fonts/
+}
+
+SRC_URI[md5sum] = "1f7ad30113afc500cab7f5b2f4dec0d7"
+SRC_URI[sha256sum] = "883363eb0c94de3d1e36f3ab9e09a8f127418d497213cc1a0ed1a1588ecd66b8"
diff --git a/recipes-qtopia/qpf-fonts/qpf-qte_3.3.5.bb b/recipes-qtopia/qpf-fonts/qpf-qte_3.3.5.bb
new file mode 100644
index 0000000..b467271
--- /dev/null
+++ b/recipes-qtopia/qpf-fonts/qpf-qte_3.3.5.bb
@@ -0,0 +1,60 @@
+require qpf.inc
+
+DESCRIPTION = "Qt/Embedded fonts version ${PV}"
+HOMEPAGE = "http://www.trolltech.com"
+LICENSE = "GPL QPL"
+PR = "r6"
+
+SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-free-${PV}.tar.bz2"
+S = "${WORKDIR}/qt-embedded-free-${PV}"
+
+do_compile() {
+ :
+}
+
+do_install() {
+ mkdir -p ${D}${sbindir}
+ mkdir -p ${D}${palmtopdir}/lib/fonts
+ cp -pPR lib/fonts/* ${D}${palmtopdir}/lib/fonts
+ # Delete all other font formats, Qt/E would have a dead slow
+ # application start time if it had to use any other font format
+ # as *.qpf ...
+ find ${D}${palmtopdir}/lib/fonts \
+ -name "*.bdf" \
+ -o -name "*.ttf" \
+ -o -name "*.pfa" \
+ -o -name "*.pfb" | xargs rm
+}
+
+PACKAGES = "qte-font-fixed"
+PROVIDES += "qte-font-fixed"
+FILES_qte-font-fixed = "${palmtopdir}/lib/fonts/fixed*"
+
+PACKAGES += "qte-font-helvetica-small"
+PROVIDES += "qte-font-helvetica-small"
+FILES_qte-font-helvetica-small = "${palmtopdir}/lib/fonts/helvetica_80*.qpf \
+ ${palmtopdir}/lib/fonts/helvetica_100*.qpf ${palmtopdir}/lib/fonts/helvetica_120*.qpf"
+
+PACKAGES += "qte-font-helvetica-large"
+PROVIDES += "qte-font-helvetica-large"
+FILES_qte-font-helvetica-large = "${palmtopdir}/lib/fonts/helvetica_140*.qpf \
+ ${palmtopdir}/lib/fonts/helvetica_180*.qpf ${palmtopdir}/lib/fonts/helvetica_240*.qpf"
+
+PACKAGES += "qte-font-smoothtimes"
+PROVIDES += "qte-font-smoothtimes"
+FILES_qte-font-smoothtimes = "${palmtopdir}/lib/fonts/smoothtimes*"
+
+PACKAGES += "qte-font-smallsmooth"
+PROVIDES += "qte-font-smallsmooth"
+FILES_qte-font-smallsmooth = "${palmtopdir}/lib/fonts/smallsmooth*"
+
+PACKAGES += "qte-font-unicode"
+PROVIDES += "qte-font-unicode"
+FILES_qte-font-unicode = "${palmtopdir}/lib/fonts/unifont*.qpf"
+
+PACKAGES += "qte-font-micro"
+PROVIDES += "qte-font-micro"
+FILES_qte-font-micro = "${palmtopdir}/lib/fonts/micro*.qpf"
+
+SRC_URI[md5sum] = "022d7a3c572b554f3c47b12cae71a8a4"
+SRC_URI[sha256sum] = "a97656796c0ef8e87dd83e6138bc406e31830d08f9b213e039d8be39ea65c8e4"
diff --git a/recipes-qtopia/qpf-fonts/qpf-terminus.bb b/recipes-qtopia/qpf-fonts/qpf-terminus.bb
new file mode 100644
index 0000000..cef1425
--- /dev/null
+++ b/recipes-qtopia/qpf-fonts/qpf-terminus.bb
@@ -0,0 +1,13 @@
+require qpf.inc
+
+DESCRIPTION = "Qt/Embedded terminus font"
+HOMEPAGE = "http://www.is-vn.bg/hamster/jimmy-en.html"
+LICENSE = "GPL"
+PR = "r3"
+
+#SRC_URI = "http://www.mn-solutions.de/downloads/mnci/terminus-fonts.tar.bz2" -> 404 error
+SRC_URI = "http://openzaurus.linuxtogo.org/download/3.5.4/sources/terminus-fonts.tar.bz2"
+S = "${WORKDIR}/terminus-fonts"
+
+SRC_URI[md5sum] = "e7b056a7619cdd460b5db5a7e263cafc"
+SRC_URI[sha256sum] = "cf7becd610e298d23780216f474907745bd29484f7f81308a9d13cf07f2a4e2d"
diff --git a/recipes-qtopia/qpf-fonts/qpf-unifont_1.0.bb b/recipes-qtopia/qpf-fonts/qpf-unifont_1.0.bb
new file mode 100644
index 0000000..5509d63
--- /dev/null
+++ b/recipes-qtopia/qpf-fonts/qpf-unifont_1.0.bb
@@ -0,0 +1,11 @@
+require qpf.inc
+
+DESCRIPTION = "Unicode fonts - QPF Edition"
+LICENSE = "GPL QPL"
+RPROVIDES_${PN} = "virtual-japanese-font"
+PR = "r3"
+
+SRC_URI = "http://www.openzaurus.org/mirror/qpf-unifont.tar.bz2;subdir=${BPN}-${PV}"
+
+SRC_URI[md5sum] = "92f6df1c5edb26351332df4f576dbb10"
+SRC_URI[sha256sum] = "c1c5b5ab3431896502c9275daeb47610fb2a840faa6d580e140909a3f4ef7391"
diff --git a/recipes-qtopia/qpf-fonts/qpf-unismall_1.0.0.bb b/recipes-qtopia/qpf-fonts/qpf-unismall_1.0.0.bb
new file mode 100644
index 0000000..26fb7ce
--- /dev/null
+++ b/recipes-qtopia/qpf-fonts/qpf-unismall_1.0.0.bb
@@ -0,0 +1,12 @@
+require qpf.inc
+
+DESCRIPTION = "Lightweight Japanese font in 10 point suitable for 320x240 display"
+HOMEPAGE = "http://sourceforge.jp/projects/zaurus-ja/"
+LICENSE = "GPL"
+RPROVIDES_${PN} = "virtual-japanese-font"
+PR = "r5"
+
+SRC_URI = "http://osdn.dl.sourceforge.jp/zaurus-ja/773/unismall-${PV}.tar.gz;subdir=${BPN}-${PV}"
+
+SRC_URI[md5sum] = "fb608934ab87ad5203aebb85c2d130c7"
+SRC_URI[sha256sum] = "9f60583875713e7d45797f25c321c1bb36f43afbbe3c4ab4fd1f58c157022eb6"
diff --git a/recipes-qtopia/qpf-fonts/qpf-utopia_1.0.bb b/recipes-qtopia/qpf-fonts/qpf-utopia_1.0.bb
new file mode 100644
index 0000000..d936ba7
--- /dev/null
+++ b/recipes-qtopia/qpf-fonts/qpf-utopia_1.0.bb
@@ -0,0 +1,12 @@
+require qpf.inc
+
+DESCRIPTION = "Utopia fonts - QPF Edition"
+HOMEPAGE = "http://www.pobox.sk/~mico/zaurus.html"
+LICENSE = "GPL QPL"
+PR = "r2"
+
+SRC_URI = "http://www.openzaurus.org/download/3.5.4/sources/qpf-utopia.tar.bz2"
+S = "${WORKDIR}/utopia"
+
+SRC_URI[md5sum] = "fa2563f3c2332c5bcb05add075908f1e"
+SRC_URI[sha256sum] = "599eed45edc9942f4b37858507c2223cb8decb13fea180cf33c6961ad48a33d1"
diff --git a/recipes-qtopia/qpf-fonts/qpf.inc b/recipes-qtopia/qpf-fonts/qpf.inc
new file mode 100644
index 0000000..c2ff3c1
--- /dev/null
+++ b/recipes-qtopia/qpf-fonts/qpf.inc
@@ -0,0 +1,32 @@
+RDEPENDS_${PN} = "font-update-common qpf-font-common"
+
+do_configure() {
+ :
+}
+
+do_compile() {
+ :
+}
+
+pkg_postinst_fonts() {
+ update-fonts
+}
+
+pkg_postrm_fonts() {
+ update-fonts
+}
+
+python populate_packages_prepend() {
+ postinst = bb.data.getVar('pkg_postinst_fonts', d, 1)
+ postrm = bb.data.getVar('pkg_postrm_fonts', d, 1)
+ fontdir = bb.data.getVar('palmtopdir', d, 1) + '/lib/fonts'
+ pkgregex = "^([a-z-]*_[0-9]*).*.qpf$"
+ pkgpattern = bb.data.getVar('QPF_PKGPATTERN', d, 1) or 'qpf-%s'
+ pkgdescription = bb.data.getVar('QPF_DESCRIPTION', d, 1) or 'QPF font %s'
+
+ do_split_packages(d, root=fontdir, file_regex=pkgregex, output_pattern=pkgpattern,
+ description=pkgdescription, postinst=postinst, postrm=postrm, recursive=True, hook=None,
+ extra_depends='qpf-font-common')
+}
+
+PACKAGE_ARCH = "all"