aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/qpe-games/aliens-qt_1.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qtopia/qpe-games/aliens-qt_1.0.0.bb')
-rw-r--r--recipes-qtopia/qpe-games/aliens-qt_1.0.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-qtopia/qpe-games/aliens-qt_1.0.0.bb b/recipes-qtopia/qpe-games/aliens-qt_1.0.0.bb
new file mode 100644
index 0000000..9555fa7
--- /dev/null
+++ b/recipes-qtopia/qpe-games/aliens-qt_1.0.0.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Alien ShootOut"
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+AUTHOR = "Bill Kendrick"
+HOMEPAGE = "http://www.linux-solutions.at/projects/zaurus/games-Aliens.html"
+
+
+SRC_URI = "http://handhelds.org/~zecke/oe_packages/aliens_V1.0.0.tar.gz \
+ file://Makefile.patch \
+ file://aliens.patch"
+
+PV = "1.0.0"
+S = "${WORKDIR}/aliens_V${PV}"
+
+APPNAME = "aliens"
+APPTYPE = "binary"
+APPDESKTOP = "${S}"
+
+do_compile_prepend () {
+ oe_runmake -C images
+}
+
+do_install () {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${S}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+
+}
+
+inherit opie
+
+
+SRC_URI[md5sum] = "9d7cde75aecf4b85478c0e47343d4293"
+SRC_URI[sha256sum] = "0aa0084a74f912f4002f1c40a815ce62ac13331ec84787a954d8bea06e1c96c5"