aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/puzz-le/puzz-le_2.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qtopia/puzz-le/puzz-le_2.0.0.bb')
-rw-r--r--recipes-qtopia/puzz-le/puzz-le_2.0.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-qtopia/puzz-le/puzz-le_2.0.0.bb b/recipes-qtopia/puzz-le/puzz-le_2.0.0.bb
new file mode 100644
index 0000000..a2fb02e
--- /dev/null
+++ b/recipes-qtopia/puzz-le/puzz-le_2.0.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Puzz-le is a colorful arcade logic game for Qt/Embedded based Palmtop Environments."
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+PR = "r1"
+
+SRC_URI = "http://www.warmi.net/zaurus/files/puzz-le_${PV}.tar.gz \
+ file://gcc3.patch"
+S = "${WORKDIR}/puzzle_arm"
+
+inherit palmtop
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin
+ install -m 0755 puzz-le ${D}${palmtopdir}/bin/
+ cp -pPR Qtopia/puzz-le/opt/QtPalmtop/* ${D}${palmtopdir}/
+}
+
+SRC_URI[md5sum] = "76535893b779926874f618d3fbf3e92b"
+SRC_URI[sha256sum] = "e4b4217b81ab0885db11cf7e0f18afdeaa969392fc15647a10c2aab9cbf583d8"