aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/hotplug-qcop/hotplug-qcop_cvs.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qtopia/hotplug-qcop/hotplug-qcop_cvs.bb')
-rw-r--r--recipes-qtopia/hotplug-qcop/hotplug-qcop_cvs.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-qtopia/hotplug-qcop/hotplug-qcop_cvs.bb b/recipes-qtopia/hotplug-qcop/hotplug-qcop_cvs.bb
new file mode 100644
index 0000000..cb2e9e2
--- /dev/null
+++ b/recipes-qtopia/hotplug-qcop/hotplug-qcop_cvs.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "HotPlug -> QCOP Event Bridge"
+SECTION = "opie/base"
+RDEPENDS_${PN} = "opie-qcop hotplug"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=core/tools/hotplug-qcop"
+S = "${WORKDIR}/hotplug-qcop"
+
+inherit opie
+
+sbindir="/sbin"
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 hotplug-qcop ${D}${sbindir}
+
+ install -d ${D}${sysconfdir}/hotplug.d/default/
+ ln -sf /sbin/hotplug-qcop ${D}${sysconfdir}/hotplug.d/default/11-qcop.hotplug
+}
+
+FILES_${PN} = "${sysconfdir} ${sbindir}"