aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/uicmoc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/uicmoc')
-rw-r--r--recipes-qt/uicmoc/uicmoc-2.3.10/gcc4.7.patch11
-rw-r--r--recipes-qt/uicmoc/uicmoc_2.3.10.bb1
2 files changed, 12 insertions, 0 deletions
diff --git a/recipes-qt/uicmoc/uicmoc-2.3.10/gcc4.7.patch b/recipes-qt/uicmoc/uicmoc-2.3.10/gcc4.7.patch
new file mode 100644
index 0000000..ad09bfe
--- /dev/null
+++ b/recipes-qt/uicmoc/uicmoc-2.3.10/gcc4.7.patch
@@ -0,0 +1,11 @@
+--- qt-2.3.10/src/tools/qvaluestack.h.orig 2013-04-23 21:04:50.373589050 +0200
++++ qt-2.3.10/src/tools/qvaluestack.h 2013-04-23 21:33:48.857599178 +0200
+@@ -49,7 +49,7 @@
+ public:
+ QValueStack() {}
+ ~QValueStack() {}
+- void push( const T& d ) { append(d); }
++ void push( const T& d ) { this->append(d); }
+ T pop()
+ {
+ T elem( this->last() );
diff --git a/recipes-qt/uicmoc/uicmoc_2.3.10.bb b/recipes-qt/uicmoc/uicmoc_2.3.10.bb
index ca6a7a1..0588436 100644
--- a/recipes-qt/uicmoc/uicmoc_2.3.10.bb
+++ b/recipes-qt/uicmoc/uicmoc_2.3.10.bb
@@ -9,6 +9,7 @@ SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-${PV}-free.tar.gz \
file://gcc3_4.patch \
file://gcc4.patch \
file://gcc4_1.patch \
+ file://gcc4.7.patch \
file://64bit-cleanup.patch \
file://kernel-asm-page.patch"
S = "${WORKDIR}/qt-${PV}"