aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/zten
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/zten
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/zten')
-rw-r--r--recipes-qtopia/zten/files/zten.patch37
-rw-r--r--recipes-qtopia/zten/zten_1.6.2.bb32
2 files changed, 69 insertions, 0 deletions
diff --git a/recipes-qtopia/zten/files/zten.patch b/recipes-qtopia/zten/files/zten.patch
new file mode 100644
index 0000000..3fff27a
--- /dev/null
+++ b/recipes-qtopia/zten/files/zten.patch
@@ -0,0 +1,37 @@
+upstream: no upstream bug tracker. Laibsch contacted author by mail on 2008-02-17.
+
+--- zten/zten.pro.orig 2003-02-16 16:45:44.000000000 +0100
++++ zten/zten.pro 2006-04-23 18:50:19.000000000 +0200
+@@ -1,11 +1,9 @@
+ TEMPLATE = app
+ CONFIG = qt warn_on release
+-HEADERS = pixmap.h \
+- qbookbrowser.h \
++HEADERS = qbookbrowser.h \
+ qbookentry.h \
+ qbookitem.h \
+ qhistorylineedit.h \
+- qlabeledit.h \
+ qlistboxrichtext.h \
+ zpixmap.h \
+ zten.h \
+@@ -29,5 +27,5 @@
+ ztenbookbase.ui \
+ ztencandidatebase.ui \
+ ztenextbase.ui
+-LIBS += -lqpe /opt/Embedix/lib/libeb.a /opt/Embedix/lib/libz.a -L/opt/QtPalmtop/lib -lkakasi
++LIBS += -lqpe -leb -lz -lkakasi
+ TRANSLATIONS = zten.ts
+
+--- zten/qbookentry.cpp.orig 2006-04-23 23:38:00.000000000 +0200
++++ zten/qbookentry.cpp 2006-04-23 23:38:10.000000000 +0200
+@@ -14,7 +14,8 @@
+ }
+
+ static const char* INSERT_MARK = "\a";
+-QTextCodec* g_codec;
++//QTextCodec* g_codec = NULL;
++QTextCodec* g_codec = QTextCodec::codecForName("eucJP");
+ unsigned int last_wide_font = 0;
+ unsigned int last_narrow_font = 0;
+
diff --git a/recipes-qtopia/zten/zten_1.6.2.bb b/recipes-qtopia/zten/zten_1.6.2.bb
new file mode 100644
index 0000000..2250811
--- /dev/null
+++ b/recipes-qtopia/zten/zten_1.6.2.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "EB*/EPWING dictionary browser for Linux Zaurus"
+AUTHOR = "Yuuichi Teranishi <teranisi@gohome.org>"
+HOMEPAGE = "http://www.gohome.org/zten"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "eb kakasi"
+RDEPENDS_${PN} = "virtual-japanese-font"
+RCONFLICTS_${PN} = "ztenv"
+PR = "r2"
+
+SRC_URI = "http://www.gohome.org/cgi-bin/viewcvs.cgi/zten.tar.gz;md5sum=d24f03c8df5c98d510590bd9a63dc932 \
+ file://zten.patch"
+
+S = "${WORKDIR}/zten"
+
+inherit palmtop
+
+CXXFLAGS += " -DQWS"
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin
+ install -d ${D}${palmtopdir}/apps/Applications
+ install -d ${D}${palmtopdir}/pics
+ install -m 0755 zten ${D}${palmtopdir}/bin/zten
+ install -m 0644 zten.desktop ${D}${palmtopdir}/apps/Applications/
+ install -m 0644 Zten.png ${D}${palmtopdir}/pics
+}
+
+
+SRC_URI[md5sum] = "d24f03c8df5c98d510590bd9a63dc932"
+SRC_URI[sha256sum] = "7fa88dcb6da482bc20fc4916f191e9c35d01b3c0f45c9bcd66067029c49cc0b4"