aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/zddice
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/zddice
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/zddice')
-rw-r--r--recipes-qtopia/zddice/zddice-1.0.0/qtopia17.patch25
-rw-r--r--recipes-qtopia/zddice/zddice_1.0.0.bb23
2 files changed, 48 insertions, 0 deletions
diff --git a/recipes-qtopia/zddice/zddice-1.0.0/qtopia17.patch b/recipes-qtopia/zddice/zddice-1.0.0/qtopia17.patch
new file mode 100644
index 0000000..7aea580
--- /dev/null
+++ b/recipes-qtopia/zddice/zddice-1.0.0/qtopia17.patch
@@ -0,0 +1,25 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- zddice-src/zddice_main.cpp~qtopia17 2004-04-15 04:44:10.000000000 +0200
++++ zddice-src/zddice_main.cpp 2004-04-18 12:54:08.000000000 +0200
+@@ -1,5 +1,15 @@
+ #include "zddice.h"
+ #include <qpe/qpeapplication.h>
+
+-QTOPIA_ADD_APPLICATION("zddice", zddice)
+-QTOPIA_MAIN
++//QTOPIA_ADD_APPLICATION("zddice", zddice)
++//QTOPIA_MAIN
++
++int main(int argc, char** argv)
++{
++ QPEApplication a( argc, argv );
++ zddice* w = new zddice();
++ a.showMainWidget( w );
++ a.exec();
++}
++
++
diff --git a/recipes-qtopia/zddice/zddice_1.0.0.bb b/recipes-qtopia/zddice/zddice_1.0.0.bb
new file mode 100644
index 0000000..b8c94ce
--- /dev/null
+++ b/recipes-qtopia/zddice/zddice_1.0.0.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Zaurus D20 Gaming Dice for Qt/Embedded based Palmtop Environments"
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://www.cinlug.org/modules/Static_Docs/data/db/zddice/zddice_${PV}_arm.src.tar.gz \
+ file://qtopia17.patch"
+S = "${WORKDIR}/zddice-src"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST += 'TMAKE_LIBS-="-luuid" TMAKE_LIBS+="-lqpe" CONFIG+=qt CONFIG-=qtopia'
+
+do_install() {
+ install -d ${D}${palmtopdir}/{bin,pics,apps/Games}
+ install -m 0755 zddice ${D}${palmtopdir}/bin/
+ install -m 0644 images/zddice.png ${D}${palmtopdir}/pics/
+ install -m 0644 zddice.desktop ${D}${palmtopdir}/apps/Games/
+}
+
+SRC_URI[md5sum] = "791e8986c6e16dcd1c9878126725e06b"
+SRC_URI[sha256sum] = "eba57692dadd21df8d4afaea4daf8db5179c7398e11cd019fd462aa6947f4119"