aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/qpegps
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/qpegps
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/qpegps')
-rw-r--r--recipes-qtopia/qpegps/files/qpegps.desktop6
-rw-r--r--recipes-qtopia/qpegps/files/qpegps.pngbin0 -> 3606 bytes
-rw-r--r--recipes-qtopia/qpegps/qpegps.inc37
-rw-r--r--recipes-qtopia/qpegps/qpegps_0.9.2.3.3.bb6
-rw-r--r--recipes-qtopia/qpegps/qpegps_0.9.3.1.bb11
-rw-r--r--recipes-qtopia/qpegps/qpegps_svn.bb15
6 files changed, 75 insertions, 0 deletions
diff --git a/recipes-qtopia/qpegps/files/qpegps.desktop b/recipes-qtopia/qpegps/files/qpegps.desktop
new file mode 100644
index 0000000..de5a93c
--- /dev/null
+++ b/recipes-qtopia/qpegps/files/qpegps.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Comment=Moving Map
+Exec=qpegps
+Icon=qpegps
+Type=Application
+Name=qpeGPS
diff --git a/recipes-qtopia/qpegps/files/qpegps.png b/recipes-qtopia/qpegps/files/qpegps.png
new file mode 100644
index 0000000..211980e
--- /dev/null
+++ b/recipes-qtopia/qpegps/files/qpegps.png
Binary files differ
diff --git a/recipes-qtopia/qpegps/qpegps.inc b/recipes-qtopia/qpegps/qpegps.inc
new file mode 100644
index 0000000..68baf8c
--- /dev/null
+++ b/recipes-qtopia/qpegps/qpegps.inc
@@ -0,0 +1,37 @@
+DESCRIPTION = "A GPS navigation application for the Opie environment"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://qpegps.sourceforge.net/"
+
+DEPENDS = "gpsd"
+RRECOMMENDS_${PN} = "gpsd"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/qpegps/qpegps_${PV}_src.zip \
+ file://qpegps.desktop \
+ file://qpegps.png"
+S = "${WORKDIR}/qpegps"
+
+inherit palmtop
+
+QMAKE_PROFILES = "qpegps.pro"
+EXTRA_QMAKEVARS_POST = "LIBS=-lqpe LIBS+=-lgps"
+OE_QMAKE_CFLAGS += " -DQWS "
+OE_QMAKE_LIBS_QT = ${QT_LIBRARY}
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Applications \
+ ${D}${palmtopdir}/pics \
+ ${D}${palmtopdir}/help/html/qpegps_icons \
+ ${D}${palmtopdir}/qpegps/maps \
+ ${D}${palmtopdir}/qpegps/icons \
+ ${D}${palmtopdir}/qpegps/tracks
+ install -m 0755 qpegps ${D}${palmtopdir}/bin/
+ install -m 0644 ${WORKDIR}/qpegps.desktop ${D}${palmtopdir}/apps/Applications/
+ install -m 0644 ${WORKDIR}/qpegps.png ${D}${palmtopdir}/pics/
+ install -m 0644 doc/qpegps.html ${D}${palmtopdir}/help/html/
+ install -m 0644 doc/qpegps_icons/*.png ${D}${palmtopdir}/help/html/qpegps_icons/
+ install -m 0644 icons/*.xpm ${D}${palmtopdir}/qpegps/icons/
+ install -m 0644 datum/*.dat ${D}${palmtopdir}/qpegps/
+}
diff --git a/recipes-qtopia/qpegps/qpegps_0.9.2.3.3.bb b/recipes-qtopia/qpegps/qpegps_0.9.2.3.3.bb
new file mode 100644
index 0000000..7cf6a84
--- /dev/null
+++ b/recipes-qtopia/qpegps/qpegps_0.9.2.3.3.bb
@@ -0,0 +1,6 @@
+require qpegps.inc
+
+PR = "r1"
+
+SRC_URI[md5sum] = "974ff064b13640329da21f565ac351e6"
+SRC_URI[sha256sum] = "5b070799c3eebf1dd94b1d800da0d532d2e9c353e061d4addc3466232e4a3072"
diff --git a/recipes-qtopia/qpegps/qpegps_0.9.3.1.bb b/recipes-qtopia/qpegps/qpegps_0.9.3.1.bb
new file mode 100644
index 0000000..675d33c
--- /dev/null
+++ b/recipes-qtopia/qpegps/qpegps_0.9.3.1.bb
@@ -0,0 +1,11 @@
+require qpegps.inc
+
+PR = "r1"
+
+do_configure_prepend() {
+ mv ${S}/Place.cpp ${S}/place.cpp
+ mv ${S}/Place.h ${S}/place.h
+}
+
+SRC_URI[md5sum] = "71b270b75bd773b81be3aaa0e4fc88cd"
+SRC_URI[sha256sum] = "f186ef1f117d3a9a9374ac19cfc8daad40a522638e5a758ec79fdd79fac351f4"
diff --git a/recipes-qtopia/qpegps/qpegps_svn.bb b/recipes-qtopia/qpegps/qpegps_svn.bb
new file mode 100644
index 0000000..3ae1d58
--- /dev/null
+++ b/recipes-qtopia/qpegps/qpegps_svn.bb
@@ -0,0 +1,15 @@
+require qpegps.inc
+
+PV = "0.0+svn${SRCDATE}"
+PR = "r1"
+
+SRC_URI = "svn://qpegps.svn.sourceforge.net/svnroot/;module=qpegps/trunk/qpegps;proto=https \
+ file://qpegps.desktop \
+ file://qpegps.png "
+
+S = "${WORKDIR}/qpegps/trunk/qpegps"
+
+do_configure_prepend() {
+ mv ${S}/Place.cpp ${S}/place.cpp
+ mv ${S}/Place.h ${S}/place.h
+}