aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/qpe-games/zrev7_1.0.1.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/qpe-games/zrev7_1.0.1.bb
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/qpe-games/zrev7_1.0.1.bb')
-rw-r--r--recipes-qtopia/qpe-games/zrev7_1.0.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-qtopia/qpe-games/zrev7_1.0.1.bb b/recipes-qtopia/qpe-games/zrev7_1.0.1.bb
new file mode 100644
index 0000000..b2b4429
--- /dev/null
+++ b/recipes-qtopia/qpe-games/zrev7_1.0.1.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Reversi"
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+AUTHOR = "Mario Weilguni"
+HOMEPAGE = "http://www.linux-solutions.at/projects/zaurus/games-ZRev7.html"
+PR = "r1"
+
+SRC_URI = "http://handhelds.org/~zecke/oe_packages/zrev7_V1.0.1.tar.gz \
+ file://zrev.patch"
+S = "${WORKDIR}/zrev7_V${PV}"
+
+APPNAME = "zrev7"
+APPTYPE = "binary"
+APPDESKTOP = "${S}"
+
+inherit opie
+
+do_compile_prepend() {
+ oe_runmake -C images
+}
+
+do_install () {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${S}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+}
+
+SRC_URI[md5sum] = "fa339990ee78b0fd1bad994f0b35764c"
+SRC_URI[sha256sum] = "bc3487bf3927f7e3ea46cef770724d20e820883f4173eb7f8a1332c51d9b6431"