aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/puzz-le
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/puzz-le
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/puzz-le')
-rw-r--r--recipes-qtopia/puzz-le/puzz-le-2.0.0/gcc3.patch24
-rw-r--r--recipes-qtopia/puzz-le/puzz-le_2.0.0.bb21
2 files changed, 45 insertions, 0 deletions
diff --git a/recipes-qtopia/puzz-le/puzz-le-2.0.0/gcc3.patch b/recipes-qtopia/puzz-le/puzz-le-2.0.0/gcc3.patch
new file mode 100644
index 0000000..9435dc5
--- /dev/null
+++ b/recipes-qtopia/puzz-le/puzz-le-2.0.0/gcc3.patch
@@ -0,0 +1,24 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- puzzle_arm/OptionsDialog.cpp~gcc3 2002-07-16 04:01:12.000000000 +0200
++++ puzzle_arm/OptionsDialog.cpp 2004-02-19 21:10:32.000000000 +0100
+@@ -24,14 +24,14 @@
+
+ int OptionsDialog::sOptions[5]={60,50,40,30,20};
+
+-OptionsDialog::OptionsDialog(QString *currLevel,QString *th, bool *se,bool *ar,bool *tl, int *gs, QWidget *parent=0,const char *name=0):QDialog(parent,name,true,WStyle_Customize|WStyle_NoBorderEx )
++OptionsDialog::OptionsDialog(QString *currLevel,QString *th, bool *se,bool *ar,bool *tlx, int *gs, QWidget *parent,const char *name):QDialog(parent,name,true,WStyle_Customize|WStyle_NoBorderEx )
+ {
+ the=th;
+ ile=currLevel;
+ ise=se;
+ iar=ar;
+ igs=gs;
+- itl=tl;
++ itl=tlx;
+
+ QFont f=font();
+ f.setBold(true);
diff --git a/recipes-qtopia/puzz-le/puzz-le_2.0.0.bb b/recipes-qtopia/puzz-le/puzz-le_2.0.0.bb
new file mode 100644
index 0000000..a2fb02e
--- /dev/null
+++ b/recipes-qtopia/puzz-le/puzz-le_2.0.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Puzz-le is a colorful arcade logic game for Qt/Embedded based Palmtop Environments."
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+PR = "r1"
+
+SRC_URI = "http://www.warmi.net/zaurus/files/puzz-le_${PV}.tar.gz \
+ file://gcc3.patch"
+S = "${WORKDIR}/puzzle_arm"
+
+inherit palmtop
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin
+ install -m 0755 puzz-le ${D}${palmtopdir}/bin/
+ cp -pPR Qtopia/puzz-le/opt/QtPalmtop/* ${D}${palmtopdir}/
+}
+
+SRC_URI[md5sum] = "76535893b779926874f618d3fbf3e92b"
+SRC_URI[sha256sum] = "e4b4217b81ab0885db11cf7e0f18afdeaa969392fc15647a10c2aab9cbf583d8"