aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/poqetpresenter
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/poqetpresenter
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/poqetpresenter')
-rw-r--r--recipes-qtopia/poqetpresenter/poqetpresenter_0.0.6.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-qtopia/poqetpresenter/poqetpresenter_0.0.6.bb b/recipes-qtopia/poqetpresenter/poqetpresenter_0.0.6.bb
new file mode 100644
index 0000000..f2f9cdd
--- /dev/null
+++ b/recipes-qtopia/poqetpresenter/poqetpresenter_0.0.6.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "OpenOffice.org Impress presentation viewer for Qt/E based Palmtop environments"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://poqetp.sourceforge.net/"
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/poqetp/poqetp_${PV}_src.tar.gz"
+S = "${WORKDIR}/poqetp"
+
+inherit palmtop
+
+do_configure_prepend() {
+ find . -name "Makefile"|xargs rm -f # force regenerating Makefiles
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Applications \
+ ${D}${palmtopdir}/pics
+ install -D -m 0755 poqetp/poqetp ${D}${palmtopdir}/bin/poqetp
+ install -D -m 0644 poqetp.desktop ${D}${palmtopdir}/apps/Applications/poqetp.desktop
+ install -d ${D}${palmtopdir}/pics/poqetp
+ cp -pPR pics/* ${D}${palmtopdir}/pics/poqetp/
+}
+
+SRC_URI[md5sum] = "b003614237445d23b512cb9571565524"
+SRC_URI[sha256sum] = "4347a70fe84bd2ccecc90738fb121d28298cf0bfdb4963ceee088c56d3109899"