aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-04-10 01:48:57 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-05-20 22:34:16 +0100
commit62f4d3d6819d7a6283bde7bd1bb7d2397e01b4f5 (patch)
treed755ff16712abc42a70a7380bc64028df42902ad /recipes-opie
parent7211ec94f4dbb96d54e540d95338bdfb9ebb3950 (diff)
downloadmeta-opie-62f4d3d6819d7a6283bde7bd1bb7d2397e01b4f5.tar.gz
opie-connmanapplet/opie-connmansettings: add
Add recipes for new Opie ConnMan frontend. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie')
-rw-r--r--recipes-opie/opie-connmanapplet/opie-connmanapplet.inc17
-rw-r--r--recipes-opie/opie-connmanapplet/opie-connmanapplet_git.bb8
-rw-r--r--recipes-opie/opie-connmansettings/opie-connmansettings.inc16
-rw-r--r--recipes-opie/opie-connmansettings/opie-connmansettings_git.bb7
4 files changed, 48 insertions, 0 deletions
diff --git a/recipes-opie/opie-connmanapplet/opie-connmanapplet.inc b/recipes-opie/opie-connmanapplet/opie-connmanapplet.inc
new file mode 100644
index 0000000..2134f29
--- /dev/null
+++ b/recipes-opie/opie-connmanapplet/opie-connmanapplet.inc
@@ -0,0 +1,17 @@
+DESCRIPTION = "Opie network connection applet"
+SECTION = "opie/applets"
+LICENSE = "GPLv2"
+# FIXME stopgap until split archives have license files included
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+RDEPENDS_${PN} += "connman opie-connmansettings"
+APPNAME = "connmanapplet"
+
+S = "${WORKDIR}/applet"
+
+inherit opie
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/connmanapplet
+ install -m 0644 ${WORKDIR}/pics/connmanapplet/*.png ${D}${palmtopdir}/pics/connmanapplet
+}
+
diff --git a/recipes-opie/opie-connmanapplet/opie-connmanapplet_git.bb b/recipes-opie/opie-connmanapplet/opie-connmanapplet_git.bb
new file mode 100644
index 0000000..6078a0a
--- /dev/null
+++ b/recipes-opie/opie-connmanapplet/opie-connmanapplet_git.bb
@@ -0,0 +1,8 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+PR = "r0"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/net/connman/applet \
+ ${OPIE_GIT};protocol=git;subpath=noncore/net/connman/settings \
+ ${OPIE_GIT};protocol=git;subpath=pics"
diff --git a/recipes-opie/opie-connmansettings/opie-connmansettings.inc b/recipes-opie/opie-connmansettings/opie-connmansettings.inc
new file mode 100644
index 0000000..927d1d0
--- /dev/null
+++ b/recipes-opie/opie-connmansettings/opie-connmansettings.inc
@@ -0,0 +1,16 @@
+DESCRIPTION = "Network connection settings for Opie"
+SECTION = "opie/settings"
+RDEPENDS_${PN} = "connman"
+LICENSE = "GPLv2"
+# FIXME stopgap until split archives have license files included
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+APPNAME = "connmansettings"
+
+S = "${WORKDIR}/settings"
+
+inherit opie
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/connmansettings/
+ install -m 0644 ${WORKDIR}/pics/connmansettings/*.png ${D}${palmtopdir}/pics/connmansettings/
+}
diff --git a/recipes-opie/opie-connmansettings/opie-connmansettings_git.bb b/recipes-opie/opie-connmansettings/opie-connmansettings_git.bb
new file mode 100644
index 0000000..d374907
--- /dev/null
+++ b/recipes-opie/opie-connmansettings/opie-connmansettings_git.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+PV = "${OPIE_GIT_PV}"
+PR = "r0"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/net/connman/settings \
+ ${OPIE_GIT};protocol=git;subpath=apps \
+ ${OPIE_GIT};protocol=git;subpath=pics"