aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-05 09:39:42 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-09 16:24:39 +0100
commit33fa4b551d08387932eb6d5797afc9e2436ceba1 (patch)
tree129841b09656c7f6de466e02787efda24821dbb7 /recipes-opie
parent13c5fb7dbbd208b8ce748b1c02ee380d31b1e2df (diff)
downloadmeta-opie-33fa4b551d08387932eb6d5797afc9e2436ceba1.tar.gz
Rename task -> packagegroup
This matches the new naming scheme in OE-Core. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie')
-rw-r--r--recipes-opie/images/opie-image-16mb.bb16
-rw-r--r--recipes-opie/images/opie-image.bb18
-rw-r--r--recipes-opie/images/opie-xqtlauncher-image.bb4
-rw-r--r--recipes-opie/meta/meta-opie-all.bb16
-rw-r--r--recipes-opie/meta/meta-opie.bb26
-rw-r--r--recipes-opie/meta/meta-toolchain-opie.bb4
-rw-r--r--recipes-opie/opie-taskbar/opie-taskbar-images.inc2
-rw-r--r--recipes-opie/packagegroups/packagegroup-opie-16mb.bb (renamed from recipes-opie/tasks/task-opie-16mb.bb)32
-rw-r--r--recipes-opie/packagegroups/packagegroup-opie-all.bb (renamed from recipes-opie/tasks/task-opie-all.bb)30
-rw-r--r--recipes-opie/packagegroups/packagegroup-opie-apps.bb (renamed from recipes-opie/tasks/task-opie-apps.bb)8
-rw-r--r--recipes-opie/packagegroups/packagegroup-opie-games.bb (renamed from recipes-opie/tasks/task-opie-games.bb)8
-rw-r--r--recipes-opie/packagegroups/packagegroup-opie-toolchain-host-nativesdk.bb (renamed from recipes-opie/tasks/task-opie-toolchain-host-nativesdk.bb)0
-rw-r--r--recipes-opie/packagegroups/packagegroup-opie-toolchain-target.bb (renamed from recipes-opie/tasks/task-opie-toolchain-target.bb)2
-rw-r--r--recipes-opie/packagegroups/packagegroup-opie.bb98
-rw-r--r--recipes-opie/packagegroups/packagegroup-xqtlauncher.bb (renamed from recipes-opie/tasks/task-xqtlauncher.bb)8
-rw-r--r--recipes-opie/tasks/task-opie.bb98
16 files changed, 185 insertions, 185 deletions
diff --git a/recipes-opie/images/opie-image-16mb.bb b/recipes-opie/images/opie-image-16mb.bb
index 253c005..be06009 100644
--- a/recipes-opie/images/opie-image-16mb.bb
+++ b/recipes-opie/images/opie-image-16mb.bb
@@ -2,17 +2,17 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
IMAGE_LINGUAS = ""
-DEPENDS = "task-boot task-opie-16mb"
+DEPENDS = "packagegroup-boot packagegroup-opie-16mb"
ANGSTROM_EXTRA_INSTALL ?= ""
-IMAGE_INSTALL = "task-boot \
+IMAGE_INSTALL = "packagegroup-core-boot \
dropbear \
- task-opie-16mb-base \
- task-opie-16mb-applets \
- task-opie-16mb-inputmethods \
- task-opie-16mb-settings \
- task-opie-16mb-apps \
- task-opie-16mb-pim \
+ packagegroup-opie-16mb-base \
+ packagegroup-opie-16mb-applets \
+ packagegroup-opie-16mb-inputmethods \
+ packagegroup-opie-16mb-settings \
+ packagegroup-opie-16mb-apps \
+ packagegroup-opie-16mb-pim \
${ANGSTROM_EXTRA_INSTALL} "
inherit image
diff --git a/recipes-opie/images/opie-image.bb b/recipes-opie/images/opie-image.bb
index f39b108..c73b6fa 100644
--- a/recipes-opie/images/opie-image.bb
+++ b/recipes-opie/images/opie-image.bb
@@ -2,19 +2,19 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
IMAGE_LINGUAS = ""
-DEPENDS = "task-base task-opie"
+DEPENDS = "packagegroup-base packagegroup-opie"
IMAGE_FEATURES = "ssh-server-dropbear"
ANGSTROM_EXTRA_INSTALL ?= ""
-IMAGE_INSTALL = "task-core-boot task-base ${ROOTFS_PKGMANAGE} \
- task-opie-base task-opie-base-applets \
- task-opie-base-inputmethods task-opie-base-apps \
- task-opie-base-settings task-opie-base-decorations \
- task-opie-base-styles task-opie-base-pim \
- task-opie-extra-settings \
- ${@base_contains("COMBINED_FEATURES", "bluetooth", "task-opie-bluetooth", "",d)} \
- ${@base_contains("COMBINED_FEATURES", "irda", "task-opie-irda", "",d)} \
+IMAGE_INSTALL = "packagegroup-core-boot packagegroup-base ${ROOTFS_PKGMANAGE} \
+ packagegroup-opie-base packagegroup-opie-base-applets \
+ packagegroup-opie-base-inputmethods packagegroup-opie-base-apps \
+ packagegroup-opie-base-settings packagegroup-opie-base-decorations \
+ packagegroup-opie-base-styles packagegroup-opie-base-pim \
+ packagegroup-opie-extra-settings \
+ ${@base_contains("COMBINED_FEATURES", "bluetooth", "packagegroup-opie-bluetooth", "",d)} \
+ ${@base_contains("COMBINED_FEATURES", "irda", "packagegroup-opie-irda", "",d)} \
${ANGSTROM_EXTRA_INSTALL} "
inherit core-image
diff --git a/recipes-opie/images/opie-xqtlauncher-image.bb b/recipes-opie/images/opie-xqtlauncher-image.bb
index db32a1e..7840533 100644
--- a/recipes-opie/images/opie-xqtlauncher-image.bb
+++ b/recipes-opie/images/opie-xqtlauncher-image.bb
@@ -1,7 +1,7 @@
require opie-image.bb
-DEPENDS += "task-xqtlauncher"
+DEPENDS += "packagegroup-xqtlauncher"
export IMAGE_BASENAME = "opie-xqtlauncher-image"
-IMAGE_INSTALL += "task-xqtlauncher task-xqtlauncher-blackbox"
+IMAGE_INSTALL += "packagegroup-xqtlauncher packagegroup-xqtlauncher-blackbox"
diff --git a/recipes-opie/meta/meta-opie-all.bb b/recipes-opie/meta/meta-opie-all.bb
index e6a0da7..0d93ab6 100644
--- a/recipes-opie/meta/meta-opie-all.bb
+++ b/recipes-opie/meta/meta-opie-all.bb
@@ -4,13 +4,13 @@ LICENSE = "MIT"
PR = "r4"
RDEPENDS_${PN} = " \
- task-qpe-applets \
- task-qpe-games \
- task-qpe-inputmethods \
- task-qpe-multimedia \
- task-qpe-emulators \
- task-qpe-applications \
- task-qpe-fonts \
- task-qpe-settings"
+ packagegroup-qpe-applets \
+ packagegroup-qpe-games \
+ packagegroup-qpe-inputmethods \
+ packagegroup-qpe-multimedia \
+ packagegroup-qpe-emulators \
+ packagegroup-qpe-applications \
+ packagegroup-qpe-fonts \
+ packagegroup-qpe-settings"
inherit meta
diff --git a/recipes-opie/meta/meta-opie.bb b/recipes-opie/meta/meta-opie.bb
index 1584765..d76fcee 100644
--- a/recipes-opie/meta/meta-opie.bb
+++ b/recipes-opie/meta/meta-opie.bb
@@ -3,18 +3,18 @@ SECTION = "opie/base"
PR = "r35"
LICENSE = "MIT"
-RDEPENDS_${PN} = "task-opie-applets task-opie-apps task-opie-base \
- task-opie-base-applets task-opie-base-apps \
- task-opie-base-decorations task-opie-base-inputmethods \
- task-opie-base-pim task-opie-base-settings \
- task-opie-base-styles \
- ${@base_contains("COMBINED_FEATURES", "bluetooth", "task-opie-bluetooth", "",d)} \
- task-opie-datebookplugins task-opie-decorations \
- task-opie-extra-apps task-opie-extra-settings \
- task-opie-extra-styles task-opie-extra-games \
- ${@base_contains("COMBINED_FEATURES", "irda", "task-opie-irda", "",d)} \
- task-opie-games task-opie-inputmethods \
- task-opie-multimedia task-opie-pim task-opie-settings \
- task-opie-styles task-opie-todayplugins task-opie-wlan"
+RDEPENDS_${PN} = "packagegroup-opie-applets packagegroup-opie-apps packagegroup-opie-base \
+ packagegroup-opie-base-applets packagegroup-opie-base-apps \
+ packagegroup-opie-base-decorations packagegroup-opie-base-inputmethods \
+ packagegroup-opie-base-pim packagegroup-opie-base-settings \
+ packagegroup-opie-base-styles \
+ ${@base_contains("COMBINED_FEATURES", "bluetooth", "packagegroup-opie-bluetooth", "",d)} \
+ packagegroup-opie-datebookplugins packagegroup-opie-decorations \
+ packagegroup-opie-extra-apps packagegroup-opie-extra-settings \
+ packagegroup-opie-extra-styles packagegroup-opie-extra-games \
+ ${@base_contains("COMBINED_FEATURES", "irda", "packagegroup-opie-irda", "",d)} \
+ packagegroup-opie-games packagegroup-opie-inputmethods \
+ packagegroup-opie-multimedia packagegroup-opie-pim packagegroup-opie-settings \
+ packagegroup-opie-styles packagegroup-opie-todayplugins packagegroup-opie-wlan"
inherit meta
diff --git a/recipes-opie/meta/meta-toolchain-opie.bb b/recipes-opie/meta/meta-toolchain-opie.bb
index 3238b37..c35fc80 100644
--- a/recipes-opie/meta/meta-toolchain-opie.bb
+++ b/recipes-opie/meta/meta-toolchain-opie.bb
@@ -1,6 +1,6 @@
PR = "r3"
-TOOLCHAIN_HOST_TASK = "task-opie-toolchain-host-nativesdk task-cross-canadian-${TRANSLATED_TARGET_ARCH}"
-TOOLCHAIN_TARGET_TASK = "task-opie-toolchain-target"
+TOOLCHAIN_HOST_TASK = "packagegroup-opie-toolchain-host-nativesdk packagegroup-cross-canadian-${TRANSLATED_TARGET_ARCH}"
+TOOLCHAIN_TARGET_TASK = "packagegroup-opie-toolchain-target"
TOOLCHAIN_OUTPUTNAME = "${SDK_NAME}-toolchain-opie-${DISTRO_VERSION}"
require recipes-core/meta/meta-toolchain.bb
diff --git a/recipes-opie/opie-taskbar/opie-taskbar-images.inc b/recipes-opie/opie-taskbar/opie-taskbar-images.inc
index ee8581e..c41564c 100644
--- a/recipes-opie/opie-taskbar/opie-taskbar-images.inc
+++ b/recipes-opie/opie-taskbar/opie-taskbar-images.inc
@@ -78,5 +78,5 @@ RPROVIDES_${PN}-480x640 = "opie-taskbar-images"
RPROVIDES_${PN}-640x480 = "opie-taskbar-images"
RPROVIDES_${PN}-800x600 = "opie-taskbar-images"
-# Add dummy packages so that the WxH + HxW RRECOMMENDS line in task-opie.bb works
+# Add dummy packages so that the WxH + HxW RRECOMMENDS line in packagegroup-opie.bb works
PACKAGES += "${PN}-320x240 ${PN}-600x800"
diff --git a/recipes-opie/tasks/task-opie-16mb.bb b/recipes-opie/packagegroups/packagegroup-opie-16mb.bb
index 34f81f6..cefc1bd 100644
--- a/recipes-opie/tasks/task-opie-16mb.bb
+++ b/recipes-opie/packagegroups/packagegroup-opie-16mb.bb
@@ -4,29 +4,29 @@ LICENSE = "MIT"
PACKAGE_ARCH = "${MACHINE_ARCH}"
PR = "r5"
-inherit task
+inherit packagegroup
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-PACKAGES = "task-opie-16mb-base \
- task-opie-16mb-applets \
- task-opie-16mb-inputmethods \
- task-opie-16mb-settings \
- task-opie-16mb-apps \
- task-opie-16mb-pim \
+PACKAGES = "packagegroup-opie-16mb-base \
+ packagegroup-opie-16mb-applets \
+ packagegroup-opie-16mb-inputmethods \
+ packagegroup-opie-16mb-settings \
+ packagegroup-opie-16mb-apps \
+ packagegroup-opie-16mb-pim \
"
#
# Dependencies to get the launcher up and running
#
-RDEPENDS_task-opie-16mb-base = "opie-init opie-alarm opie-qcop opie-qss opie-quicklauncher \
+RDEPENDS_packagegroup-opie-16mb-base = "opie-init opie-alarm opie-qcop opie-qss opie-quicklauncher \
opie-taskbar opie-pics opie-sounds opie-freetype opie-taskbar-images-240x320 \
ttf-dejavu-sans ttf-dejavu-sans-mono"
#
# things for reasonable bootstrap image
#
-RDEPENDS_task-opie-16mb-applets = "opie-aboutapplet opie-clockapplet opie-suspendapplet \
+RDEPENDS_packagegroup-opie-16mb-applets = "opie-aboutapplet opie-clockapplet opie-suspendapplet \
opie-homeapplet opie-rotateapplet \
opie-brightnessapplet opie-volumeapplet \
opie-screenshotapplet \
@@ -38,19 +38,19 @@ RDEPENDS_task-opie-16mb-applets = "opie-aboutapplet opie-clockapplet opie-suspen
#
# clamshell models can benefit from the autorotate applet
#
-RDEPENDS_task-opie-16mb-applets_append_c7x0 = " opie-autorotateapplet"
-RDEPENDS_task-opie-16mb-applets_append_spitz = " opie-autorotateapplet"
-RDEPENDS_task-opie-16mb-applets_append_akita = " opie-autorotateapplet"
+RDEPENDS_packagegroup-opie-16mb-applets_append_c7x0 = " opie-autorotateapplet"
+RDEPENDS_packagegroup-opie-16mb-applets_append_spitz = " opie-autorotateapplet"
+RDEPENDS_packagegroup-opie-16mb-applets_append_akita = " opie-autorotateapplet"
-RDEPENDS_task-opie-16mb-inputmethods = "opie-multikey"
+RDEPENDS_packagegroup-opie-16mb-inputmethods = "opie-multikey"
-RDEPENDS_task-opie-16mb-settings = "opie-packagemanager opie-light-and-power opie-appearance \
+RDEPENDS_packagegroup-opie-16mb-settings = "opie-packagemanager opie-light-and-power opie-appearance \
opie-systemtime opie-networksettings opie-button-settings \
opie-icon-reload opie-launcher-settings opie-security \
opie-securityplugin-pin"
-RDEPENDS_task-opie-16mb-apps = "opie-console opie-clock opie-backup opie-sysinfo \
+RDEPENDS_packagegroup-opie-16mb-apps = "opie-console opie-clock opie-backup opie-sysinfo \
opie-advancedfm"
-RDEPENDS_task-opie-16mb-pim = "opie-addressbook opie-datebook opie-drawpad \
+RDEPENDS_packagegroup-opie-16mb-pim = "opie-addressbook opie-datebook opie-drawpad \
opie-search opie-textedit opie-today opie-todo"
diff --git a/recipes-opie/tasks/task-opie-all.bb b/recipes-opie/packagegroups/packagegroup-opie-all.bb
index 3f3a33b..17541da 100644
--- a/recipes-opie/tasks/task-opie-all.bb
+++ b/recipes-opie/packagegroups/packagegroup-opie-all.bb
@@ -3,19 +3,19 @@ SECTION = "opie/base"
LICENSE = "MIT"
PR = "r3"
-inherit task
+inherit packagegroup
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-PACKAGES = "task-opie-applets task-opie-inputmethods task-opie-styles \
- task-opie-decorations task-opie-multimedia task-opie-wlan \
- task-opie-settings task-opie-pim task-opie-datebookplugins \
- task-opie-todayplugins"
+PACKAGES = "packagegroup-opie-applets packagegroup-opie-inputmethods packagegroup-opie-styles \
+ packagegroup-opie-decorations packagegroup-opie-multimedia packagegroup-opie-wlan \
+ packagegroup-opie-settings packagegroup-opie-pim packagegroup-opie-datebookplugins \
+ packagegroup-opie-todayplugins"
#
# all OPIE stuff
#
-RDEPENDS_task-opie-applets = "opie-aboutapplet opie-autorotateapplet opie-batteryapplet \
+RDEPENDS_packagegroup-opie-applets = "opie-aboutapplet opie-autorotateapplet opie-batteryapplet \
opie-bluetoothapplet opie-brightnessapplet \
opie-clipboardapplet opie-clockapplet opie-homeapplet \
opie-irdaapplet opie-lockapplet opie-logoutapplet \
@@ -26,16 +26,16 @@ RDEPENDS_task-opie-applets = "opie-aboutapplet opie-autorotateapplet opie-batter
opie-screenshotapplet opie-suspendapplet opie-vmemo \
opie-volumeapplet opie-vtapplet opie-zkbapplet \
"
-RDEPENDS_task-opie-inputmethods = "opie-dvorak opie-handwriting \
+RDEPENDS_packagegroup-opie-inputmethods = "opie-dvorak opie-handwriting \
opie-handwriting-classicset opie-jumpx opie-keyboard \
opie-keyview opie-kjumpx opie-multikey opie-unikeyboard"
-RDEPENDS_task-opie-styles = "opie-style-flat opie-style-fresh opie-style-liquid opie-style-metal \
+RDEPENDS_packagegroup-opie-styles = "opie-style-flat opie-style-fresh opie-style-liquid opie-style-metal \
opie-style-web opie-style-phase opie-theme"
-RDEPENDS_task-opie-decorations = "opie-deco-flat opie-deco-liquid opie-deco-polished"
+RDEPENDS_packagegroup-opie-decorations = "opie-deco-flat opie-deco-liquid opie-deco-polished"
-RDEPENDS_task-opie-multimedia = "opie-mediaplayer1 \
+RDEPENDS_packagegroup-opie-multimedia = "opie-mediaplayer1 \
${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'opie-mediaplayer1-libmadplugin', d)} \
opie-mediaplayer1-libmodplugin \
opie-mediaplayer1-libtremorplugin \
@@ -47,24 +47,24 @@ RDEPENDS_task-opie-multimedia = "opie-mediaplayer1 \
opie-mediaplayer2-skin-techno \
opie-powerchord opie-recorder opie-tonleiter"
-RDEPENDS_task-opie-settings = "opie-appearance opie-aqpkg opie-backup opie-button-settings \
+RDEPENDS_packagegroup-opie-settings = "opie-appearance opie-aqpkg opie-backup opie-button-settings \
opie-citytime opie-confeditor opie-doctab \
opie-formatter opie-language opie-launcher-settings \
opie-light-and-power opie-mediummount opie-networksettings \
opie-packagemanager opie-security opie-sshkeys opie-sysinfo \
opie-systemtime opie-icon-reload opie-vmemo-settings"
-RDEPENDS_task-opie-pim = "task-opie-base-pim task-opie-todayplugins task-opie-datebookplugins \
+RDEPENDS_packagegroup-opie-pim = "packagegroup-opie-base-pim packagegroup-opie-todayplugins packagegroup-opie-datebookplugins \
opie-mail opie-pimconverter"
-RDEPENDS_task-opie-datebookplugins = "opie-datebook-birthdayplugin \
+RDEPENDS_packagegroup-opie-datebookplugins = "opie-datebook-birthdayplugin \
opie-datebook-chrisholidayplugin \
opie-datebook-nationalholidayplugin"
-RDEPENDS_task-opie-todayplugins = "opie-today-addressbookplugin opie-today-datebookplugin \
+RDEPENDS_packagegroup-opie-todayplugins = "opie-today-addressbookplugin opie-today-datebookplugin \
opie-today-fortuneplugin opie-today-mailplugin \
opie-today-stocktickerplugin opie-today-todolistplugin \
opie-today-weatherplugin"
-RDEPENDS_task-opie-wlan = "wireless-tools opie-wellenreiter opie-networksettings-wlanplugin"
+RDEPENDS_packagegroup-opie-wlan = "wireless-tools opie-wellenreiter opie-networksettings-wlanplugin"
diff --git a/recipes-opie/tasks/task-opie-apps.bb b/recipes-opie/packagegroups/packagegroup-opie-apps.bb
index 2cb0981..12cd4b3 100644
--- a/recipes-opie/tasks/task-opie-apps.bb
+++ b/recipes-opie/packagegroups/packagegroup-opie-apps.bb
@@ -4,13 +4,13 @@ LICENSE = "MIT"
PR = "r1"
-inherit task
+inherit packagegroup
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-PACKAGES = "task-opie-apps task-opie-extra-apps"
+PACKAGES = "packagegroup-opie-apps packagegroup-opie-extra-apps"
-RDEPENDS_task-opie-apps = "opie-advancedfm opie-bartender opie-calculator \
+RDEPENDS_packagegroup-opie-apps = "opie-advancedfm opie-bartender opie-calculator \
opie-checkbook opie-clock \
opie-console opie-embeddedkonsole \
opie-eye opie-ftp opie-gutenbrowser \
@@ -23,7 +23,7 @@ RDEPENDS_task-opie-apps = "opie-advancedfm opie-bartender opie-calculator \
# additional things for a >= 24mb distribution
#
-RDEPENDS_task-opie-extra-apps = "opie-calculator opie-checkbook opie-mail opie-eye \
+RDEPENDS_packagegroup-opie-extra-apps = "opie-calculator opie-checkbook opie-mail opie-eye \
opie-rdesktop opie-wellenreiter opie-irc \
opie-mediaplayer2 \
qpdf2"
diff --git a/recipes-opie/tasks/task-opie-games.bb b/recipes-opie/packagegroups/packagegroup-opie-games.bb
index 0193532..437bd10 100644
--- a/recipes-opie/tasks/task-opie-games.bb
+++ b/recipes-opie/packagegroups/packagegroup-opie-games.bb
@@ -3,13 +3,13 @@ SECTION = "opie/base"
LICENSE = "MIT"
PR = "r1"
-inherit task
+inherit packagegroup
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-PACKAGES = "task-opie-games task-opie-extra-games"
+PACKAGES = "packagegroup-opie-games packagegroup-opie-extra-games"
-RDEPENDS_task-opie-games = "opie-backgammon opie-bounce opie-buzzword opie-fifteen \
+RDEPENDS_packagegroup-opie-games = "opie-backgammon opie-bounce opie-buzzword opie-fifteen \
opie-go opie-kbill opie-kcheckers opie-kpacman opie-mindbreaker \
opie-minesweep opie-oyatzee opie-parashoot opie-qasteroids \
opie-sfcave opie-snake opie-solitaire opie-tetrix opie-tictac \
@@ -19,6 +19,6 @@ RDEPENDS_task-opie-games = "opie-backgammon opie-bounce opie-buzzword opie-fifte
# additional things for a >= 24mb distribution
#
-RDEPENDS_task-opie-extra-games = "opie-parashoot opie-mindbreaker opie-fifteen opie-tictac \
+RDEPENDS_packagegroup-opie-extra-games = "opie-parashoot opie-mindbreaker opie-fifteen opie-tictac \
opie-tetrix"
diff --git a/recipes-opie/tasks/task-opie-toolchain-host-nativesdk.bb b/recipes-opie/packagegroups/packagegroup-opie-toolchain-host-nativesdk.bb
index 52693ba..52693ba 100644
--- a/recipes-opie/tasks/task-opie-toolchain-host-nativesdk.bb
+++ b/recipes-opie/packagegroups/packagegroup-opie-toolchain-host-nativesdk.bb
diff --git a/recipes-opie/tasks/task-opie-toolchain-target.bb b/recipes-opie/packagegroups/packagegroup-opie-toolchain-target.bb
index b9ea713..ca42e0d 100644
--- a/recipes-opie/tasks/task-opie-toolchain-target.bb
+++ b/recipes-opie/packagegroups/packagegroup-opie-toolchain-target.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
RDEPENDS_${PN} = "\
- task-core-standalone-sdk-target \
+ packagegroup-core-standalone-sdk-target \
libopie2-dev \
libqpe-opie-dev \
${@base_conditional("PALMTOP_USE_MULTITHREADED_QT", "yes", "qte-mt", "qte", d)}-dev \
diff --git a/recipes-opie/packagegroups/packagegroup-opie.bb b/recipes-opie/packagegroups/packagegroup-opie.bb
new file mode 100644
index 0000000..6acf081
--- /dev/null
+++ b/recipes-opie/packagegroups/packagegroup-opie.bb
@@ -0,0 +1,98 @@
+DESCRIPTION = "Tasks for OPIE stuff"
+SECTION = "opie/base"
+LICENSE = "MIT"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+PR = "r16"
+
+inherit packagegroup
+
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
+PROVIDES = "packagegroup-opie-everything"
+
+PACKAGES = "packagegroup-opie-base \
+ packagegroup-opie-base-applets packagegroup-opie-base-apps \
+ packagegroup-opie-base-decorations packagegroup-opie-base-inputmethods \
+ packagegroup-opie-base-pim packagegroup-opie-base-settings \
+ packagegroup-opie-base-styles packagegroup-opie-base-todayplugins \
+ packagegroup-opie-extra-settings \
+ packagegroup-opie-extra-styles \
+ ${@base_contains("COMBINED_FEATURES", "bluetooth", "packagegroup-opie-bluetooth", "",d)} \
+ ${@base_contains("COMBINED_FEATURES", "irda", "packagegroup-opie-irda", "",d)} \
+ "
+
+RDEPENDS_packagegroup-opie-everything := "${PACKAGES}"
+
+PACKAGES += "packagegroup-opie-everything"
+
+#
+# Dependencies to get the launcher up and running
+#
+RDEPENDS_packagegroup-opie-base = "opie-init opie-alarm opie-qcop opie-qss opie-quicklauncher \
+ opie-taskbar opie-pics opie-sounds opie-freetype \
+ ttf-dejavu-sans ttf-dejavu-sans-mono"
+MACHINE_DISPLAY_WIDTH_PIXELS ?= "240"
+MACHINE_DISPLAY_HEIGHT_PIXELS ?= "320"
+# Recommend both landscape and portrait backgrounds
+RRECOMMENDS_packagegroup-opie-base = "opie-taskbar-images-${MACHINE_DISPLAY_WIDTH_PIXELS}x${MACHINE_DISPLAY_HEIGHT_PIXELS} \
+ opie-taskbar-images-${MACHINE_DISPLAY_HEIGHT_PIXELS}x${MACHINE_DISPLAY_WIDTH_PIXELS}"
+
+#
+# things for reasonable bootstrap image
+#
+RDEPENDS_packagegroup-opie-base-applets = "opie-aboutapplet opie-clockapplet opie-suspendapplet \
+ opie-homeapplet opie-rotateapplet \
+ opie-brightnessapplet opie-volumeapplet \
+ opie-screenshotapplet \
+ ${@base_contains("COMBINED_FEATURES", "irda", "opie-irdaapplet", "",d)} \
+ ${@base_contains("MACHINE_FEATURES", "apm", "opie-batteryapplet", "",d)} \
+ ${@base_contains("COMBINED_FEATURES", "pcmcia", "opie-cardapplet", "",d)} \
+ ${@base_contains("MACHINE_FEATURES", "keyboard", "opie-vtapplet opie-logoutapplet", "",d)}"
+
+#
+# clamshell models can benefit from the autorotate applet
+#
+RDEPENDS_packagegroup-opie-base-applets_append_c7x0 = " opie-autorotateapplet"
+RDEPENDS_packagegroup-opie-base-applets_append_spitz = " opie-autorotateapplet"
+RDEPENDS_packagegroup-opie-base-applets_append_akita = " opie-autorotateapplet"
+
+RDEPENDS_packagegroup-opie-base-inputmethods = "opie-multikey opie-handwriting opie-handwriting-classicset"
+
+RDEPENDS_packagegroup-opie-base-apps = "opie-console opie-clock opie-citytime opie-backup opie-sysinfo \
+ opie-advancedfm opie-textedit"
+
+RDEPENDS_packagegroup-opie-base-settings = "opie-packagemanager opie-light-and-power opie-appearance \
+ opie-systemtime opie-networksettings opie-button-settings \
+ opie-icon-reload opie-launcher-settings opie-security \
+ opie-securityplugin-pin"
+
+#
+# That settings can be removed and device will be still usable
+#
+RDEPENDS_packagegroup-opie-extra-settings = "opie-language opie-doctab opie-mediummount \
+ ${@base_contains("DISTRO_FEATURES", "wifi", "opie-networksettings-wlanplugin", "",d)} \
+ ${@base_contains("DISTRO_FEATURES", "ppp", "opie-networksettings-pppplugin", "",d)} \
+ "
+
+RDEPENDS_packagegroup-opie-base-decorations = "opie-deco-flat opie-deco-liquid opie-deco-polished"
+
+RDEPENDS_packagegroup-opie-base-styles = "opie-style-flat opie-style-fresh opie-style-web opie-style-phase"
+
+#
+# Those styles are big and does not look good on QVGA screen
+#
+RDEPENDS_packagegroup-opie-extra-styles = "opie-style-liquid opie-style-metal"
+
+RDEPENDS_packagegroup-opie-base-todayplugins = "opie-today-addressbookplugin opie-today-datebookplugin \
+ opie-today-todolistplugin"
+
+RDEPENDS_packagegroup-opie-base-pim = "opie-addressbook opie-datebook opie-drawpad \
+ opie-search opie-notes opie-today opie-todo \
+ packagegroup-opie-base-todayplugins \
+ opie-datebook-birthdayplugin"
+
+RDEPENDS_packagegroup-opie-bluetooth = "bluez4 obexftp obexpush libopieobex0 \
+ opie-bluetoothmanager opie-bluetoothapplet"
+
+RDEPENDS_packagegroup-opie-irda = "irda-utils libopieobex0 obexftp obexpush"
diff --git a/recipes-opie/tasks/task-xqtlauncher.bb b/recipes-opie/packagegroups/packagegroup-xqtlauncher.bb
index 242307f..16da41e 100644
--- a/recipes-opie/tasks/task-xqtlauncher.bb
+++ b/recipes-opie/packagegroups/packagegroup-xqtlauncher.bb
@@ -3,14 +3,14 @@ SECTION = "opie/base"
LICENSE = "MIT"
PR = "r1"
-inherit task
+inherit packagegroup
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-PACKAGES = "task-xqtlauncher task-xqtlauncher-blackbox"
+PACKAGES = "packagegroup-xqtlauncher packagegroup-xqtlauncher-blackbox"
#xkbd is currently needed becuse of a bug at xqt2
-RDEPENDS_task-xqtlauncher = "xqtlauncher \
+RDEPENDS_packagegroup-xqtlauncher = "xqtlauncher \
xkbd \
"
@@ -18,6 +18,6 @@ RDEPENDS_task-xqtlauncher = "xqtlauncher \
# xqtlauncher with blackbox as wm
#
-RDEPENDS_task-xqtlauncher-blackbox = "xqtlauncher-blackbox-config \
+RDEPENDS_packagegroup-xqtlauncher-blackbox = "xqtlauncher-blackbox-config \
"
diff --git a/recipes-opie/tasks/task-opie.bb b/recipes-opie/tasks/task-opie.bb
deleted file mode 100644
index 64e6492..0000000
--- a/recipes-opie/tasks/task-opie.bb
+++ /dev/null
@@ -1,98 +0,0 @@
-DESCRIPTION = "Tasks for OPIE stuff"
-SECTION = "opie/base"
-LICENSE = "MIT"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-PR = "r16"
-
-inherit task
-
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-
-PROVIDES = "task-opie-everything"
-
-PACKAGES = "task-opie-base \
- task-opie-base-applets task-opie-base-apps \
- task-opie-base-decorations task-opie-base-inputmethods \
- task-opie-base-pim task-opie-base-settings \
- task-opie-base-styles task-opie-base-todayplugins \
- task-opie-extra-settings \
- task-opie-extra-styles \
- ${@base_contains("COMBINED_FEATURES", "bluetooth", "task-opie-bluetooth", "",d)} \
- ${@base_contains("COMBINED_FEATURES", "irda", "task-opie-irda", "",d)} \
- "
-
-RDEPENDS_task-opie-everything := "${PACKAGES}"
-
-PACKAGES += "task-opie-everything"
-
-#
-# Dependencies to get the launcher up and running
-#
-RDEPENDS_task-opie-base = "opie-init opie-alarm opie-qcop opie-qss opie-quicklauncher \
- opie-taskbar opie-pics opie-sounds opie-freetype \
- ttf-dejavu-sans ttf-dejavu-sans-mono"
-MACHINE_DISPLAY_WIDTH_PIXELS ?= "240"
-MACHINE_DISPLAY_HEIGHT_PIXELS ?= "320"
-# Recommend both landscape and portrait backgrounds
-RRECOMMENDS_task-opie-base = "opie-taskbar-images-${MACHINE_DISPLAY_WIDTH_PIXELS}x${MACHINE_DISPLAY_HEIGHT_PIXELS} \
- opie-taskbar-images-${MACHINE_DISPLAY_HEIGHT_PIXELS}x${MACHINE_DISPLAY_WIDTH_PIXELS}"
-
-#
-# things for reasonable bootstrap image
-#
-RDEPENDS_task-opie-base-applets = "opie-aboutapplet opie-clockapplet opie-suspendapplet \
- opie-homeapplet opie-rotateapplet \
- opie-brightnessapplet opie-volumeapplet \
- opie-screenshotapplet \
- ${@base_contains("COMBINED_FEATURES", "irda", "opie-irdaapplet", "",d)} \
- ${@base_contains("MACHINE_FEATURES", "apm", "opie-batteryapplet", "",d)} \
- ${@base_contains("COMBINED_FEATURES", "pcmcia", "opie-cardapplet", "",d)} \
- ${@base_contains("MACHINE_FEATURES", "keyboard", "opie-vtapplet opie-logoutapplet", "",d)}"
-
-#
-# clamshell models can benefit from the autorotate applet
-#
-RDEPENDS_task-opie-base-applets_append_c7x0 = " opie-autorotateapplet"
-RDEPENDS_task-opie-base-applets_append_spitz = " opie-autorotateapplet"
-RDEPENDS_task-opie-base-applets_append_akita = " opie-autorotateapplet"
-
-RDEPENDS_task-opie-base-inputmethods = "opie-multikey opie-handwriting opie-handwriting-classicset"
-
-RDEPENDS_task-opie-base-apps = "opie-console opie-clock opie-citytime opie-backup opie-sysinfo \
- opie-advancedfm opie-textedit"
-
-RDEPENDS_task-opie-base-settings = "opie-packagemanager opie-light-and-power opie-appearance \
- opie-systemtime opie-networksettings opie-button-settings \
- opie-icon-reload opie-launcher-settings opie-security \
- opie-securityplugin-pin"
-
-#
-# That settings can be removed and device will be still usable
-#
-RDEPENDS_task-opie-extra-settings = "opie-language opie-doctab opie-mediummount \
- ${@base_contains("DISTRO_FEATURES", "wifi", "opie-networksettings-wlanplugin", "",d)} \
- ${@base_contains("DISTRO_FEATURES", "ppp", "opie-networksettings-pppplugin", "",d)} \
- "
-
-RDEPENDS_task-opie-base-decorations = "opie-deco-flat opie-deco-liquid opie-deco-polished"
-
-RDEPENDS_task-opie-base-styles = "opie-style-flat opie-style-fresh opie-style-web opie-style-phase"
-
-#
-# Those styles are big and does not look good on QVGA screen
-#
-RDEPENDS_task-opie-extra-styles = "opie-style-liquid opie-style-metal"
-
-RDEPENDS_task-opie-base-todayplugins = "opie-today-addressbookplugin opie-today-datebookplugin \
- opie-today-todolistplugin"
-
-RDEPENDS_task-opie-base-pim = "opie-addressbook opie-datebook opie-drawpad \
- opie-search opie-notes opie-today opie-todo \
- task-opie-base-todayplugins \
- opie-datebook-birthdayplugin"
-
-RDEPENDS_task-opie-bluetooth = "bluez4 obexftp obexpush libopieobex0 \
- opie-bluetoothmanager opie-bluetoothapplet"
-
-RDEPENDS_task-opie-irda = "irda-utils libopieobex0 obexftp obexpush"