aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/tasks
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/tasks
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/tasks')
-rw-r--r--recipes-opie/tasks/task-opie-16mb.bb55
-rw-r--r--recipes-opie/tasks/task-opie-all.bb68
-rw-r--r--recipes-opie/tasks/task-opie-apps.bb26
-rw-r--r--recipes-opie/tasks/task-opie-games.bb22
-rw-r--r--recipes-opie/tasks/task-opie.bb99
-rw-r--r--recipes-opie/tasks/task-xqtlauncher.bb21
6 files changed, 291 insertions, 0 deletions
diff --git a/recipes-opie/tasks/task-opie-16mb.bb b/recipes-opie/tasks/task-opie-16mb.bb
new file mode 100644
index 0000000..859a0f5
--- /dev/null
+++ b/recipes-opie/tasks/task-opie-16mb.bb
@@ -0,0 +1,55 @@
+DESCRIPTION = "Tasks for small OPIE image"
+SECTION = "opie/base"
+LICENSE = "MIT"
+PR = "r3"
+
+inherit task
+
+PACKAGES = "task-opie-16mb-base \
+ task-opie-16mb-applets \
+ task-opie-16mb-inputmethods \
+ task-opie-16mb-settings \
+ task-opie-16mb-apps \
+ task-opie-16mb-pim \
+ "
+
+#
+# Dependencies to get the launcher up and running
+#
+RDEPENDS_task-opie-16mb-base = "opie-init opie-alarm opie-qcop opie-qss opie-quicklauncher \
+ opie-taskbar opie-pics opie-sounds opie-freetype opie-taskbar-images-320x240 \
+ ttf-dejavu-sans ttf-dejavu-sans-mono"
+
+#
+# things for reasonable bootstrap image
+#
+RDEPENDS_task-opie-16mb-applets = "opie-aboutapplet opie-clockapplet opie-suspendapplet \
+ opie-homeapplet opie-rotateapplet \
+ opie-brightnessapplet opie-volumeapplet \
+ opie-screenshotapplet \
+ ${@base_contains("COMBINED_FEATURES", "irda", "opie-irdaapplet", "",d)} \
+ ${@base_contains("MACHINE_FEATURES", "apm", "opie-batteryapplet", "",d)} \
+ ${@base_contains("COMBINED_FEATURES", "pcmcia", "opie-cardapplet", "",d)} \
+ ${@base_contains("MACHINE_FEATURES", "keyboard", "opie-vtapplet opie-logoutapplet", "",d)}"
+
+PACKAGE_ARCH_task-opie-16mb-applets = "${MACHINE_ARCH}"
+
+#
+# clamshell models can benefit from the autorotate applet
+#
+RDEPENDS_task-opie-16mb-applets_append_c7x0 = " opie-autorotateapplet"
+RDEPENDS_task-opie-16mb-applets_append_spitz = " opie-autorotateapplet"
+RDEPENDS_task-opie-16mb-applets_append_akita = " opie-autorotateapplet"
+
+RDEPENDS_task-opie-16mb-inputmethods = "opie-multikey"
+
+RDEPENDS_task-opie-16mb-settings = "opie-packagemanager opie-light-and-power opie-appearance \
+ opie-systemtime opie-networksettings opie-button-settings \
+ opie-icon-reload opie-launcher-settings opie-security \
+ opie-securityplugin-pin"
+
+RDEPENDS_task-opie-16mb-apps = "opie-console opie-clock opie-backup opie-sysinfo \
+ opie-advancedfm"
+
+RDEPENDS_task-opie-16mb-pim = "opie-addressbook opie-datebook opie-drawpad \
+ opie-search opie-textedit opie-today opie-todo"
diff --git a/recipes-opie/tasks/task-opie-all.bb b/recipes-opie/tasks/task-opie-all.bb
new file mode 100644
index 0000000..e316971
--- /dev/null
+++ b/recipes-opie/tasks/task-opie-all.bb
@@ -0,0 +1,68 @@
+DESCRIPTION = "Tasks for OPIE stuff"
+SECTION = "opie/base"
+LICENSE = "MIT"
+PR = "r3"
+
+inherit task
+
+PACKAGES = "task-opie-applets task-opie-inputmethods task-opie-styles \
+ task-opie-decorations task-opie-multimedia task-opie-wlan \
+ task-opie-settings task-opie-pim task-opie-datebookplugins \
+ task-opie-todayplugins"
+
+#
+# all OPIE stuff
+#
+RDEPENDS_task-opie-applets = "opie-aboutapplet opie-autorotateapplet opie-batteryapplet \
+ opie-bluetoothapplet opie-brightnessapplet \
+ opie-clipboardapplet opie-clockapplet opie-homeapplet \
+ opie-irdaapplet opie-lockapplet opie-logoutapplet \
+ opie-mailapplet opie-memoryapplet opie-multikeyapplet \
+ opie-networkapplet opie-notesapplet opie-cardapplet \
+ opie-pyquicklaunchapplet opie-restartapplet \
+ opie-restartapplet2 opie-rotateapplet \
+ opie-screenshotapplet opie-suspendapplet opie-vmemo \
+ opie-volumeapplet opie-vtapplet opie-zkbapplet \
+ "
+RDEPENDS_task-opie-inputmethods = "opie-dvorak opie-handwriting \
+ opie-handwriting-classicset opie-jumpx opie-keyboard \
+ opie-keyview opie-kjumpx opie-multikey opie-unikeyboard"
+
+RDEPENDS_task-opie-styles = "opie-style-flat opie-style-fresh opie-style-liquid opie-style-metal \
+ opie-style-web opie-style-phase opie-theme"
+
+RDEPENDS_task-opie-decorations = "opie-deco-flat opie-deco-liquid opie-deco-polished"
+
+RDEPENDS_task-opie-multimedia = "opie-mediaplayer1 \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'opie-mediaplayer1-libmadplugin', d)} \
+ opie-mediaplayer1-libmodplugin \
+ opie-mediaplayer1-libtremorplugin \
+ opie-mediaplayer1-libwavplugin \
+ opie-mediaplayer2 \
+ opie-mediaplayer2-skin-default \
+ opie-mediaplayer2-skin-default-landscape \
+ opie-mediaplayer2-skin-pod \
+ opie-mediaplayer2-skin-techno \
+ opie-powerchord opie-recorder opie-tonleiter"
+
+RDEPENDS_task-opie-settings = "opie-appearance opie-aqpkg opie-backup opie-button-settings \
+ opie-citytime opie-confeditor opie-doctab \
+ opie-formatter opie-language opie-launcher-settings \
+ opie-light-and-power opie-mediummount opie-networksettings \
+ opie-packagemanager opie-security opie-sshkeys opie-sysinfo \
+ opie-systemtime opie-icon-reload opie-vmemo-settings"
+
+RDEPENDS_task-opie-pim = "task-opie-base-pim task-opie-todayplugins task-opie-datebookplugins \
+ opie-mail opie-pimconverter"
+
+RDEPENDS_task-opie-datebookplugins = "opie-datebook-birthdayplugin \
+ opie-datebook-chrisholidayplugin \
+ opie-datebook-nationalholidayplugin"
+
+RDEPENDS_task-opie-todayplugins = "opie-today-addressbookplugin opie-today-datebookplugin \
+ opie-today-fortuneplugin opie-today-mailplugin \
+ opie-today-stocktickerplugin opie-today-todolistplugin \
+ opie-today-weatherplugin"
+
+RDEPENDS_task-opie-wlan = "wireless-tools opie-wellenreiter opie-networksettings-wlanplugin"
+
diff --git a/recipes-opie/tasks/task-opie-apps.bb b/recipes-opie/tasks/task-opie-apps.bb
new file mode 100644
index 0000000..f791c21
--- /dev/null
+++ b/recipes-opie/tasks/task-opie-apps.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Tasks for OPIE stuff"
+SECTION = "opie/base"
+LICENSE = "MIT"
+
+inherit task
+
+PACKAGES = "task-opie-apps task-opie-extra-apps"
+
+RDEPENDS_task-opie-apps = "opie-advancedfm opie-bartender opie-calculator \
+ opie-checkbook opie-clock \
+ opie-console opie-embeddedkonsole \
+ opie-euroconv opie-eye opie-ftp opie-gutenbrowser \
+ opie-helpbrowser opie-irc opie-keypebble opie-odict \
+ opie-oxygen opie-rdesktop opie-reader opie-remote \
+ opie-sheet opie-tableviewer opie-tinykate \
+ opie-wellenreiter opie-write opie-zsafe"
+
+#
+# additional things for a >= 24mb distribution
+#
+
+RDEPENDS_task-opie-extra-apps = "opie-calculator opie-checkbook opie-mail opie-eye \
+ opie-rdesktop opie-wellenreiter opie-irc \
+ opie-mediaplayer2 \
+ qpdf2"
+# konqueror-embedded
diff --git a/recipes-opie/tasks/task-opie-games.bb b/recipes-opie/tasks/task-opie-games.bb
new file mode 100644
index 0000000..4449c7a
--- /dev/null
+++ b/recipes-opie/tasks/task-opie-games.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Tasks for OPIE stuff"
+SECTION = "opie/base"
+LICENSE = "MIT"
+PR = "r1"
+
+inherit task
+
+PACKAGES = "task-opie-games task-opie-extra-games"
+
+RDEPENDS_task-opie-games = "opie-backgammon opie-bounce opie-buzzword opie-fifteen \
+ opie-go opie-kbill opie-kcheckers opie-kpacman opie-mindbreaker \
+ opie-minesweep opie-oyatzee opie-parashoot opie-qasteroids \
+ opie-sfcave opie-snake opie-solitaire opie-tetrix opie-tictac \
+ opie-wordgame opie-zlines opie-zsame"
+
+#
+# additional things for a >= 24mb distribution
+#
+
+RDEPENDS_task-opie-extra-games = "opie-parashoot opie-mindbreaker opie-fifteen opie-tictac \
+ opie-tetrix"
+
diff --git a/recipes-opie/tasks/task-opie.bb b/recipes-opie/tasks/task-opie.bb
new file mode 100644
index 0000000..a1daaf6
--- /dev/null
+++ b/recipes-opie/tasks/task-opie.bb
@@ -0,0 +1,99 @@
+DESCRIPTION = "Tasks for OPIE stuff"
+SECTION = "opie/base"
+LICENSE = "MIT"
+
+PR = "r14"
+
+inherit task
+
+PROVIDES = "task-opie-everything"
+
+PACKAGES = "task-opie-base \
+ task-opie-base-applets task-opie-base-apps \
+ task-opie-base-decorations task-opie-base-inputmethods \
+ task-opie-base-pim task-opie-base-settings \
+ task-opie-base-styles task-opie-base-todayplugins \
+ task-opie-extra-settings \
+ task-opie-extra-styles \
+ ${@base_contains("COMBINED_FEATURES", "bluetooth", "task-opie-bluetooth", "",d)} \
+ ${@base_contains("COMBINED_FEATURES", "irda", "task-opie-irda", "",d)} \
+ "
+
+RDEPENDS_task-opie-everything := "${PACKAGES}"
+
+PACKAGES += "task-opie-everything"
+
+#
+# Dependencies to get the launcher up and running
+#
+RDEPENDS_task-opie-base = "opie-init opie-alarm opie-qcop opie-qss opie-quicklauncher \
+ opie-taskbar opie-pics opie-sounds opie-freetype \
+ ttf-dejavu-sans ttf-dejavu-sans-mono"
+# Recommend both landscape and portrait backgrounds
+RRECOMMENDS_task-opie-base = "opie-taskbar-images-${MACHINE_DISPLAY_WIDTH_PIXELS}x${MACHINE_DISPLAY_HEIGHT_PIXELS} \
+ opie-taskbar-images-${MACHINE_DISPLAY_HEIGHT_PIXELS}x${MACHINE_DISPLAY_WIDTH_PIXELS}"
+
+PACKAGE_ARCH_task-opie-base = "${MACHINE_ARCH}"
+
+#
+# things for reasonable bootstrap image
+#
+RDEPENDS_task-opie-base-applets = "opie-aboutapplet opie-clockapplet opie-suspendapplet \
+ opie-homeapplet opie-rotateapplet \
+ opie-brightnessapplet opie-volumeapplet \
+ opie-screenshotapplet \
+ ${@base_contains("COMBINED_FEATURES", "irda", "opie-irdaapplet", "",d)} \
+ ${@base_contains("MACHINE_FEATURES", "apm", "opie-batteryapplet", "",d)} \
+ ${@base_contains("COMBINED_FEATURES", "pcmcia", "opie-cardapplet", "",d)} \
+ ${@base_contains("MACHINE_FEATURES", "keyboard", "opie-vtapplet opie-logoutapplet", "",d)}"
+
+PACKAGE_ARCH_task-opie-base-applets = "${MACHINE_ARCH}"
+
+#
+# clamshell models can benefit from the autorotate applet
+#
+RDEPENDS_task-opie-base-applets_append_c7x0 = " opie-autorotateapplet"
+RDEPENDS_task-opie-base-applets_append_spitz = " opie-autorotateapplet"
+RDEPENDS_task-opie-base-applets_append_akita = " opie-autorotateapplet"
+
+RDEPENDS_task-opie-base-inputmethods = "opie-multikey opie-handwriting opie-handwriting-classicset"
+
+RDEPENDS_task-opie-base-apps = "opie-console opie-clock opie-citytime opie-backup opie-sysinfo \
+ opie-advancedfm opie-textedit"
+
+RDEPENDS_task-opie-base-settings = "opie-packagemanager opie-light-and-power opie-appearance \
+ opie-systemtime opie-networksettings opie-button-settings \
+ opie-icon-reload opie-launcher-settings opie-security \
+ opie-securityplugin-pin"
+
+#
+# That settings can be removed and device will be still usable
+#
+RDEPENDS_task-opie-extra-settings = "opie-language opie-doctab opie-mediummount \
+ ${@base_contains("DISTRO_FEATURES", "wifi", "opie-networksettings-wlanplugin", "",d)} \
+ ${@base_contains("DISTRO_FEATURES", "ppp", "opie-networksettings-pppplugin", "",d)} \
+ "
+
+PACKAGE_ARCH_task-opie-extra-settings = "${MACHINE_ARCH}"
+
+RDEPENDS_task-opie-base-decorations = "opie-deco-flat opie-deco-liquid opie-deco-polished"
+
+RDEPENDS_task-opie-base-styles = "opie-style-flat opie-style-fresh opie-style-web opie-style-phase"
+
+#
+# Those styles are big and does not look good on QVGA screen
+#
+RDEPENDS_task-opie-extra-styles = "opie-style-liquid opie-style-metal"
+
+RDEPENDS_task-opie-base-todayplugins = "opie-today-addressbookplugin opie-today-datebookplugin \
+ opie-today-todolistplugin"
+
+RDEPENDS_task-opie-base-pim = "opie-addressbook opie-datebook opie-drawpad \
+ opie-search opie-notes opie-today opie-todo \
+ task-opie-base-todayplugins \
+ opie-datebook-birthdayplugin"
+
+RDEPENDS_task-opie-bluetooth = "bluez-utils obexftp obexpush libopieobex0 \
+ opie-bluepin opie-bluetoothmanager opie-bluetoothapplet"
+
+RDEPENDS_task-opie-irda = "irda-utils libopieobex0 obexftp obexpush"
diff --git a/recipes-opie/tasks/task-xqtlauncher.bb b/recipes-opie/tasks/task-xqtlauncher.bb
new file mode 100644
index 0000000..690d0df
--- /dev/null
+++ b/recipes-opie/tasks/task-xqtlauncher.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Tasks for xqtlauncher stuff"
+SECTION = "opie/base"
+LICENSE = "MIT"
+PR = "r1"
+
+inherit task
+
+PACKAGES = "task-xqtlauncher task-xqtlauncher-blackbox"
+
+#xkbd is currently needed becuse of a bug at xqt2
+RDEPENDS_task-xqtlauncher = "xqtlauncher \
+ xkbd \
+ "
+
+#
+# xqtlauncher with blackbox as wm
+#
+
+RDEPENDS_task-xqtlauncher-blackbox = "xqtlauncher-blackbox-config \
+ "
+