aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/nonworking/opie-dagger
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/nonworking/opie-dagger
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/nonworking/opie-dagger')
-rw-r--r--recipes-opie/nonworking/opie-dagger/opie-dagger.inc18
-rw-r--r--recipes-opie/nonworking/opie-dagger/opie-dagger_1.2.5.bb8
-rw-r--r--recipes-opie/nonworking/opie-dagger/opie-dagger_cvs.bb9
3 files changed, 35 insertions, 0 deletions
diff --git a/recipes-opie/nonworking/opie-dagger/opie-dagger.inc b/recipes-opie/nonworking/opie-dagger/opie-dagger.inc
new file mode 100644
index 0000000..7ba8962
--- /dev/null
+++ b/recipes-opie/nonworking/opie-dagger/opie-dagger.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "A Bible study program utilizing the Sword library."
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "libopiecore2 libopieui2 sword"
+APPNAME = "dagger"
+
+EXTRA_QMAKEVARS_PRE += "LIBSWORD_INC_DIR=${STAGING_INCDIR}/sword"
+
+S = "${WORKDIR}/${APPNAME}"
+
+inherit opie
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/pics/${APPNAME}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+}
+
diff --git a/recipes-opie/nonworking/opie-dagger/opie-dagger_1.2.5.bb b/recipes-opie/nonworking/opie-dagger/opie-dagger_1.2.5.bb
new file mode 100644
index 0000000..c218b1b
--- /dev/null
+++ b/recipes-opie/nonworking/opie-dagger/opie-dagger_1.2.5.bb
@@ -0,0 +1,8 @@
+require ${PN}.inc
+
+PR = "r0"
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_noncore_apps_dagger.tar.bz2 \
+ http://sources.openembedded.org/opie-1.2.5-split_pics.tar.bz2 \
+ http://sources.openembedded.org/opie-1.2.5-split_apps.tar.bz2"
+
diff --git a/recipes-opie/nonworking/opie-dagger/opie-dagger_cvs.bb b/recipes-opie/nonworking/opie-dagger/opie-dagger_cvs.bb
new file mode 100644
index 0000000..2bffd49
--- /dev/null
+++ b/recipes-opie/nonworking/opie-dagger/opie-dagger_cvs.bb
@@ -0,0 +1,9 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+PR = "r2"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/apps/dagger \
+ ${OPIE_GIT};protocol=git;subpath=pics \
+ ${OPIE_GIT};protocol=git;subpath=apps"
+