aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2011-12-13 20:25:15 +0400
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2011-12-13 20:25:15 +0400
commitdbb923d01c97577cf06b59daae33e902675fa380 (patch)
treef523ca1affad67b116ed2fda77826629890509c1
parent2f67ac9db9d3fd5883c5e0d954f8cf30bd97170c (diff)
downloadmeta-opie-dbb923d01c97577cf06b59daae33e902675fa380.tar.gz
task-opie, task-opie-16mb: make whole recipe a machine-only
Currently bitbake spills warnings on task-opie and task-opie-16mb recipes containing machine packages, while being non-machine ones. Disable this warning by replacing all PACKAGE_ARCH_xxx stuff with a single PACKAGE_ARCH = "${MACHINE_ARCH}" Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
-rw-r--r--recipes-opie/tasks/task-opie-16mb.bb5
-rw-r--r--recipes-opie/tasks/task-opie.bb9
2 files changed, 4 insertions, 10 deletions
diff --git a/recipes-opie/tasks/task-opie-16mb.bb b/recipes-opie/tasks/task-opie-16mb.bb
index 42ed6a4..33eb19a 100644
--- a/recipes-opie/tasks/task-opie-16mb.bb
+++ b/recipes-opie/tasks/task-opie-16mb.bb
@@ -1,7 +1,8 @@
DESCRIPTION = "Tasks for small OPIE image"
SECTION = "opie/base"
LICENSE = "MIT"
-PR = "r3"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+PR = "r4"
inherit task
@@ -34,8 +35,6 @@ RDEPENDS_task-opie-16mb-applets = "opie-aboutapplet opie-clockapplet opie-suspen
${@base_contains("COMBINED_FEATURES", "pcmcia", "opie-cardapplet", "",d)} \
${@base_contains("MACHINE_FEATURES", "keyboard", "opie-vtapplet opie-logoutapplet", "",d)}"
-PACKAGE_ARCH_task-opie-16mb-applets = "${MACHINE_ARCH}"
-
#
# clamshell models can benefit from the autorotate applet
#
diff --git a/recipes-opie/tasks/task-opie.bb b/recipes-opie/tasks/task-opie.bb
index 5e3a113..64e6492 100644
--- a/recipes-opie/tasks/task-opie.bb
+++ b/recipes-opie/tasks/task-opie.bb
@@ -1,8 +1,9 @@
DESCRIPTION = "Tasks for OPIE stuff"
SECTION = "opie/base"
LICENSE = "MIT"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
-PR = "r15"
+PR = "r16"
inherit task
@@ -37,8 +38,6 @@ MACHINE_DISPLAY_HEIGHT_PIXELS ?= "320"
RRECOMMENDS_task-opie-base = "opie-taskbar-images-${MACHINE_DISPLAY_WIDTH_PIXELS}x${MACHINE_DISPLAY_HEIGHT_PIXELS} \
opie-taskbar-images-${MACHINE_DISPLAY_HEIGHT_PIXELS}x${MACHINE_DISPLAY_WIDTH_PIXELS}"
-PACKAGE_ARCH_task-opie-base = "${MACHINE_ARCH}"
-
#
# things for reasonable bootstrap image
#
@@ -51,8 +50,6 @@ RDEPENDS_task-opie-base-applets = "opie-aboutapplet opie-clockapplet opie-suspen
${@base_contains("COMBINED_FEATURES", "pcmcia", "opie-cardapplet", "",d)} \
${@base_contains("MACHINE_FEATURES", "keyboard", "opie-vtapplet opie-logoutapplet", "",d)}"
-PACKAGE_ARCH_task-opie-base-applets = "${MACHINE_ARCH}"
-
#
# clamshell models can benefit from the autorotate applet
#
@@ -78,8 +75,6 @@ RDEPENDS_task-opie-extra-settings = "opie-language opie-doctab opie-mediummount
${@base_contains("DISTRO_FEATURES", "ppp", "opie-networksettings-pppplugin", "",d)} \
"
-PACKAGE_ARCH_task-opie-extra-settings = "${MACHINE_ARCH}"
-
RDEPENDS_task-opie-base-decorations = "opie-deco-flat opie-deco-liquid opie-deco-polished"
RDEPENDS_task-opie-base-styles = "opie-style-flat opie-style-fresh opie-style-web opie-style-phase"