aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-01-08 19:05:05 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-01-08 19:19:21 +0000
commit1f2f03c6c269ab336a6b8c908bcca8bc88194703 (patch)
treed693e2407bebccff64284b3630c84f422a15e920
parentdc82bf0e52b07a0767b6bf253852278c473ea248 (diff)
downloadmeta-opie-1f2f03c6c269ab336a6b8c908bcca8bc88194703.tar.gz
classes: add palmtop-defs.bbclass
The Opie-related definitions are about to be removed from bitbake.conf in OE-Core, so create a palmtop-defs.bbclass which can be used to hold these and make every recipe that refers to any of these definitions inherit it. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
-rw-r--r--classes/opie_i18n.bbclass2
-rw-r--r--classes/palmtop-defs.bbclass9
-rw-r--r--classes/palmtop.bbclass2
-rw-r--r--classes/sdl.bbclass2
-rw-r--r--recipes-opie/opie-help-en/opie-help-en.inc2
-rw-r--r--recipes-opie/opie-i18n/opie-i18n.inc3
-rw-r--r--recipes-opie/opie-icon-reload/opie-icon-reload.inc2
-rw-r--r--recipes-opie/opie-keytabs/opie-keytabs.inc2
-rw-r--r--recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin.inc2
-rw-r--r--recipes-opie/opie-pics/opie-pics.inc2
-rw-r--r--recipes-opie/opie-sh-snes/opie-sh-snes_0.2.bb3
-rw-r--r--recipes-opie/opie-sounds/opie-sounds.inc2
-rw-r--r--recipes-opie/opie-ttf-support/opie-ttf-support_1.1.bb2
-rw-r--r--recipes-qtopia/frodo/frodo_4.1b.bb2
-rw-r--r--recipes-qtopia/frodo/frodo_4.2.bb2
-rw-r--r--recipes-qtopia/konqueror/konqueror-embedded_20030705.bb2
-rw-r--r--recipes-qtopia/konqueror/konqueror-embedded_20060404.bb2
-rw-r--r--recipes-qtopia/konqueror/konqueror-embedded_20070316.bb2
-rw-r--r--recipes-qtopia/phalanx/phalanx_22.bb2
-rw-r--r--recipes-qtopia/poboxserver/poboxserver_1.2.5.bb2
-rw-r--r--recipes-qtopia/prboom/prboom-opie_2.2.6.bb2
-rw-r--r--recipes-qtopia/prboom/prboom_2.3.1.bb2
-rw-r--r--recipes-qtopia/qpf-fonts/qpf.inc2
-rw-r--r--recipes-qtopia/snes9x/snes9x-sdl-qpe_1.39.bb2
-rw-r--r--recipes-qtopia/tickypip/tickypip-levels_1.1.bb2
-rw-r--r--recipes-qtopia/xqtlauncher/xqtlauncher.bb2
26 files changed, 49 insertions, 12 deletions
diff --git a/classes/opie_i18n.bbclass b/classes/opie_i18n.bbclass
index 259add6..121533f 100644
--- a/classes/opie_i18n.bbclass
+++ b/classes/opie_i18n.bbclass
@@ -8,6 +8,8 @@
# Todo:
#
+inherit palmtop-defs
+
I18N_STATS = "1"
SRC_URI += "${OPIE_GIT};protocol=git;subpath=i18n"
DEPENDS += "opie-i18n"
diff --git a/classes/palmtop-defs.bbclass b/classes/palmtop-defs.bbclass
new file mode 100644
index 0000000..47c9670
--- /dev/null
+++ b/classes/palmtop-defs.bbclass
@@ -0,0 +1,9 @@
+# Sets basic definitions for QPE/Opie applications
+# (These values were formerly in bitbake.conf in OE-Core)
+
+export QTDIR = "${STAGING_DIR_HOST}/qt2"
+export QPEDIR = "${STAGING_DIR_HOST}"
+export OPIEDIR = "${STAGING_DIR_HOST}"
+export palmtopdir = "${libdir}/opie"
+export palmqtdir = "${palmtopdir}"
+
diff --git a/classes/palmtop.bbclass b/classes/palmtop.bbclass
index 932e917..059a058 100644
--- a/classes/palmtop.bbclass
+++ b/classes/palmtop.bbclass
@@ -7,7 +7,7 @@
# inherit opie if you want to build programs against libopie2
# don't override EXTRA_QMAKEVARS_POST, if you use inherit this class
-inherit qmake
+inherit qmake palmtop-defs
# special case for DISTRO = sharprom
CPP_SUPPORT_LIB = "LIBS-=-lstdc++ LIBS+=-lsupc++"
diff --git a/classes/sdl.bbclass b/classes/sdl.bbclass
index dc4cd8f..d3c1689 100644
--- a/classes/sdl.bbclass
+++ b/classes/sdl.bbclass
@@ -2,6 +2,8 @@
# (C) Michael 'Mickey' Lauer <mickey@Vanille.de>
#
+inherit palmtop-defs
+
DEPENDS += "virtual/libsdl libsdl-mixer libsdl-image"
APPDESKTOP ?= "${WORKDIR}/${PN}.desktop"
diff --git a/recipes-opie/opie-help-en/opie-help-en.inc b/recipes-opie/opie-help-en/opie-help-en.inc
index 78ad55a..1ad39b1 100644
--- a/recipes-opie/opie-help-en/opie-help-en.inc
+++ b/recipes-opie/opie-help-en/opie-help-en.inc
@@ -11,6 +11,8 @@ RDEPENDS_${PN} = "opie-helpbrowser"
S = "${WORKDIR}/html"
+inherit palmtop-defs
+
do_install() {
install -d ${D}${palmtopdir}/help/en/html/
install -m 0644 ${WORKDIR}/html/*.html ${D}${palmtopdir}/help/en/html/
diff --git a/recipes-opie/opie-i18n/opie-i18n.inc b/recipes-opie/opie-i18n/opie-i18n.inc
index f2be6f9..6caf876 100644
--- a/recipes-opie/opie-i18n/opie-i18n.inc
+++ b/recipes-opie/opie-i18n/opie-i18n.inc
@@ -5,9 +5,10 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
DEPENDS = "opie-lrelease-native"
-
S = "${WORKDIR}/i18n"
+inherit palmtop-defs
+
do_compile() {
for f in ?? ??_??
do
diff --git a/recipes-opie/opie-icon-reload/opie-icon-reload.inc b/recipes-opie/opie-icon-reload/opie-icon-reload.inc
index fe897c8..6eb628c 100644
--- a/recipes-opie/opie-icon-reload/opie-icon-reload.inc
+++ b/recipes-opie/opie-icon-reload/opie-icon-reload.inc
@@ -10,6 +10,8 @@ SRC_URI = "file://icon-reload.desktop \
file://icon-reload.sh \
file://reload.png"
+inherit palmtop-defs
+
FILES_${PN} += "${palmtopdir}"
do_install() {
diff --git a/recipes-opie/opie-keytabs/opie-keytabs.inc b/recipes-opie/opie-keytabs/opie-keytabs.inc
index 4f51c05..05962a2 100644
--- a/recipes-opie/opie-keytabs/opie-keytabs.inc
+++ b/recipes-opie/opie-keytabs/opie-keytabs.inc
@@ -4,6 +4,8 @@ LICENSE = "GPLv2"
# FIXME stopgap until split archives have license files included
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+inherit palmtop-defs
+
do_install() {
install -d ${D}${palmtopdir}/etc/keytabs/
install -m 0644 ${WORKDIR}/etc/keytabs/*.* ${D}${palmtopdir}/etc/keytabs/
diff --git a/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin.inc b/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin.inc
index 1df6032..1227415 100644
--- a/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin.inc
+++ b/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin.inc
@@ -5,6 +5,8 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
RPROVIDES_${PN} = "opie-mediaplayer2-skin"
+inherit palmtop-defs
+
do_install() {
install -d ${D}${palmtopdir}/pics/opieplayer2/skins/${SKINNAME}/
install -m 0644 ${WORKDIR}/pics/opieplayer2/skins/${SKINNAME}/*.png ${D}${palmtopdir}/pics/opieplayer2/skins/${SKINNAME}/
diff --git a/recipes-opie/opie-pics/opie-pics.inc b/recipes-opie/opie-pics/opie-pics.inc
index a4adad2..82e761a 100644
--- a/recipes-opie/opie-pics/opie-pics.inc
+++ b/recipes-opie/opie-pics/opie-pics.inc
@@ -7,6 +7,8 @@ PR = "r2"
S = "${WORKDIR}"
+inherit palmtop-defs
+
SHIP_INLINE_PICS = "yes"
INLINE_PICS = '${@base_conditional("GUI_MACHINE_CLASS", "bigscreen", "pics-hires/inline", "pics/inline", d)}'
diff --git a/recipes-opie/opie-sh-snes/opie-sh-snes_0.2.bb b/recipes-opie/opie-sh-snes/opie-sh-snes_0.2.bb
index 97ec480..2b75b5c 100644
--- a/recipes-opie/opie-sh-snes/opie-sh-snes_0.2.bb
+++ b/recipes-opie/opie-sh-snes/opie-sh-snes_0.2.bb
@@ -6,9 +6,10 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425
RDEPENDS_${PN} = "opie-sh"
-
PR = "r3"
+inherit palmtop-defs
+
FILES_${PN} = "/opt/QtPalmtop"
SRC_URI = "file://snes.desktop \
diff --git a/recipes-opie/opie-sounds/opie-sounds.inc b/recipes-opie/opie-sounds/opie-sounds.inc
index 8a8b2ea..8ae96b7 100644
--- a/recipes-opie/opie-sounds/opie-sounds.inc
+++ b/recipes-opie/opie-sounds/opie-sounds.inc
@@ -6,6 +6,8 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425
S = "${WORKDIR}/sounds"
+inherit palmtop-defs
+
SOUNDS = "alarm touchsound keysound"
do_install() {
diff --git a/recipes-opie/opie-ttf-support/opie-ttf-support_1.1.bb b/recipes-opie/opie-ttf-support/opie-ttf-support_1.1.bb
index 50cec6e..524057a 100644
--- a/recipes-opie/opie-ttf-support/opie-ttf-support_1.1.bb
+++ b/recipes-opie/opie-ttf-support/opie-ttf-support_1.1.bb
@@ -10,6 +10,8 @@ S = "${WORKDIR}"
LIC_FILES_CHKSUM = "file://update-qtttffontdir.c;beginline=4;endline=7;md5=84d4335f8f9e85774e2a15b2dff91401"
+inherit palmtop-defs
+
# Seems to break linking
ASNEEDED = ""
diff --git a/recipes-qtopia/frodo/frodo_4.1b.bb b/recipes-qtopia/frodo/frodo_4.1b.bb
index daf2d51..870aa34 100644
--- a/recipes-qtopia/frodo/frodo_4.1b.bb
+++ b/recipes-qtopia/frodo/frodo_4.1b.bb
@@ -12,7 +12,7 @@ SRC_URI = "http://frodo.cebix.net/downloads/FrodoV4_1b.Src.tar.gz \
file://frodo.desktop"
S = "${WORKDIR}/Frodo-${PV}/Src"
-inherit autotools
+inherit autotools palmtop-defs
EXTRA_OECONF = "--disable-sdltest --enable-qtopia"
diff --git a/recipes-qtopia/frodo/frodo_4.2.bb b/recipes-qtopia/frodo/frodo_4.2.bb
index ec4e041..804b0c5 100644
--- a/recipes-qtopia/frodo/frodo_4.2.bb
+++ b/recipes-qtopia/frodo/frodo_4.2.bb
@@ -13,7 +13,7 @@ SRC_URI = "cvs://anoncvs:anoncvs@cvs.cebix.net/home/cvs/cebix;module=Frodo4 \
S = "${WORKDIR}/Frodo4/Src"
-inherit autotools
+inherit autotools palmtop-defs
EXTRA_OECONF = "--disable-sdltest --enable-qtopia"
diff --git a/recipes-qtopia/konqueror/konqueror-embedded_20030705.bb b/recipes-qtopia/konqueror/konqueror-embedded_20030705.bb
index b98791b..aec037e 100644
--- a/recipes-qtopia/konqueror/konqueror-embedded_20030705.bb
+++ b/recipes-qtopia/konqueror/konqueror-embedded_20030705.bb
@@ -23,7 +23,7 @@ SRC_URI = "http://devel-home.kde.org/~hausmann/snapshots/Attic/konqueror-embedde
file://konq-embedrc"
S = "${WORKDIR}/konqueror-embedded-snapshot-${PV}"
-inherit autotools
+inherit autotools palmtop-defs
FILES_${PN} = "${palmtopdir}"
diff --git a/recipes-qtopia/konqueror/konqueror-embedded_20060404.bb b/recipes-qtopia/konqueror/konqueror-embedded_20060404.bb
index a4ea55a..f64b93f 100644
--- a/recipes-qtopia/konqueror/konqueror-embedded_20060404.bb
+++ b/recipes-qtopia/konqueror/konqueror-embedded_20060404.bb
@@ -7,7 +7,7 @@ PR = "r3"
# this Konqueror needs the KDEDIR set and the font helvetica installed on the target
-inherit autotools
+inherit autotools palmtop-defs
SRC_URI = "svn://anonsvn.kde.org/home/kde/tags/KDE/3.5.1;module=kdelibs;date=${PV} \
svn://anonsvn.kde.org/home/kde/trunk;module=kdenox;date=${PV} \
diff --git a/recipes-qtopia/konqueror/konqueror-embedded_20070316.bb b/recipes-qtopia/konqueror/konqueror-embedded_20070316.bb
index fd9abda..69824c2 100644
--- a/recipes-qtopia/konqueror/konqueror-embedded_20070316.bb
+++ b/recipes-qtopia/konqueror/konqueror-embedded_20070316.bb
@@ -7,7 +7,7 @@ PR = "r7"
# this Konqueror needs the KDEDIR set and the font helvetica installed on the target
-inherit autotools
+inherit autotools palmtop-defs
SRC_URI = "http://www.basyskom.de/uploads/175/37/kdenox_snapshot_qt2_20070316.tar.bz2 \
file://dont-use-kde-config.patch \
diff --git a/recipes-qtopia/phalanx/phalanx_22.bb b/recipes-qtopia/phalanx/phalanx_22.bb
index 1f41511..77c18b8 100644
--- a/recipes-qtopia/phalanx/phalanx_22.bb
+++ b/recipes-qtopia/phalanx/phalanx_22.bb
@@ -10,6 +10,8 @@ S = "${WORKDIR}/Phalanx-XXII/"
LIC_FILES_CHKSUM = "file://COPYING;md5=33994abd59dbf0ac2baa657e9f174dae \
file://README;beginline=5;endline=18;md5=4c61e95ba5157e3e35319745fbb3fb3d"
+inherit palmtop-defs
+
do_compile() {
oe_runmake CC="${CC}" CFLAGS="${CFLAGS}" STRIP=echo LD="${CC}"
}
diff --git a/recipes-qtopia/poboxserver/poboxserver_1.2.5.bb b/recipes-qtopia/poboxserver/poboxserver_1.2.5.bb
index 2a6305e..02aa6d2 100644
--- a/recipes-qtopia/poboxserver/poboxserver_1.2.5.bb
+++ b/recipes-qtopia/poboxserver/poboxserver_1.2.5.bb
@@ -13,7 +13,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/gakusei/pobox-${PV}.tar.bz2;name=archive \
S = "${WORKDIR}/OpenPOBox"
-inherit autotools update-rc.d
+inherit autotools update-rc.d palmtop-defs
INITSCRIPT_NAME = "pbserver"
INITSCRIPT_PARAMS = "start 99 5 . stop 01 0 ."
diff --git a/recipes-qtopia/prboom/prboom-opie_2.2.6.bb b/recipes-qtopia/prboom/prboom-opie_2.2.6.bb
index 6acd997..bf1fd25 100644
--- a/recipes-qtopia/prboom/prboom-opie_2.2.6.bb
+++ b/recipes-qtopia/prboom/prboom-opie_2.2.6.bb
@@ -8,7 +8,7 @@ SRC_URI_append = " file://prboom.png \
file://prboom.desktop \
file://prboom.sh "
-
+inherit palmtop-defs
do_install_append() {
install -d ${D}${palmtopdir}/apps/Games \
diff --git a/recipes-qtopia/prboom/prboom_2.3.1.bb b/recipes-qtopia/prboom/prboom_2.3.1.bb
index daea8d4..7bf5896 100644
--- a/recipes-qtopia/prboom/prboom_2.3.1.bb
+++ b/recipes-qtopia/prboom/prboom_2.3.1.bb
@@ -12,7 +12,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/prboom/prboom-${PV}.tar.gz \
file://prboom.png \
file://prboom.desktop"
-inherit autotools
+inherit autotools palmtop-defs
EXTRA_OECONF = "--without-x --disable-sdltest"
diff --git a/recipes-qtopia/qpf-fonts/qpf.inc b/recipes-qtopia/qpf-fonts/qpf.inc
index c2ff3c1..7fcb5a0 100644
--- a/recipes-qtopia/qpf-fonts/qpf.inc
+++ b/recipes-qtopia/qpf-fonts/qpf.inc
@@ -1,3 +1,5 @@
+inherit palmtop-defs
+
RDEPENDS_${PN} = "font-update-common qpf-font-common"
do_configure() {
diff --git a/recipes-qtopia/snes9x/snes9x-sdl-qpe_1.39.bb b/recipes-qtopia/snes9x/snes9x-sdl-qpe_1.39.bb
index b041faf..c5c1d08 100644
--- a/recipes-qtopia/snes9x/snes9x-sdl-qpe_1.39.bb
+++ b/recipes-qtopia/snes9x/snes9x-sdl-qpe_1.39.bb
@@ -10,7 +10,7 @@ S = "${WORKDIR}/snes9x-sdl-${PV}"
FILESPATHPKG .= ":snes9x-sdl"
-inherit qmake_base
+inherit qmake_base palmtop-defs
QT_LIBRARY = '${@base_conditional("PALMTOP_USE_MULTITHREADED_QT", "yes", "qte-mt", "qte",d)}'
diff --git a/recipes-qtopia/tickypip/tickypip-levels_1.1.bb b/recipes-qtopia/tickypip/tickypip-levels_1.1.bb
index f49fd04..4fa937b 100644
--- a/recipes-qtopia/tickypip/tickypip-levels_1.1.bb
+++ b/recipes-qtopia/tickypip/tickypip-levels_1.1.bb
@@ -11,6 +11,8 @@ SRC_URI = "http://www.openzaurus.org/download/3.5.4/sources/tickypip-levels_${PV
S = "${WORKDIR}/"
+inherit palmtop-defs
+
#
# Authors response to LICENSE question:
#
diff --git a/recipes-qtopia/xqtlauncher/xqtlauncher.bb b/recipes-qtopia/xqtlauncher/xqtlauncher.bb
index b4203d4..2458b03 100644
--- a/recipes-qtopia/xqtlauncher/xqtlauncher.bb
+++ b/recipes-qtopia/xqtlauncher/xqtlauncher.bb
@@ -14,6 +14,8 @@ SRC_URI = "file://dot.directory \
file://cleanup.desktop \
file://xqtlauncher "
+inherit palmtop-defs
+
do_install() {
cd ${WORKDIR}
install -d ${D}${bindir}