aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-01-03 00:35:37 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-01-03 00:36:45 +0000
commita386abbcdcc1920d7de896d5b1dc29faca230b83 (patch)
treee8fac6a2724c9ace136d0d98085c9691fa86bbd3
parent4618b40a6a7b2302faecc57906d677a9602c00b1 (diff)
downloadmeta-opie-a386abbcdcc1920d7de896d5b1dc29faca230b83.tar.gz
task-opie: split out old networksettings into its own task package
Add task-opie-network-lite to bring in old networksettings application and associated plugins as appropriate (in preparation for adding the connman equivalent.) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
-rw-r--r--recipes-opie/images/jlime-opie.bb3
-rw-r--r--recipes-opie/images/opie-image.bb2
-rw-r--r--recipes-opie/meta/meta-opie.bb3
-rw-r--r--recipes-opie/tasks/task-opie.bb15
4 files changed, 13 insertions, 10 deletions
diff --git a/recipes-opie/images/jlime-opie.bb b/recipes-opie/images/jlime-opie.bb
index 816e8f9..b61e12b 100644
--- a/recipes-opie/images/jlime-opie.bb
+++ b/recipes-opie/images/jlime-opie.bb
@@ -1,4 +1,3 @@
-PR = "r1"
IMAGE_LINGUAS = ""
DEPENDS = "task-base task-opie"
@@ -9,7 +8,7 @@ IMAGE_INSTALL = "task-base task-opie-base task-opie-base-applets \
task-opie-base-inputmethods task-opie-base-apps \
task-opie-base-settings task-opie-base-decorations \
task-opie-base-styles task-opie-base-pim \
- task-opie-extra-settings \
+ task-opie-extra-settings task-opie-base-network-lite \
task-opie-bluetooth task-opie-irda \
${extra_stuff}"
diff --git a/recipes-opie/images/opie-image.bb b/recipes-opie/images/opie-image.bb
index dd654c1..a7ac527 100644
--- a/recipes-opie/images/opie-image.bb
+++ b/recipes-opie/images/opie-image.bb
@@ -11,7 +11,7 @@ IMAGE_INSTALL = "task-core-boot ${ROOTFS_PKGMANAGE} task-opie-base task-opie-bas
task-opie-base-inputmethods task-opie-base-apps \
task-opie-base-settings task-opie-base-decorations \
task-opie-base-styles task-opie-base-pim \
- task-opie-extra-settings \
+ task-opie-extra-settings task-opie-base-network-lite \
${@base_contains("COMBINED_FEATURES", "bluetooth", "task-opie-bluetooth", "",d)} \
${@base_contains("COMBINED_FEATURES", "irda", "task-opie-irda", "",d)} \
${ANGSTROM_EXTRA_INSTALL} "
diff --git a/recipes-opie/meta/meta-opie.bb b/recipes-opie/meta/meta-opie.bb
index 1584765..6905d45 100644
--- a/recipes-opie/meta/meta-opie.bb
+++ b/recipes-opie/meta/meta-opie.bb
@@ -15,6 +15,7 @@ RDEPENDS_${PN} = "task-opie-applets task-opie-apps task-opie-base \
${@base_contains("COMBINED_FEATURES", "irda", "task-opie-irda", "",d)} \
task-opie-games task-opie-inputmethods \
task-opie-multimedia task-opie-pim task-opie-settings \
- task-opie-styles task-opie-todayplugins task-opie-wlan"
+ task-opie-styles task-opie-todayplugins task-opie-wlan \
+ task-opie-base-network-lite"
inherit meta
diff --git a/recipes-opie/tasks/task-opie.bb b/recipes-opie/tasks/task-opie.bb
index 64e6492..d5e3e9d 100644
--- a/recipes-opie/tasks/task-opie.bb
+++ b/recipes-opie/tasks/task-opie.bb
@@ -3,7 +3,7 @@ SECTION = "opie/base"
LICENSE = "MIT"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-PR = "r16"
+PR = "r17"
inherit task
@@ -16,6 +16,7 @@ PACKAGES = "task-opie-base \
task-opie-base-decorations task-opie-base-inputmethods \
task-opie-base-pim task-opie-base-settings \
task-opie-base-styles task-opie-base-todayplugins \
+ task-opie-base-network-lite \
task-opie-extra-settings \
task-opie-extra-styles \
${@base_contains("COMBINED_FEATURES", "bluetooth", "task-opie-bluetooth", "",d)} \
@@ -63,17 +64,19 @@ RDEPENDS_task-opie-base-apps = "opie-console opie-clock opie-citytime opie-backu
opie-advancedfm opie-textedit"
RDEPENDS_task-opie-base-settings = "opie-packagemanager opie-light-and-power opie-appearance \
- opie-systemtime opie-networksettings opie-button-settings \
+ opie-systemtime opie-button-settings \
opie-icon-reload opie-launcher-settings opie-security \
opie-securityplugin-pin"
+RDEPENDS_task-opie-base-network-lite = "opie-networksettings \
+ ${@base_contains("DISTRO_FEATURES", "wifi", "opie-networksettings-wlanplugin", "",d)} \
+ ${@base_contains("DISTRO_FEATURES", "ppp", "opie-networksettings-pppplugin", "",d)} \
+ "
+
#
# That settings can be removed and device will be still usable
#
-RDEPENDS_task-opie-extra-settings = "opie-language opie-doctab opie-mediummount \
- ${@base_contains("DISTRO_FEATURES", "wifi", "opie-networksettings-wlanplugin", "",d)} \
- ${@base_contains("DISTRO_FEATURES", "ppp", "opie-networksettings-pppplugin", "",d)} \
- "
+RDEPENDS_task-opie-extra-settings = "opie-language opie-doctab opie-mediummount"
RDEPENDS_task-opie-base-decorations = "opie-deco-flat opie-deco-liquid opie-deco-polished"