aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb')
-rw-r--r--meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb23
1 files changed, 21 insertions, 2 deletions
diff --git a/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb b/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb
index d83901ff3a..a801920c09 100644
--- a/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb
+++ b/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb
@@ -1,8 +1,27 @@
-require python-pyparted.inc
+DESCRIPTION = "pyparted is a set of Python modules that provide Python programmers \
+an interface to libparted, the GNU parted library for disk partitioning and \
+filesystem manipulation."
+SUMMARY = "Python bindings for libparted"
+HOMEPAGE = "https://github.com/rhinstaller/pyparted"
+LICENSE = "GPL-2.0+"
+LIC_FILES_CHKSUM = "\
+ file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
+ file://src/_pedmodule.c;beginline=10;endline=22;md5=9e53304db812b80d0939e11bb69dcab2 \
+"
+DEPENDS += "parted"
+
+# upstream only publishes releases in github archives which are discouraged
+SRCREV = "481510c10866851844b19f3d2ffcdaa37efc0cf8"
+SRC_URI = "git://github.com/rhinstaller/pyparted.git;protocol=https"
inherit distutils3
-RDEPENDS_${PN} += "python3-stringold python3-codecs python3-math"
+S = "${WORKDIR}/git"
+
+RDEPENDS_${PN}_class-target += " \
+ parted (>= 2.3) \
+ python3-stringold python3-codecs python3-math \
+"
RDEPENDS_${PN}_class-native = ""
BBCLASSEXTEND = "native"