aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-watchdog_0.10.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-watchdog_0.10.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-watchdog_0.10.3.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-watchdog_0.10.3.bb b/meta-python/recipes-devtools/python/python3-watchdog_0.10.3.bb
new file mode 100644
index 0000000000..2108cbb93b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-watchdog_0.10.3.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Filesystem events monitoring"
+DEPENDS = "${PYTHON_PN}-argh"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI[md5sum] = "9a5c9134e943b534b9f8b51d78338cf8"
+SRC_URI[sha256sum] = "4214e1379d128b0588021880ccaf40317ee156d4603ac388b9adcf29165e0c04"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} = " \
+ ${PYTHON_PN}-argh \
+ ${PYTHON_PN}-pathtools3 \
+ ${PYTHON_PN}-pyyaml \
+ ${PYTHON_PN}-requests \
+"
+
+BBCLASSEXTEND = "native nativesdk"