aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-u-msgpack-python_2.6.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-u-msgpack-python_2.6.0.bb14
1 files changed, 13 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.6.0.bb b/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.6.0.bb
index 6d2e0e0c32..f3f321e184 100644
--- a/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.6.0.bb
+++ b/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.6.0.bb
@@ -5,7 +5,19 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=9eb4691bcb66360acee473a8cf75f594"
SRC_URI[sha256sum] = "754edb07eaee39a9686a99823892e3a1be4e0948d9cc5c717946750c27643c9c"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ cp -f ${S}/test_umsgpack.py ${D}${PTEST_PATH}/
+}
RDEPENDS_${PN} += " \
${PYTHON_PN}-datetime \